Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 30-12-2015, 10:16   #646
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta test 4.1.1108 Release

...another one(raster) with a concurrent log
Click image for larger version

Name:	anotherScreengrabGL-OFF.jpg
Views:	47
Size:	107.2 KB
ID:	115873
opencpn.log.doc

apparently I need the gshh map.maybe that's it.

PS able to use my own Mark/wpt icons again, by changing "permissions". Operator error I guess, in the copying of them across partitions?(sigh)
__________________

__________________
HappySeagull is offline   Reply With Quote
Old 30-12-2015, 11:10   #647
Registered User
 
HappySeagull's Avatar

Join Date: Dec 2010
Location: B.C.,Canada
Boat: 29'
Posts: 2,395
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Originally Posted by did-g View Post
Are you using a compositing window manager?
I believe "Cinnamon" is the right answer? ... in any case. I have not changed from the default,
__________________

__________________
HappySeagull is offline   Reply With Quote
Old 30-12-2015, 12:10   #648
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta test 4.1.1108 Release

Rick/Hakan...

re:
Code:
Zooming in and out as far as possible.
Result:
Memory from start: ~300 MB
- Zoom in/out at a location I've been before: no mem change
- In/out in a location not visited before: mem. increase ~100 MB
- Repeated in a new location: mem. increase ~100 MB 

For every new location around 100 MB increased mem. usage, some spinning  mouse and one black screen occurrence for a couple of seconds.
The O memory usage is now more than 1 GB and it's not released!
After some poking around on my available hardware, I see very little difference in performance or behaviour of this 4.1 Beta versus O4 Release. cm93 objects are accumulated in memory as you pan and zoom, and are not released until the entire cm93 chart is dismissed.

Chart outlines exacerbate the issue, in that there are even more cm93 cells loaded to calculate the cell outlines dynamically.

We could, I suppose, add code to periodically "garbage-collect" the cm93 object tables under high memory stress conditions. We would discard objects/geo areas that have not been visited lately. This would slow things down, somewhat, but allow memory recovery if desired.

I think this is not a great idea. O tries to use the linux model of memory management, which is simply: "empty memory is wasted memory".

Further, I'm becoming more convinced that Windows OpenGL drivers for Intel hardware, while better these days, are still not up to the standard of dedicated solutions like nVidia. It seems that the GPU shares a lot of resources with the CPU, and there are concurrency issues which lead to occasional "black screen".

I added a tentative patch to github master which should eliminate "black screen" effects on MSW, and I'd like to see this verified, and see that it does not impact GUI performance significantly.

So I think we are where we are for O4.2. Normal navigational use cases work fine, and high memory stress cases with dodgy OpenGL drivers are a bit flakey.


I also fixed the Journeyman style PlugIn icon rendering problems.

Thanks
Dave
__________________
bdbcat is online now   Reply With Quote
Old 30-12-2015, 13:00   #649
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,967
Re: OpenCPN Beta test 4.1.1108 Release

Dave..
Maybe apart from the spinning mouse and the occasionally black screen I don't either think this is new. And we should not solve this payed with daily use slowness. What we are doing here to stress this memory build is a like desktop planning. We never use charts in this way while sailing, do we.

I'll check your patch for this and the icons as well.

Thanks
Håkan
__________________
Hakan is offline   Reply With Quote
Old 30-12-2015, 13:29   #650
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,967
Re: OpenCPN Beta test 4.1.1108 Release

Dave..
It may be that the little glFinish(); helped!
I've tried to stress like before. Some spinning mouse, of course, but no black screen, and it may be the memory build up is not more then half of what experienced yesterday.
But no files built in \CM93. As normal??
Case closed??

Journeyman icons are very fine, great.

Thanks
Håkan

Edit:
Three files showed up in\CM93 after some 20 minutes?? - OK??
__________________
Hakan is offline   Reply With Quote
Old 30-12-2015, 13:29   #651
Registered User

Join Date: Jul 2015
Location: Plano, Texas
Posts: 68
Re: OpenCPN Beta test 4.1.1108 Release

Hi Paval,

I deleted the entire cmake directory. Verified that I could still rebuild the non-svg build and every thing worked. Deleted the cmake directory again and build the svg version. Still get the error about zlib1.dll. Copied zlib1.dll to the opencpn exectuable directory (x86} Program Files\OpenCPN and the program runs. However, the menu bar looks exactly the same, so I am wondering if there is something else going on. I took the strategy of renaming buildwin to buildwin-nosvg and created a new buildwin directory using the files you posted in your 7z plus the other files that had to be copied as I mentioned earlier. Shoud the menu bar look different? This is on a W10, i5 system running a moderately decent ATI graphics card and OpenGL. I will be glad to do any testing you need to help sort this out. As I mentioned earlier, there is not SVG sub-directory in the OpenCPN\Data path, so I would think I don't have the new icons. I did not see them posted seperately. Should I have them and is so, where do I get them?

Thanks in advance,
Doug
__________________
dwoodall is offline   Reply With Quote
Old 30-12-2015, 13:48   #652
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 1,967
Re: OpenCPN Beta test 4.1.1108 Release

Douge...
On Win10 and VS2013
The build works for me but I build also the Package project, "build only package", and use that installation file to update OCPN. Than all new files are copied to the running directory.
Håkan
__________________
Hakan is offline   Reply With Quote
Old 30-12-2015, 13:54   #653
Registered User

Join Date: Feb 2011
Posts: 490
Re: OpenCPN Beta test 4.1.1108 Release

When do you expect the fully working with install for Windows?
Happy New Year 2016 and thanks for the works.
Regards
__________________
P_Dub is offline   Reply With Quote
Old 30-12-2015, 14:10   #654
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,019
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Originally Posted by dwoodall View Post
Hi Paval,

I deleted the entire cmake directory. Verified that I could still rebuild the non-svg build and every thing worked. Deleted the cmake directory again and build the svg version. Still get the error about zlib1.dll. Copied zlib1.dll to the opencpn exectuable directory (x86} Program Files\OpenCPN and the program runs. However, the menu bar looks exactly the same, so I am wondering if there is something else going on. I took the strategy of renaming buildwin to buildwin-nosvg and created a new buildwin directory using the files you posted in your 7z plus the other files that had to be copied as I mentioned earlier.
You should not need to copy anything anywhere manually, just extract the new dependency archive over source tree (See https://github.com/OpenCPN/OpenCPN/b...ter/Curl.cmake for reference as to what we include in the package - if libcurl.dll gets included in your setup package, zlib1.dll must be included as well, there simply is no difference). It is also very weird that you need the ssl libraries, as the new curl build simply is not linked against them at all. The only cause I can think of really is that you have some 3rd party plugin still using curl instead of our download methods in the source tree, are you sure it is not the case?
Quote:
Shoud the menu bar look different?
Yes, it should, the most visible change is that the "active" icons, like show ENC text or follow ship should now have a green background when switched on.
Quote:
This is on a W10, i5 system running a moderately decent ATI graphics card and OpenGL. I will be glad to do any testing you need to help sort this out.
The HW should not matter, once we render the SVG when the icon is first needed, it is a normal bitmap as the old icons were.
Quote:
As I mentioned earlier, there is not SVG sub-directory in the OpenCPN\Data path, so I would think I don't have the new icons. I did not see them posted separately. Should I have them and is so, where do I get them?
Yes, you definitely should have them in your source tree (https://github.com/OpenCPN/OpenCPN/t...vg/traditional)
In the installed program, they will be in ?:\Program Files\OpenCPN\data\uidata\traditional (if not found there, we fall back to the old bitmap icons) - https://github.com/OpenCPN/OpenCPN/b...ists.txt#L1745

Pavel
__________________
nohal is offline   Reply With Quote
Old 30-12-2015, 15:23   #655
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,407
Re: OpenCPN Beta test 4.1.1108 Release

@HSeagull. That looks like memory stutter, ...whatever that is.

Dave,

While on the plane I cleaned up computer, updated it, optimized disk, ran System Mechanic to optimize memory and repair windows, etc.

Started Opencpn with OpenGL=on ChartOutline=off using CM93 charts.

First screenshot was near the start.
1. Start: O-Mem=290mb TotMem=68%
2. Pan-Zoom: O-Mem=687mb TotMem=76%
3. Wait: o-Mem=438mb TotMem=74% -Memory down
4. Not Resp: o-Mem=557mb TotMem=77% Closed
5. Start Again: o-mem=289mb totmem=47%
6. o-mem=1288mb
7. o-mem=1504mb
8. o-mem=1578mb
9. o-mem=1578mb
10. o-mem=1580-screen
11. o-mem=1580-ocpn-NoToolbar-grey <--totally bogged down, slow
12. o-mem=1580mb-63percent-greytoolbar
13. Options-Also-Minimized-OpenCPN and something re: Memory use
14. o-mem=1411mb-down-chartstuck-grey-toolbar
15. o-mem=57percent
16. o-mem=56percent
17. o-mem=0-percent-suddenly
18. still-toolbar-grey
19. clicktoShowIcons
20. clicktoShowMoreIcon

Somewhere around 13 it got pretty stuck. I was able to move the Toolbar, grey space. Could click on a spot on the toolbar to get the icon underneath to show. Could do this with additional icons. Was able to open Options. Charts were stalled and would not work.

At number "13.Options-Also-Minimized-OpenCPN and something re: Memory use." I shrank OpenCPN because it was stuck anyway with memory issues, and I wanted to see what would happen. At the time the Toolbar was grey with not icons, I could click on the toolbar and get the icon to show and could do that multiple times. The charts would not work nor could I pan. When I shrank or minimized OpenCPN to a partial window, the Opencpn memory use started going Down and it hit 0 quite quickly.

I was not done yet. I maxmized the program again to see if charts would start working, they did not, nor could I pan or zoom. The toolbar was still grey, but I could move it around.

I had to Terminate the Program with TaskManager. Would not close.

After running OpenCPON with Opengl=on and ChartOutline=off (above),
I ran System Mechanic PC Total Care and it recovered 239mb of fragmented memory.
I had run System Mechanicm prior to doing the test so the memory was completely cleaned then. Have no idea how this impacts Opencpn

The Screenshots 1-21 are uploaded and on

OpenCPN Beta File Thingie rguser rgpass
Look under TESTS-opengl-chart-outlines directory please.
You can download them if you want, I did not want to compress them.
__________________
rgleason is offline   Reply With Quote
Old 30-12-2015, 15:47   #656
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 4,028
Re: OpenCPN Beta test 4.1.1108 Release

When I had the issue of zlib1.dll reported as missing I found I was building a "hybrid" of some old and some new project files. I cloned everything cleanly from git and it all built without errors or missing dlls. So if you have missing dlls then I think try building with a completely virgin git clone.
__________________
transmitterdan is offline   Reply With Quote
Old 30-12-2015, 16:52   #657
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta test 4.1.1108 Release

Hakan...

re:
Edit:
Three files showed up in\CM93 after some 20 minutes?? - OK??

The new cached cell outline helper files only show up when OCPN is closed down.

Dave
__________________
bdbcat is online now   Reply With Quote
Old 30-12-2015, 17:21   #658
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,407
Re: OpenCPN Beta test 4.1.1108 Release

Pavel,

Quote:
You should not need to copy anything anywhere manually, just extract the new dependency archive over source tree (See https://github.com/OpenCPN/OpenCPN/b...ter/Curl.cmake for reference as to what we include in the package - if libcurl.dll gets included in your setup package, zlib1.dll must be included as well, there simply is no difference).
This may have changed recently, but several days ago I did have to copy the following:

Quote:
Under my git directory for Opencpn
Renamed buildwin to buildwin-old
Unpacked the OpenCPN_buildwin-svg.7z to the Git Opencpn directory creating a new buildwin.
Tried to compile and found errors related to NSIS so I copied the NSIS directory from buildwin-old into buildwin
Tried to compile and found more errors related to
crashrpt.h so I copied that and
crashrpt.lang.ini and
privacypolicy.txt
from buildwin-old/crashrpt to the buildwin/crashrpt directory.
Then I was able to compile it completely and run cpack
__________________
rgleason is offline   Reply With Quote
Old 30-12-2015, 17:40   #659
Registered User

Join Date: Mar 2010
Location: Wandering around North America
Boat: Defever 43 - Gray Hawk
Posts: 602
Re: OpenCPN Beta test 4.1.1108 Release

Quote:
Originally Posted by rgleason View Post
Again,
Nobody has a problem with current beta when
ON = Show Chart Outlines
with Opengl=ON and Texture Cache=ON?
With OpenGL ON and Texture Cache ON I get an immediate crash to the desktop. With OpenGL ON and Texture Cache OFF I get a hung system but its not necessarily immediate. It happens "promptly" but I may get a chance to scroll once or zoom one level.
__________________
R.J.(Bob) Evans
M/V Gray Hawk, 43 Defever Offshore Cruiser
http://www.bobandmarilyn.ca
bobofthenorth is offline   Reply With Quote
Old 30-12-2015, 18:03   #660
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OpenCPN Beta test 4.1.1108 Release

Bob...

Back to your BSB4 issue, buried but not forgotten.

Using 4.1.1108 (current Beta)...
When you crash with OpenGL=ON, Compression=ON, do you get a standard OCPN crash report dialog? Or just a crash back to blank desk?

Thanks
Dave
__________________

__________________
bdbcat is online now   Reply With Quote
Reply

Tags
enc, lease, opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Beta test 4.1.1022 Release bdbcat OpenCPN 122 07-11-2015 02:12
OpenCPN Beta test 4.1.925 Release bdbcat OpenCPN 177 04-11-2015 09:16
OpenCPN Beta test 4.1.602 Release bdbcat OpenCPN 193 13-10-2015 09:19
OpenCPN Version 2.2 Beta Test bdbcat OpenCPN 437 15-12-2010 20:17
OpenCPN Version 2.2 Beta Test Bugs / Discussion bdbcat OpenCPN 120 26-09-2010 03:53



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 19:52.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.