Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 17-02-2020, 18:26   #1
Registered User

Join Date: May 2018
Location: Santa Barbara CA/Pompano Beach FL
Boat: Leopard 46 Owners
Posts: 14
Generator only runs when glow plug is activated

My Northern lights generator was running fine for an hour or so then cut out.
It re-started fine, but when I release the glow plug rocker it cuts out again. Seems to run fine if I hold the glow plug rocker, but the second I release it, it stops.

Any ideas on where to begin the trouble shooting?
__________________

SailSB is offline   Reply With Quote
Old 17-02-2020, 18:39   #2
Registered User

Join Date: Feb 2010
Posts: 455
Re: Generator only runs when glow plug is activated

Quote:
Originally Posted by SailSB View Post
My Northern lights generator was running fine for an hour or so then cut out.

It re-started fine, but when I release the glow plug rocker it cuts out again. Seems to run fine if I hold the glow plug rocker, but the second I release it, it stops.



Any ideas on where to begin the trouble shooting?


It sounds like the shutdown circuit is activated and being overridden by the glow/ override. First check the oil and coolant levels. If they are ok check the temp sender on the exhaust mixer elbow. If you canít find an actual fault ie no oil, an overheat or no raw flow then consider starting the sender testing routine until you find the culprit. Does your control panel have gauges on it?
Pete.
__________________

skipperpete is offline   Reply With Quote
Old 17-02-2020, 19:22   #3
Registered User

Join Date: Dec 2010
Location: W Carib
Boat: Wildcat 35, Hobie 33
Posts: 11,975
Re: Generator only runs when glow plug is activated

Quote:
Originally Posted by skipperpete View Post
It sounds like the shutdown circuit is activated and being overridden by the glow/ override. First check the oil and coolant levels. If they are ok check the temp sender on the exhaust mixer elbow. If you canít find an actual fault ie no oil, an overheat or no raw flow then consider starting the sender testing routine until you find the culprit. Does your control panel have gauges on it?
Pete.
...also check relays...very commonly the cause of such problems. Or, just swap them all for new and see if that resolves it. A few bucks at any auto parts store.
belizesailor is offline   Reply With Quote
Old 17-02-2020, 19:23   #4
Registered User

Join Date: May 2018
Location: Santa Barbara CA/Pompano Beach FL
Boat: Leopard 46 Owners
Posts: 14
Re: Generator only runs when glow plug is activated

Panel has gauges for power, but not for oil, water, or temp. Iíll check the basics in the morning. I think what you are suggesting makes a lot of sense. Hopefully it is something simple and shutting down for a good reason.

Thanks!

Ken
SailSB is offline   Reply With Quote
Old 17-02-2020, 19:48   #5
Senior Cruiser
 
tkeithlu's Avatar

Cruisers Forum Supporter

Join Date: Feb 2012
Location: Carrabelle, Florida
Boat: Fiberglas shattering 44' steel trawler
Posts: 1,761
Re: Generator only runs when glow plug is activated

I really don't see running an engine without oil pressure and water temperature gauges. They and their senders are cheap and available at any auto parts store. Even if you just mount them at the engine but where you can see them from time to time, they put you in a much better working relationship with your motor.

I bet Skipper Pete is right and you are running it by over-riding an automatic shutdown (such as oil pressure) by holding down the glow plug switch.
__________________
Never let anything mechanical know that you are in a hurry.
tkeithlu is offline   Reply With Quote
Old 17-02-2020, 19:57   #6
Elvish meaning 'Far-Wanderer'
 
Palarran's Avatar

Join Date: Jan 2008
Location: Boat - Bahamas - Me - Michigan
Boat: 56' Fountaine Pajot Marquises
Posts: 3,170
Re: Generator only runs when glow plug is activated

I had the same problem. Mine is a Northern Lights and has 4 Bosch relays in the control panel. I took out the first one, moved the second to the first, third to second, etc and the unit ran. As soon as I could purchase a replacement relay I reversed this and found it was the third relay that was bad.
__________________
Our course is set for an uncharted sea
Dante
Palarran is offline   Reply With Quote
Old 17-02-2020, 20:15   #7
Registered User
 
Dennis.G's Avatar

Join Date: May 2011
Location: Sea of Cortez and the U.P. of Michigan
Boat: Celestial 48
Posts: 893
Re: Generator only runs when glow plug is activated

Note that most glow plugs can be burnt out if energized for too long. Some get damaged in less that 20 seconds powered. Keep in mind when figuring out your generator issue.
Dennis.G is offline   Reply With Quote
Old 17-02-2020, 22:11   #8
Registered User

Join Date: Apr 2007
Location: Australia
Boat: Island Packet 40
Posts: 3,357
Images: 7
Re: Generator only runs when glow plug is activated

A circuit diagram to see what's connected to what is generally a good start.
RaymondR is offline   Reply With Quote
Old 17-02-2020, 23:12   #9
Registered User

Join Date: Feb 2010
Posts: 455
Re: Generator only runs when glow plug is activated

Iím just guessing itís a NL 673 so hopefully this DC wiring diagram will help. YES , over glowing might indeed do harm to the glow plugs, good advice Dennis.G. Also overcranking with the raw water intake open can cause harm to your engine. After 5 attempts the NL wiring diagram failed to attach.
Iíll get back to you with the screen shot.
Pete.
skipperpete is offline   Reply With Quote
Old 17-02-2020, 23:22   #10
Registered User

Join Date: Feb 2010
Posts: 455
Re: Generator only runs when glow plug is activated

Click image for larger version

Name:	IMG_2363.jpg
Views:	101
Size:	369.2 KB
ID:	209019
skipperpete is offline   Reply With Quote
Old 18-02-2020, 05:17   #11
Registered User

Join Date: Dec 2010
Location: W Carib
Boat: Wildcat 35, Hobie 33
Posts: 11,975
Re: Generator only runs when glow plug is activated

Quote:
Originally Posted by Palarran View Post
I had the same problem. Mine is a Northern Lights and has 4 Bosch relays in the control panel. I took out the first one, moved the second to the first, third to second, etc and the unit ran. As soon as I could purchase a replacement relay I reversed this and found it was the third relay that was bad.
There ya go! Ive fixed a bunch of genset issues that way (used to run a lot of boats in charter with big gensets and fully aircon'ed...guests are not happy when the aircon is down!).

You can of course test the relays to find the bad one (sometimes, but intermittent malfunctions can be hard to find). I made up a little test rig for this purpose. Just keep a few spare relays aboard and swap when you have trouble. This is a very common issue so often that solves the problem.
belizesailor is offline   Reply With Quote
Old 18-02-2020, 05:24   #12
Moderator
 
a64pilot's Avatar

Cruisers Forum Supporter

Join Date: Oct 2013
Location: Albany Ga.
Boat: Island Packet 38
Posts: 29,114
Re: Generator only runs when glow plug is activated

If it’s not a relay then I would suspect a low oil pressure switch, I believe it’s common to override that switch when the glow plugs are on, the reason is to allow oil pressure to build before the switch is put into the circuit.
a64pilot is offline   Reply With Quote
Old 18-02-2020, 06:20   #13
Registered User
 
MV Wanderlust's Avatar

Join Date: May 2016
Location: Palmetto, FL
Boat: "Wanderlust" -- 1999 Jefferson Rivanna 52'
Posts: 834
Images: 28
Re: Generator only runs when glow plug is activated

Quote:
Originally Posted by a64pilot View Post
If itís not a relay then I would suspect a low oil pressure switch, I believe itís common to override that switch when the glow plugs are on, the reason is to allow oil pressure to build before the switch is put into the circuit.
Ours was doing the same thing as SailSB. Called Northern Lights and talked to one of their engineers. He said the preheat switch does, indeed, bypass the oil pressure and water temp switches to allow starting. He also said it was a common, known issue for the water temp switch to fail and cause this issue. We picked up a new water temp switch but never actually installed it.
By some experimenting, we found out that after starting the generator, if we toggle the preheat switch up and down a couple of times before releasing it, it starts and runs normally. Weird but true.
__________________
John and Deb Easley
John - USCG 50 ton Master
1999 Jefferson Rivanna 52' CPMY
MV Wanderlust is offline   Reply With Quote
Old 18-02-2020, 06:31   #14
Registered User
 
transmitterdan's Avatar

Join Date: Oct 2011
Boat: Valiant 42
Posts: 5,886
Re: Generator only runs when glow plug is activated

Quote:
Originally Posted by MV Wanderlust View Post
Ours was doing the same thing as SailSB. Called Northern Lights and talked to one of their engineers. He said the preheat switch does, indeed, bypass the oil pressure and water temp switches to allow starting. He also said it was a common, known issue for the water temp switch to fail and cause this issue. We picked up a new water temp switch but never actually installed it.
By some experimenting, we found out that after starting the generator, if we toggle the preheat switch up and down a couple of times before releasing it, it starts and runs normally. Weird but true.
Then almost certainly the problem is not the water temp switch. Most likely you have a relay with dirty contacts and toggling the preheat switch also toggles the faulty relay and it eventually makes contact. These relays are fairly garden variety so look them over and think about replacing one at a time. Eventually that faulty relay will fail completely and then it won't run at all.
transmitterdan is online now   Reply With Quote
Old 18-02-2020, 06:34   #15
Registered User
 
MV Wanderlust's Avatar

Join Date: May 2016
Location: Palmetto, FL
Boat: "Wanderlust" -- 1999 Jefferson Rivanna 52'
Posts: 834
Images: 28
Re: Generator only runs when glow plug is activated

Quote:
Originally Posted by transmitterdan View Post
Then almost certainly the problem is not the water temp switch. Most likely you have a relay with dirty contacts and toggling the preheat switch also toggles the faulty relay and it eventually makes contact. These relays are fairly garden variety so look them over and think about replacing one at a time. Eventually that faulty relay will fail completely and then it won't run at all.
Good to know. Are the relays on the back of the control panel (in our breaker panel) or are the on the board in the control box? The control box is in a corner of the engine room that is almost completely inaccessible, only about a six inch clearance from the ceiling and wedged between the fuel tank and a forward bulkhead.
__________________

MV Wanderlust is offline   Reply With Quote
Reply

Tags
generator, plug

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Glow Plug Installation michaelmrc Engines and Propulsion Systems 26 12-11-2017 04:37
Westerbeke Glow Plug Substitute Waterjack Engines and Propulsion Systems 13 05-04-2016 18:35
Glow plug for Universal M-35 taildragerdrive Monohull Sailboats 2 30-03-2011 12:22
Glow Plug Issues Firehoser75 Engines and Propulsion Systems 7 11-09-2008 19:15

Advertise Here


All times are GMT -7. The time now is 23:58.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.