Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 29-04-2016, 01:42   #31
Registered User

Join Date: Nov 2014
Location: Suffolk Yacht Harbour, UK
Boat: Jeanneau Sunfast 32
Posts: 28
Re: OPCPN not outputing autopilot sentences

Dear Rick,

OK, I'll do that in the next few days.

Stuart
__________________

__________________
StuartGunn is offline   Reply With Quote
Old 09-05-2016, 05:42   #32
Registered User

Join Date: Apr 2012
Location: Turkey, Greece
Boat: Moody 44
Posts: 108
Re: OPCPN not outputing autopilot sentences

Quote:
Originally Posted by StuartGunn View Post
Dear Rick,

OK, I'll do that in the next few days.

Stuart
Stuart Id also be keen to see your write up.
I am using the OpenPlotter OCPN Rpi image and struggled to get AP output (ECRMB etc) working.
With help, I now seem to have sorted it but Seatalk IN (using the NMEA/Seatalk converter) is next on the list so any pointers would be appreciated.

Rgds
Steve
__________________

__________________
affinite is offline   Reply With Quote
Old 09-05-2016, 06:36   #33
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: OPCPN not outputing autopilot sentences

Meanwhile read these links in the user manual
Route to Autopilot | Official OpenCPN Homepage
Connections | Official OpenCPN Homepage Read the bottom Sending an Active Route to Autopilot
Also http://opencpn.org/ocpn/options_connections

Also read about the Active Route Console Window down at the bottom.
http://opencpn.org/ocpn/toolbar_marks-and-routes


I am hoping Stuart will provide a writeup with contextual experience which also helps. We will be adding that to the Advanced Sending Route to Autopilot.
__________________
rgleason is online now   Reply With Quote
Old 12-05-2016, 13:15   #34
Registered User

Join Date: Nov 2014
Location: Suffolk Yacht Harbour, UK
Boat: Jeanneau Sunfast 32
Posts: 28
Re: OPCPN not outputing autopilot sentences

Dear All,

I have written a short description of what I have done (attached). I am unused to these fora but if this upload works then I will upload some photos.

I am no expert but I am willing to respond as best I can to any questions.

I am going away on a 2 to 3 week trip on Saturday so there will be a hiatus during that time.

Hope this reaches you.

Stuart
Attached Files
File Type: doc Chameleon Chartplotter.doc (25.5 KB, 57 views)
__________________
StuartGunn is offline   Reply With Quote
Old 12-05-2016, 13:55   #35
Registered User

Join Date: Nov 2014
Location: Suffolk Yacht Harbour, UK
Boat: Jeanneau Sunfast 32
Posts: 28
Re: OPCPN not outputing autopilot sentences

I am posting a few photos. I can provide more if anyone wants to see some detail.

Photo 1 the open wooden box with RPi inside, USB hub on top, SeaTalk translator behind
Photo 2 the power locker: 12v - 5 v converter with screen on the right wall, 12v dcdc with input and output voltages on the base
Photo 3 the Matsutec and HDMIPI on the chart table. For development I use a full size keyboard and mouse.
Photo 4 the back of the units

Stuart
Attached Thumbnails
Click image for larger version

Name:	CHAMTOO_1.jpg
Views:	217
Size:	414.4 KB
ID:	124203   Click image for larger version

Name:	CHAMTOO_2.jpg
Views:	213
Size:	261.4 KB
ID:	124204  

Click image for larger version

Name:	CHAMTOO_3.jpg
Views:	265
Size:	441.3 KB
ID:	124205   Click image for larger version

Name:	CHAMTOO_4.jpg
Views:	235
Size:	440.9 KB
ID:	124206  

__________________
StuartGunn is offline   Reply With Quote
Old 13-05-2016, 01:20   #36
Registered User

Join Date: Apr 2012
Location: Turkey, Greece
Boat: Moody 44
Posts: 108
Re: OPCPN not outputing autopilot sentences

Stuart
Thanks for the write up of your setup. It was the Seatalk data input which interested me but I think you are using NMEA wind instrument data and dont (currently) drive your Autopilot directly from OCPN ?

BTW - Have you looked at the OpenPlotter implementation of OCPN/Kplex?
It seems you have been working in parallel
__________________
affinite is offline   Reply With Quote
Old 13-05-2016, 01:58   #37
Registered User

Join Date: Nov 2014
Location: Suffolk Yacht Harbour, UK
Boat: Jeanneau Sunfast 32
Posts: 28
Re: OPCPN not outputing autopilot sentences

I am using a SeaTalk/ nmea bridge to bring data from Raymarine Tridata into KPLEX and to export autopilot data to the Raymarine Graphic Display. The display shows COG, bearing and distance to waypoint etc. as well as wind info from the nmea wind sensor. I can easily connect the same nmea or SeaTalk data stream to the autopilot.

There is a Raymarine translator available but I have used one from gadgetpool.de. The unit works well and can be programmed to filter messages so that only required sentences are passed each way. The unit outputs on a serial line and I use a serial/usb converter to connect to the multiplexer.

This is the unit currently available:
gadgetPool.de - !!!! Tiny USB SeaTalk NMEA Link
and the shop page:
gadgetPool.de

When I bought there wasn't an integrated usb connection. The serial unit is priced at 100 Euro and the usb at 125 Euro.

I recently heard about openplotter and it seemed that it would be exactly what I need. I have tried testing it at home but so far without good results.

Stuart
__________________
StuartGunn is offline   Reply With Quote
Old 13-05-2016, 03:47   #38
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: OPCPN not outputing autopilot sentences

Stuart, I us gadgetpool.de bidirectional seatalk link too.

When I get a moment I'll put your writeup in the user manual. Thankyou! I like your setup.
__________________
rgleason is online now   Reply With Quote
Old 13-05-2016, 07:00   #39
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: OPCPN not outputing autopilot sentences

@StuartGunn
Your writeup is more focused on software and equipment configuration (RPI), rather than Autopilot configuration. I think it would be more appropriate to have this article with some photos as you have attached, under
Low Power Devices | Official OpenCPN Homepage under Raspberry_pi.
don't you?
__________________
rgleason is online now   Reply With Quote
Old 13-05-2016, 07:39   #40
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 9,421
Re: OPCPN not outputing autopilot sentences

User Manual Changes re Route to Autopilot documentation
Route to Autopilot | Official OpenCPN Homepage
Connections | Official OpenCPN Homepage
Marks and Routes | Official OpenCPN Homepage

Basically adding links to relevant portions of the User Manual for convenience.
__________________
rgleason is online now   Reply With Quote
Old 13-05-2016, 08:31   #41
Registered User

Join Date: Nov 2014
Location: Suffolk Yacht Harbour, UK
Boat: Jeanneau Sunfast 32
Posts: 28
Re: OPCPN not outputing autopilot sentences

Rick,
My original request was for help with getting autopilot messages out of OpenCPN. The short answer was that the bug that disabled the nmea monitoring window was the reason for all my confusion. I have not addressed that in my note but the note really just provides an outline of my setup. I agree that an autopilot thread is not the best location and would be happy you relocate it. Can you please do it for me?

I see that a new version of OpenCPN is just out but I won't risk loading it until I have finished the trip I am about to start.

The problem with losing the .conf file is getting worse and I hope that the new version cures that.

Regards,

Stuart
__________________
StuartGunn is offline   Reply With Quote
Old 13-05-2016, 08:43   #42
Registered User

Join Date: Nov 2014
Location: Suffolk Yacht Harbour, UK
Boat: Jeanneau Sunfast 32
Posts: 28
Re: OPCPN not outputing autopilot sentences

Rick,

I forgot one thing to add to the todo list:

A couple of winters ago I made a weather unit which read intermittently from the barometer and humidity sensors and displayed current readings plus a constantly updating graph of the past 3 days. I programmed in Python using tkinter and matplotlib.This is the most useful thing for weather monitoring. I set it on one side because of problems with the touch location reversing on the Waveshare 3.5 inch screen I was using but at the same time I realised that it was going to be a drain on the battery. I thus hope to be able to convert the program to force the multiplexer to wake every 2 hours if asleep and record data to file and then have the viewing program runnable on the chartplotter and reading from the data file on the multiplexer. This will be a next winter project.

You could add that to my note if you want.

Stuart
__________________
StuartGunn is offline   Reply With Quote
Old 13-05-2016, 08:57   #43
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OPCPN not outputing autopilot sentences

re:

The problem with losing the .conf file is getting worse and I hope that the new version cures that.

What problem is that, please?

Thanks
Dave
__________________
bdbcat is online now   Reply With Quote
Old 13-05-2016, 09:24   #44
Registered User

Join Date: Nov 2014
Location: Suffolk Yacht Harbour, UK
Boat: Jeanneau Sunfast 32
Posts: 28
Re: OPCPN not outputing autopilot sentences

Dave,

Even though I close OpenCPN properly and shut down the RPi properly, occassionally when restarting the .conf file is a new one (asks to enter charts etc.) This is a nuisance as I have to reset comms, charts, dashboards.

My workaround is to maintain one good conf file called opencpn.x and swap it with the new .conf file that has been created.

I used to think that the problem was associated with low power but my stabilised power supply is working well, showing good voltage on the output and I even feed the RPi (5v) and HDMIPI screen (12v) seperately.

The past few days the .conf file has been wiped almost every time I shut down.

Stuart
__________________
StuartGunn is offline   Reply With Quote
Old 13-05-2016, 10:46   #45
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: OPCPN not outputing autopilot sentences

Stuart...

When you shutdown normally, is the .conf file always present, or is it sometimes missing altogether? Or present, but short/corrupted?

If it is present, does O ever declare it missing or invalid, and so creates a new one?

Dave
__________________

__________________
bdbcat is online now   Reply With Quote
Reply

Tags
autopilot, enc

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MWV sentences not working in dashboard conachair OpenCPN 13 16-12-2017 12:21
NMEA AIS Sentences with Tag block. O 4.0 Do not show AIS targets. Gilletarom OpenCPN 4 08-12-2015 11:35
OpenCPN 3.3.xxxx and plugins : NMEA sentences list ? Gilletarom OpenCPN 17 01-05-2014 07:02
OpenCPN not sending NMEA autopilot sentences. Islander OpenCPN 6 16-04-2014 08:02
Which NMEA Sentences Does an Autopilot Use ? svpresent Marine Electronics 7 17-09-2010 03:21



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 08:34.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.