Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 09-04-2014, 08:33   #16
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: S63_PI Beta Test 0.4.0

Gerhard...

Pardon me if this is not relevant or useful, but...

I see this:
xcode - Making OS X Installer Packages like a Pro - Xcode4 Developer ID Mountain Lion ready pkg - Stack Overflow

and this:
https://developer.apple.com/library/...kgbuild.1.html

Lots to study here....

Thanks
Dave
__________________

__________________
bdbcat is online now   Reply With Quote
Old 09-04-2014, 09:12   #17
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: S63_PI Beta Test 0.4.0

Dave,
do you have an Apple Developer ID?
It will cost $99 a year.
So you will be able to build Gatekeeper installs.

Gerhard
__________________

__________________
CarCode is offline   Reply With Quote
Old 09-04-2014, 12:02   #18
Registered User

Join Date: Aug 2012
Posts: 17
Re: S63_PI Beta Test 0.4.0

Hi @all:
is there somebody who tested the 0.4.0 Plugin with Ubuntu 12.04 ?
After downloading I've started the application with the Ubuntu-Software-Center. And this tells me : 2,6 GB after installing ???!
I've interrupted the process after 10 minutes without any messages..

Have someone of you the same problems ?

with best regards

Gerd
Attached Thumbnails
Click image for larger version

Name:	Bildschirmfoto.jpg
Views:	79
Size:	228.0 KB
ID:	79067  
__________________
Columbus488 is offline   Reply With Quote
Old 09-04-2014, 13:08   #19
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: S63_PI Beta Test 0.4.0

Hello Dave,

I just installed S63_0.4.0 in O331606.

No apparent problem but looking at the log I found 4 errors.

4 files current language are well placed in the LIB subdirectory of the plugins folder. But these four language files can not be copied in the usual language files folder (share ...).

Here attached the log file and a screenshot.

B.R. Gilletarom
Attached Images
 
Attached Files
File Type: doc install.log.doc (3.5 KB, 29 views)
__________________
Gilletarom is offline   Reply With Quote
Old 09-04-2014, 14:14   #20
Registered User
 
Gilletarom's Avatar

Join Date: Mar 2010
Location: France
Boat: 10.50 mètres
Posts: 2,294
Re: S63_PI Beta Test 0.4.0

Hello,
I tried to run S63_040.

1) I entered userpermit and installpermit. Then I tried to import S63 charts.

I do not have a green (or red) border to indicate the presence of charts. It seems that the charts are not charged. Yet they appear in the Options window.

What have I forgotten?

2) With one test 2, I receive an error message. In this message, the alert window is in English while all other items are in French
(Note: Following the installation indicated in my previous post I copied manually the file language with other french files language).

Is this item is not in the pot file or ???

B.R. Gilletarom
Attached Thumbnails
Click image for larger version

Name:	2014-04-09_S63_0.4.0_Langue_francaise.jpg
Views:	83
Size:	86.2 KB
ID:	79070  
__________________
Gilletarom is offline   Reply With Quote
Old 10-04-2014, 09:53   #21
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Beta Test 0.4.0

Dave,

sorry had not time in the last days so starting some testing today.

S-64 charts will install (Win7), selecting the 7a test set. Install permits do install but then installing the charts I'm getting:
-------------------------------------------------------
Security Scheme Error

SSE08 - SA Digital Certificate File incorrect format
.....
--------------------------------------------------------
for the four cells. None Installed.

Hubert
__________________
bcn is offline   Reply With Quote
Old 10-04-2014, 10:07   #22
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Beta Test 0.4.0

W7 problem when installing.

Uninstalled the previous version of OpenCPN and then cleaned by hand (erasing) the remaining PI folder, including the S-63 stuff. In the case of the S-63 most probably I should have used its own Uninstaller, which one finds in the S-63 PI directory.

This a general problem of the Uninstall at Windows. As the Uninstaller does not know about the user-installed (copied into the plug-in directory) plug-ins, those will not be uninstalled, thus requiring to remove the directory and its content manually.

It seems that the S-63_pi installer looks into the registry, finds there a still existing entry and forces an update of the install. Thus installing a new plug-in into an "old" directory (and even creating this "old" directory if it does not exist anymore).
As the installer is not asking for a parallel install, there is no way to indicate the correct install path. Had to hand-copy the S-63 then.

Hubert
__________________
bcn is offline   Reply With Quote
Old 10-04-2014, 10:58   #23
Registered User

Join Date: Aug 2012
Posts: 17
Re: S63_PI Beta Test 0.4.0

Hallo @all:
I've got installed the new 0.4.0 Plugin as follow:
first download the Plugin
then open a terminal (by "Strg"+"Alt" and "T") and start the command: sudo dpkg --install /home/XXX/Downloads/s63_pi_0.4.0-_i386.deb
XXX must replaced by the name of the user
then starts the installation without any problems.

C488
__________________
Columbus488 is offline   Reply With Quote
Old 10-04-2014, 11:29   #24
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Beta Test 0.4.0

Ok on the W8.1 and the OS-X so far.

OS-X has the well known issues of the z-order of windows - for instance Open the Installpermit dialog, then search which the browser Dave's posting for the Permits and when you come back the Dialog is buried down-under. But as one just has to shuffle the other windows away, no real problem....
__________________
bcn is offline   Reply With Quote
Old 10-04-2014, 11:35   #25
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: S63_PI Beta Test 0.4.0

Hubert,
you might use the F3 key for OS X. Most Mac users don't know this function key, you are not the only one...

Gerhard
__________________
CarCode is offline   Reply With Quote
Old 10-04-2014, 11:57   #26
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Beta Test 0.4.0

Gerhard,

CTRL Arrow-up in my case after some searching, but thanks anyhow to point me to "Mission Control".....

Hubert
__________________
bcn is offline   Reply With Quote
Old 10-04-2014, 17:35   #27
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: S63_PI Beta Test 0.4.0

Gilletarom....

Regarding your post # 19/20:

1. I can reproduce the failure to copy the language files. This is a bug in the installer. Interestingly, it works properly if you re-install the S64 PlugIn immediately.

2. The "SSE - 12" message is NOT in the .po files. Sorry, oversight.

3. Regarding the error message. "SSE - 12..." message only appears if the PERMIT.TXT file is somehow corrupted. Seems unlikely.

Perhaps you could try the test again.
a. Options->Charts->S63Charts->Delete all permits.
b. Re-install permits
c. Load chart cells.

Please post the OpenCPN log file. There is useful S63 information therein.

Thanks
Dave
__________________
bdbcat is online now   Reply With Quote
Old 10-04-2014, 17:52   #28
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,884
Re: S63_PI Beta Test 0.4.0

bcn....

1. Did you get past the W7 trouble with SSE-08 message? Any more feedback from the OCPN log?

2. Regarding parallel installations/un-installs:

We only allow one formal installation of the S63 PlugIn currently. So, if you have multiple parallel OCPN installations, only one of them can have the S64 PlugIn formally installed by the installer, and thus recorded in the registry.

Of course, one may manually copy the PlugIn into any or all of the parallel OCPN's without using the installer/uninstaller. This does not involve the registry.

Like all Windows apps, I recommend that you use the installer and avoid manually moving the PlugIn around. It will make upgrading and maintenance much easier. This would be the normal end-user mode of operation.

Thanks
Dave
__________________
bdbcat is online now   Reply With Quote
Old 11-04-2014, 04:30   #29
Registered User

Join Date: Mar 2009
Location: Currently in Malaysia
Boat: Valiant Esprit 37
Posts: 126
Re: S63_PI Beta Test 0.4.0

I downloaded the beta version yesterday and tried to install the charts I
had purchased through Polar Navy. Didn't have any luck! I cleared everything
and tried step by step, but I'm sure the problems are related to the charts
being issued to Polar Navy. Anyway, FYI, here is what happened with each
step.

Import Cell Permits
Received error SSE 11 - Cell permit not found

Import Charts/Updates
After answering yes to "Create ESENC on Import, received error message
SSE 10 - Permits not available for this data provider

New User Permit
Attempted to use the User permit for Polar Navy. Received an unusual
message that I'm not sure about... Error S63-pi could not execute OCPNSenc
Utility

Install Permit
I'm puzzled about this one. I do not recall receiving this from Polar
Navy. It may be that this number was hidden from me in the routines that
installed the charts for Polar Navy. Who or where do I obtain the Install
Permit?

I'm still hoping I can transfer the Polar Navy charts I purchased to OCPN
and I also want to purchase some additional charts.

I'm very excited to see this so close to implementation! Thank you for
all the work you have put into this!! Let me know when you start issuing the
User Permits and when the Web-Shop is open for business!!
__________________
reflectionsv37 is offline   Reply With Quote
Old 11-04-2014, 04:50   #30
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 2,761
Re: S63_PI Beta Test 0.4.0

Gene,

please have a look at the latest "S-63 plug-in explained" document at o-charts.org as it covers some of your doubts.

First the UserPermits are always for one given system, so PolarNavy or OpenCPN or MaxSea or .... and are not interchangeable.

So charts bought with a PolarNavy UserPermit are only valid for PolarNavy and this is the same for the rest of the OEMs (like us at OpenCPN). Vendor-lock-in by S-63.

If you want to use the PolarNavy encoded charts with OpenCPN you will need the help of ChartWorld to migrate those, using the UserPermit we will have to issue for your OpenCPN plug-in.

To make live a bit easier and more flexible we have introduced the concept of the InstallPermit which marries a UserPermit to a specific system. Here comes the Fingerprint in play which we will need to generate the individual InstallPermit.


Hubert
__________________

__________________
bcn is offline   Reply With Quote
Reply

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beta Test / Technical bdbcat OpenCPN 2072 12-12-2017 18:48
S63_PI Alpha Test 0.3.0 bdbcat OpenCPN 25 07-04-2014 11:00
S63_PI Alpha Test 0.2.0 bdbcat OpenCPN 29 05-02-2014 11:26



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 10:58.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.