Cruisers Forum
 


Join CruisersForum Today

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 25-10-2010, 01:28   #196
Registered User

Join Date: Aug 2010
Posts: 291
hihihi, thanks for your quick reply Pavel. I'll be patient :-)

Keep up the good work!
__________________

__________________
George64 is offline  
Old 25-10-2010, 06:04   #197
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
OpenCPN Version 2.2 Beta 1025

Hello Beta Testers!

OpenCPN Version 2.2 Beta Build 1025 is now available for download.

Changelog:

104. Correct AIS ROT value in Target Query (FS#149)
105. Update Tide/Current HARMONIC file for improved location name formatting.
106. Correct Lat/Lon formatted printing. (FS#156)
107. Add OpenCPN welcome message to .pot file
108. Correct bad encoding of some data (Font descriptors) in config file. (FS#157)
109. Accept comma as decimal delimiter in MarkProp Dialog (FS#141)
110. Add "rename waypoints" dialog to context menu invocation of Route Reverse. (FS#146)
111. Correct "Remove this chart from quilt" logic when only one chart is available. (FS#148)
112. Correct crash in RouteManagerDialog route delete of route actively under creation. (FS#152)
113. Correct error in geolocation with TMERC charts with "Show Skewed charts as North-Up" active.
114. Correct rendering of VERCLR and VERCLL to match selected depth units on S57 ENCs.
115. Correct Tide/Current time calculations near DST transition date. (FS#168)
116. Correct cm93 cell outline rendering near Prime Meridian. (FS#167)
117. Correct Garmin A201 protocol route uploading. Thanks to Jim Dowling. (FS#163)
118. Correct Font item selection drop list for duplicate entries on language change. (FS#143)
119. Correct S52 ENC height and width attribute formatting for Ft./Fathoms settings. (FS#169)
120. Correct linux GnomePrintCups warning message on cli invocation. (FS#99)
121. Correct symbolization of buoy OBJNAM size. (FS#158)
122. Improve AIS target rollover and context menu consistency. (FS#115)
123. Improve Route/Waypoint/Rollover selection logic (FS#70), Thanks, JP.
124. Add compile condition to allow optimized inline assembler code only on Intel 386 compatible architecture.
125. Optimize language selecion pulldown box in Toolbox->Language (FSFeature#19)
126. Correct chart database for Unicode chart file names.
127. Improve Route segment selection math for highly zoomed routes. (FS#170)
128. Bold Highlite active route in RouteManagerDialog (FSFeature#78)
129. Revert (partially) FSFeature#12, Changelog #89 above.
130. Correct crash on some ENC creation (FS#155, FS#175)
131. Integrate new Windows Installer package. Thanks very much to Gunther (NetSurfer)
132. Major update to Dashboard PlugIn. Thanks to Jean-Eudes (sethdart).
133. Build-option port to wxWidgets 2.9.1(experimental)

Release Beta 1025

Notes:
105. Many thanks the Thomas (cagney) for fixing up the remaining Unicode location names.
107. Translators please take note!
131. This is a big one. Many thanks to Gunther. I know you will like it.
132. Ditto. Jean-Eudes has worked like a trooper to bring this PlugIn up, Kudos are due.
133. Planning for the future, and also to expedite the wxMac port. See the separate thread for instructions.

Thanks for all of your useful feedback. Really.
There is a lot that is new and improved in this Beta, and I look forward to our November formal release of OpenCPN Version 2.3.x

Enjoy!
Dave
__________________

__________________
bdbcat is offline  
Old 25-10-2010, 07:29   #198
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,697
Images: 57
Send a message via Skype™ to sinbad7
Dave..

Thanks for ver 1025. Problems with Swedish charts solved.

One remark so far: The font selector for the AIS target query box is not functioning.

Thanks again for all the hard work.

Tore
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline  
Old 25-10-2010, 08:07   #199
Registered User

Join Date: Oct 2010
Location: São Paulo, Brazil
Boat: Brasilia 27 - Asa Branca
Posts: 4
Hello All,

I'm having problems running OpenCPN 2.2 (build 1025) on Ubuntu 10.04.
Compilation is ok. The program starts running, reads the charts and routes.
After some time, it stops responding. The operating system still works fine and I can kill the opencpn process. I have this problem with all builds I tried of version 2.2. Haven't seen this happen in 2.1.

Anyone has an idea of what this problem is an how to fix it?

Thank you!
Paulo
__________________
pbpaiva is offline  
Old 25-10-2010, 08:10   #200
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
Paulo....

Welcome aboard!

Are you using libgps or gpsd? Any PlugIns loaded?

Thanks
Dave
__________________
bdbcat is offline  
Old 25-10-2010, 08:14   #201
Registered User

Join Date: Sep 2010
Location: Gouda, the Netherlands
Posts: 11
Quote:
Originally Posted by sinbad7 View Post
Dave..

Thanks for ver 1025. Problems with Swedish charts solved.

One remark so far: The font selector for the AIS target query box is not functioning.

Thanks again for all the hard work.

Tore
Dear Tore,
I had the same. When you right click an AIS target on the map, I discovered that there are two fields with AIS object query's in stead of the AIS Target query and the AIS Object query fields. When you like to change the font of the target query you should change it in the AIS object query in the list of text elements. Changing the font of the AIS objects overview seems to be impossible now.

Furthermore it seems to work fine!

Regards,

WimvdH
__________________
wimvdh is offline  
Old 25-10-2010, 08:30   #202
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 3,905
Dave,
excellent as usually
Two little glitches with my mother tongue though - for the first the patch follows, the second is that it appears twice in the list (see screenshot)

Pavel

Code:
diff --git a/src/options.cpp b/src/options.cpp
index 7128052..7b7e946 100755
--- a/src/options.cpp
+++ b/src/options.cpp
@@ -2673,7 +2673,7 @@ wxString GetOCPNKnownLanguage(wxString lang_canonical, wxString *lang_dir)
       wxString dir_suffix;
 
       if     (lang_canonical == _T("en_US")) {dir_suffix = _T("en");    return_string = wxString("English (U.S.)", wxConvUTF8);}
-      else if(lang_canonical == _T("cs_CZ")) {dir_suffix = _T("cs");    return_string = wxString("Ceština", wxConvUTF8);}
+      else if(lang_canonical == _T("cs_CZ")) {dir_suffix = _T("cs");    return_string = wxString("Čeština", wxConvUTF8);}
       else if(lang_canonical == _T("da_DK")) {dir_suffix = _T("da");    return_string = wxString("Dansk", wxConvUTF8);}
       else if(lang_canonical == _T("de_DE")) {dir_suffix = _T("de");    return_string = wxString("Deutsch", wxConvUTF8);}
       else if(lang_canonical == _T("et_EE")) {dir_suffix = _T("et");    return_string = wxString("Eesti", wxConvUTF8);}
Attached Thumbnails
Click image for larger version

Name:	double_cz.png
Views:	62
Size:	7.8 KB
ID:	20493  
__________________
nohal is online now  
Old 25-10-2010, 08:34   #203
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Pavel,
Quote:
Originally Posted by nohal View Post
Dave,
excellent as usually
Two little glitches with my mother tongue though - for the first the patch follows, the second is that it appears twice in the list (see screenshot)
the first was my fault - sorry.

The second is still a problem as the current system language appears once at the second position in the drop-down list (first entry always is English (U.S.)) and the second time in the "normal" order.

I am quite sure that Dave will find a solution for this little problem ... !

Gunther
__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline  
Old 25-10-2010, 08:34   #204
Registered User
 
motorbaad's Avatar

Join Date: Feb 2010
Location: scandinavia
Boat: pilotboat 36
Posts: 28
Windows XP sp3:
Build 1025. This version does not read HDT sentence from my compass. Neither in dashboard HDG or ships heading on map.
This worked fine in earlier versions.
The dashboard does not have a correct memory for chosen informations, but ads the default instruments to my settings, after next start of program.
__________________
motorbaad is offline  
Old 25-10-2010, 08:41   #205
Registered User
 
koldun's Avatar

Join Date: Apr 2009
Location: EU
Posts: 4
W7 with beta 2.2.1025

No GPS position even if until today was no problem. I have NMEA but for some reason it doesn't show up on map!



BR
__________________
koldun is offline  
Old 25-10-2010, 08:50   #206
Registered User
 
revivo's Avatar

Join Date: Oct 2010
Location: Porto do Son
Posts: 4
W7 with beta 2.2.1025

No GPS position

AIS is OK
__________________
revivo is offline  
Old 25-10-2010, 08:56   #207
Registered User
 
Netsurfer's Avatar

Join Date: Jan 2010
Location: Cologne, Germany
Boat: Beneteau Oceanis 331
Posts: 557
Quote:
Originally Posted by revivo View Post
W7 with beta 2.2.1025

No GPS position
Copy that.
__________________
Deutschsprachige Community- und Support-Website unter OpenCPN.de
Netsurfer is offline  
Old 25-10-2010, 08:58   #208
Registered User

Join Date: Oct 2010
Location: São Paulo, Brazil
Boat: Brasilia 27 - Asa Branca
Posts: 4
Quote:
Originally Posted by bdbcat View Post
Paulo....

Welcome aboard!

Are you using libgps or gpsd? Any PlugIns loaded?

Thanks
Dave
Hi Dave,

I am using "Network libgps", GRIB and Dashboard plugins.

Thanks
Paulo
__________________
pbpaiva is offline  
Old 25-10-2010, 08:59   #209
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
Re GPS position problems:

There was a change in NMEA decoding for this version, required by port to wxWidgets 2.9. I sort of expected some problem here.

We need to see some NMEA message logs to debug this issue precisely.

Can anyone post an NMEA message log that does not seem to work?

Thanks
Dave
__________________
bdbcat is offline  
Old 25-10-2010, 09:03   #210
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 4,494
Gunther....

Can you send me a non-working NMEA stream? Thanks

Paulo...There seems to be some problem with libgps on Ubuntu 10.04. Cagney reports similar problems. Does it work better if no PlugIns are loaded?

Dave
__________________

__________________
bdbcat is offline  
Closed Thread

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Beta Test / Technical bdbcat OpenCPN 1879 30-11-2016 01:30
OpenCPN Version 2.1.0 Beta bdbcat OpenCPN 1045 25-06-2010 11:09
OpenCPN Version 1.3.5 Beta Technical bdbcat OpenCPN 544 24-03-2010 11:34


Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 06:32.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.