Cruisers Forum
 


Join CruisersForum Today

Closed Thread
 
Thread Tools Rate Thread Display Modes
Old 10-04-2010, 13:50   #151
Registered User

Join Date: Feb 2010
Posts: 619
AIS case of MMSI == 0

Nothing critical, but...

I have a fishing vessel nearby that transmits the following

Quote:
!AIVDM,2,1,8,B,50000000000300000000000000000000000 000000823440Ht023kA@00000,0*76
!AIVDM,2,2,8,B,00000000003,2*2C
!AIVDM,1,1,,B,3000005P0112jVFNU8Jc2gw80000,0*2B
This is obviously illegal, since the value of many of the attribute fields are just zeroes.
However, it is a real case. The ship is really there.

OpenCPN requires MMSI to be nonzero for the Target Properties Dialog, but not for the icon display or AIS Rollover.
This may lead to confusion, because the behaviour will depend on whether other AIS Queries have already been built since OCPN startup or not.

I would propose to display all the other data available also for MMSI==0. After some limited testing I do not see negative effects of allowing this.

Attached is the display sample of original OCPN 2.1.0 and modified 1.3.6 (file "chcanv.cpp" function "AISTargetQueryDialog::UpdateText()" statement "if (m_MMSI)").
Attached Thumbnails
Click image for larger version

Name:	ais0mmsis.jpg
Views:	104
Size:	18.9 KB
ID:	15248   Click image for larger version

Name:	ais0mmsi_fix_s.jpg
Views:	97
Size:	43.4 KB
ID:	15249  

__________________

__________________
PjotrC is offline  
Old 10-04-2010, 16:14   #152
Registered User

Join Date: Oct 2006
Location: Norfolk UK
Boat: Hunter 34
Posts: 14
I get an error message MSVCP80.dll not found. I'm running windows 2000.
__________________

__________________
Richard
s/v Green Dragon
HunterWanderer is offline  
Old 10-04-2010, 16:20   #153
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,248
May not have anything at all to do with OpenCPN.
Check this: Msvcp80.dll - Msvcp80.dll Not Found Error - Missing Msvcp80.dll - Fix Msvcp80.dll
__________________
cagney is offline  
Old 11-04-2010, 14:00   #154
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Just downloaded 2.1.0 build 331 which is NOT working well on my Acer Aspire
laptop running Vista...

Fails to download my CM93 maps,showing just black background.
When panning past a big black square it returns to CM93 mode.

I was also trying to monitor the incoming AIS data but instead
the black screen appeared.

Also my Mercator world map completely disintegrates in pieces??

What happened?

P.S. I have an old request to make the contents of the AIS Query box
copyable with the mouse. It speeds up selecting MMSI and IMO numbers
for external ship data lookups.
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline  
Old 11-04-2010, 14:36   #155
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Quote:
Also my Mercator world map completely disintegrates in pieces??
Download it here:http://www.4shared.com/file/1o1Pqu5b/Worldmercator.html
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline  
Old 11-04-2010, 15:30   #156
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Hi..

My remarks re OpenCPN 2.1.0 build 331 was a little hasty.

I have had a couple of unexpected crashes but by only problem now is the Mercator
.kap chart which just disintegrates and causes a crash. It works fine in 1.3.6 ver.

A mouse copy function in the AIS Query box is still missing. Imagine fumbling after pencial and paper in a wet or dark cockpit in order to copy down the IMO or MMSI
number of a specific vessel for lookup in an external database. It can not be so
difficult to make ALL the text in this box copyable? I can take a screendump of course but it is so much more time consuming. PLEASE DAVE....

Thanks for the great improvements in this new version,you must have had a busy vacation. Much appreciated.
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline  
Old 11-04-2010, 15:43   #157
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
I am having quite frequent crashes while changing from CM93 to raster charts.
It does not matter if it is standard .bsb or our converted .kap versions.
Taking into consideration also the total disintegration and crash of my converted
Mercator world .kap chart EVERY time,there is something very unstable with this new version.
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline  
Old 12-04-2010, 09:30   #158
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Wrong interpretation of converted .kap charts

Hi all.

The new version of OpenCPN has a wrong interpretation of converted .kap charts which are now all distorted. The maps were ok in previous versions
and also in other nav. progs. See attached sample..
Attached Thumbnails
Click image for larger version

Name:	SOLENT.jpg
Views:	109
Size:	324.2 KB
ID:	15260  
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline  
Old 12-04-2010, 10:50   #159
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,248
Quote:
Originally Posted by sinbad7 View Post
Hi all.

The new version of OpenCPN has a wrong interpretation of converted .kap charts which are now all distorted. The maps were ok in previous versions
and also in other nav. progs. See attached sample..
None of the charts that I or Marco has converted are distorted on my computer. Some charts that I have converted now has a red warning bar and the log message "Georeference Chart_Error_Factor....etc", some of these were a bit problematic to start with, but none is distorted the way your dump shows.

What is your log showing, when loading these charts?

Thomas
__________________
cagney is offline  
Old 12-04-2010, 11:10   #160
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
Thomas..

Very strange. They all worked perfectly in all previous versions and also now in SeaClear.
Perhaps it is mostly the charts I have assembled from tiles.

Where do I find the log files in Vista? I know they put files in hidden directories.
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline  
Old 12-04-2010, 11:19   #161
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,248
OpenCpn.org has the answer to your question:Installing OpenCPN | Official OpenCPN Homepage

Thomas
__________________
cagney is offline  
Old 12-04-2010, 14:39   #162
oem
Registered User

Join Date: Nov 2009
Location: Vejle, Denmark
Boat: Vindø 995 ds
Posts: 133
On my Acer aspire one netbok, running XP,I don't seem to be able to start OpenCPn, build 331 after update from 1.3.6. It crashes before I can hit the Tools icon according to above. Must have to do with the initial chart db upgrade and certain charts?

Log file on my netbook (initial upgrade from 1.3.6).
(...)
22:17:19: Using bells sound file: C:\Programmer\OpenCPN\sounds\8bells.wav
22:17:19: Using existing Config_File: C:\Documents and Settings\far\Applicati
22:17:19: Setting Viewpoint Lat/Lon 55.6942, 9.6795
22:17:19: Setting Ownship Lat/Lon 55.6911, 9.7017
22:17:19: System default Language: da_DK
22:17:19: Opencpn language set to: da_DK
22:17:19: Using s57data in C:\Programmer\OpenCPN\s57data
22:17:19: Using Tide/Current data from: C:\Programmer\OpenCPN\tcdata\
22:17:19: Setting Viewpoint Lat/Lon 55.6942, 9.6795
22:17:19: Setting Ownship Lat/Lon 55.6911, 9.7017
22:17:19: NMEA Data Source is....Serial:COM3
22:17:21: AIS Data Source is....None
22:17:21: Using WVSChart datafile: C:\Programmer\OpenCPN\wvsdata\wvs43.dat
22:17:21: NMEA AutoPilot Port is....None
22:17:21: Warning: found incorrect chart db version: V015
22:17:21: Scheduling db upgrade to current db version on Toolbox->Charts p
22:17:21: Chart directory C:\Documents and Settings\far\Dokumenter\s°kort\bsb
22:17:21: Chart directory C:\Documents and Settings\far\Dokumenter\s°kort\enc
22:17:21: GPS Watchdog Timeout is: 6 sec.
22:17:22: Initializing Chart C:\Documents and Settings\far\Dokumenter\s°kort\
22:17:23: VP Final Check: Georeference Chart_Error_Factor on chart C:\Docu

Using dos-box copy/paste, so unfortunately missing some line ends..

I managed somehow to make the upgrade on my desktop vista machine. But I still have a number of crashes on my vista on certain maps still. Removing charts causing errors can help, but seems to run into many other charts causing crashes still. All charts are .KAP, created with mapcal, libbsb and tif2bsb etc. I don't know enough yet about which charts causes crashes. All charts used to be OK in 1.3.6.
__________________
oem is offline  
Old 12-04-2010, 18:09   #163
Senior Cruiser
 
sinbad7's Avatar

Cruisers Forum Supporter

Join Date: Sep 2003
Location: Ubatuba,SP,Brazil (Ex Norway)
Boat: (Ex) Alu. 60' yacht-"Eight Bells"
Posts: 2,717
Images: 57
Send a message via Skype™ to sinbad7
oem..
Same here running on Vista.. A very large number of my .kap converted charts are showing up completely disintegrated. Also those converted from the original NZ maps.When i revert to ver. 1.3.6 all works normal again. What happened I wonder? They seem not to be Vista compatible any more.
__________________
"And all I ask is a tall ship and a star to steer her by."
sinbad7 is offline  
Old 12-04-2010, 18:26   #164
Registered User

Join Date: Mar 2010
Location: Normandy, France
Boat: Flush Poker, 8.25m (Point Barre)
Posts: 335
cmake progress...

While playing with cmake, I had problems compiling because of the GSocket bug already patched a few months ago. IMHO the previous patch is not correct, include wx/socket should be out of the undef:

Code:
Index: include/ais.h
===================================================================
RCS file: /cvsroot/opencpn/opencpn/include/ais.h,v
retrieving revision 1.30
diff -u -r1.30 ais.h
--- include/ais.h    29 Mar 2010 03:17:36 -0000    1.30
+++ include/ais.h    12 Apr 2010 23:47:27 -0000
@@ -144,11 +144,9 @@
 #define GSocket GlibGSocket
 #include <gtk/gtk.h>
 //#include <glib.h>
-#include "wx/socket.h"
 #undef GSocket
-#else
-#include "wx/socket.h"
 #endif
+#include "wx/socket.h"
 ///////////TH100126////////////////
 #include "wx/sound.h"
 
Index: include/nmea.h
===================================================================
RCS file: /cvsroot/opencpn/opencpn/include/nmea.h,v
retrieving revision 1.28
diff -u -r1.28 nmea.h
--- include/nmea.h    29 Mar 2010 02:59:02 -0000    1.28
+++ include/nmea.h    12 Apr 2010 23:47:27 -0000
@@ -121,11 +121,9 @@
 #define GSocket GlibGSocket
 #include <gtk/gtk.h>
 //#include <glib.h>
-#include "wx/socket.h"
 #undef GSocket
-#else
-#include "wx/socket.h"
 #endif
+#include "wx/socket.h"
 ////////////////////TH100126/////////////////
 #include <wx/datetime.h>
Quote:
Originally Posted by bdbcat View Post
Yet another reason maybe to move to cmake? Any volunteers?
Here is my first try. Compiling successfully here on Fedora.

- GTK2 macro are only available in cmake >= 2.8.0 Most distro currently ship cmake 2.6.4 As a workaround we can include these macro in our build tree. Do you agree or should we require cmake >= 2.8.0
- Version number can be handled by cmake to build package and produce appropriate header for source code VERSION.cmake -> config.h
- Should we use -fno-stack-protector or any other option (same for linking)
- BZip2 is linked dynamically if possible (more testing required) or built from included source.
- I've not yet included USE_GLU_TESS test and options
- I've split build process in a few distinct targets: GRIB, NMEA0183, S57ENCis it OK?
- USE_S57ENC in optional (as with autotools) default ON it build and install only if enabled
- same for wifi client

TODO:
- Test on Win32
- Test on OSX plus special build options / code changes
- add uninstall option
- allow packaging with CPack
- anything else...

Please test and report any comment. It's very easy to use: simply copy CMakeLists.txt (remove .doc suffix) with this one.
Code:
$ mkdir build
$ cd build
$ cmake -DPREFIX=/usr ..
$ make
# make install
Attached Files
File Type: doc CMakeLists.txt.doc (13.0 KB, 32 views)
__________________
SethDart is offline  
Old 13-04-2010, 00:15   #165
oem
Registered User

Join Date: Nov 2009
Location: Vejle, Denmark
Boat: Vindø 995 ds
Posts: 133
Here is another crash example. On my desktop vista machine the program starts, shows the initial 'ownship'-position and map, - but crashes after some 15-20 seconds without touching anything.

08:07:41: 2010-04-13
08:07:41: -------Starting opencpn-------
08:07:41: Version 2.1.0 Build 331
08:07:41: SData_Locn is C:\Program Files\OpenCPN\
08:07:41: Using bells sound file: C:\Program Files\OpenCPN\sounds\1bells.wav
08:07:41: Using bells sound file: C:\Program Files\OpenCPN\sounds\2bells.wav
08:07:41: Using bells sound file: C:\Program Files\OpenCPN\sounds\3bells.wav
08:07:41: Using bells sound file: C:\Program Files\OpenCPN\sounds\4bells.wav
08:07:41: Using bells sound file: C:\Program Files\OpenCPN\sounds\5bells.wav
08:07:41: Using bells sound file: C:\Program Files\OpenCPN\sounds\6bells.wav
08:07:41: Using bells sound file: C:\Program Files\OpenCPN\sounds\7bells.wav
08:07:41: Using bells sound file: C:\Program Files\OpenCPN\sounds\8bells.wav
08:07:41: Using existing Config_File: C:\Users\oem\AppData\Roaming\opencpn\opencpn.ini
08:07:41: Setting Viewpoint Lat/Lon 55.7242, 9.5585
08:07:41: Setting Ownship Lat/Lon 55.7211, 9.5539
08:07:41: System default Language: da_DK
08:07:41: Opencpn language set to: da_DK
08:07:41: Using s57data in C:\Program Files\OpenCPN\s57data
08:07:41: Using Tide/Current data from: C:\Program Files\OpenCPN\tcdata\
08:07:41: Setting Viewpoint Lat/Lon 55.7242, 9.5585
08:07:41: Setting Ownship Lat/Lon 55.7211, 9.5539
08:07:41: NMEA Data Source is....Serial:COM3
08:07:41: AIS Data Source is....None
08:07:41: Using WVSChart datafile: C:\Program Files\OpenCPN\wvsdata\wvs43.dat
08:07:41: NMEA AutoPilot Port is....None
08:07:41: Loading chart db version: V016
08:07:41: Chart directory D:\data\Drabant 22\søkort\OpenCPN\kms
08:07:41: Chart directory D:\data\Drabant 22\søkort\OpenCPN\ENC
08:07:41: Chart directory D:\data\Drabant 22\søkort\OpenCPN\BSB_Germany_Denmark
08:07:41: GPS Watchdog Timeout is: 6 sec.
08:07:41: Initializing Chart D:\data\Drabant 22\søkort\OpenCPN\kms\S_157_25000.kap
08:07:42: OpenPD: 316, new_count = 1 for COM3

The crash's seem to be rather consistent at the moment. I'm using the quilting-function. But trying to switch it off did not help.

Could have something to do with a GPS device which I attached recently? But the NMEA-log screen looks completely readable and OK. And works OK with Polarview.
__________________

__________________
oem is offline  
Closed Thread

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Version 1.3.5 Beta Technical bdbcat OpenCPN 544 24-03-2010 11:34
OpenCPN Version 1.3.6 Release bdbcat OpenCPN 32 30-01-2010 06:07



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 07:16.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.