Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-01-2013, 14:09   #1
Registered User

Join Date: Jul 2012
Location: Russell Bay Of Islands New Zealand
Boat: Salthouse 33
Posts: 74
Slow to start

I have a Ford Dover with 900 hours running since rebuild.
Every so often on start up from cold it takes quite a few winds to start.
This is a fuel fuel starvation problem I am sure and not compression as a majority of the time is fires first rotation. My query is what would cause this, I am wondering after sitting on occasions the fuel is "running back" from the injector pump/fuel filter, is this possible, what causes it and where does it go. If this is the case can I rectify it,
__________________
phil23 is offline   Reply With Quote
Reply

Tags
Motor Hard to start

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 11:37.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.