Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 05-11-2013, 11:09   #1
cruiser

Join Date: Nov 2013
Location: Potomac River, VA
Boat: Maxum 3100se
Posts: 2
No HEAT or AC. Please help.

I have a 2004 3100se Maxum - 5k GenSet, Dometic Marine Air Systems heat/AC unit. I think its a 16000BTU. I was getting ready to winterize the heat / AC system, when I turned it on. Unfortunatly, the unit did not engage. The digital control worked fine, and the fan kicked on, but the comprossor / water pump would not active. The AC light stayed lit, even when I turned the temp up to 85. With it not kicking on, I could not run antifreeze through it to winterize.
I then did the factory automated self test, by holding the power button right when I hit the breaker. This did kick it on. I was then able to run antifreeze through it to get it winterized.
When spring comes around, this is the first thing on my agenda to fix. Any thoughts as to why it would not kick on normally, heat or AC, but would with the self test? it was 66 degrees in the cabin, 80 on the top deck (campertop up) 55 outside with the a 10 knot wind. Water temp was between 50-60 degrees.
Thanks in advance for your help!!!
__________________

__________________
michels280 is offline   Reply With Quote
Old 06-11-2013, 06:40   #2
Moderator Emeritus
 
GordMay's Avatar

Join Date: Mar 2003
Location: Thunder Bay, Ontario - 48-29N x 89-20W
Boat: (Cruiser Living On Dirt)
Posts: 31,573
Images: 240
Re: No HEAT or AC. Please help.

Greetings and welcome aboard the CF, michels280.
__________________

__________________
Gord May
"If you didn't have the time or money to do it right in the first place, when will you get the time/$ to fix it?"



GordMay is offline   Reply With Quote
Old 12-11-2013, 15:23   #3
Registered User
 
mayball's Avatar

Join Date: Jul 2008
Location: Puerto Vallarta, Mexico & Denver, Colorado
Boat: Sovereign, 28
Posts: 47
Re: No HEAT or AC. Please help.

Hi michels280,
I have no experience with a Marine Air Chiller system, but most such systems have a low pressure cut-out switch in the refrigerant system that will not allow the compressor and sea water pump to run when a R-22 refrigerant leak lowers the suction pressure to about 38 psig. If it cuts out, the unit will not start until the pressure raises to 68 psig. This would be the case whether operating as an air conditioner or a heat pump It looks to me that you have a leak.
__________________
mayball is offline   Reply With Quote
Old 13-11-2013, 07:21   #4
cruiser

Join Date: Nov 2013
Location: Potomac River, VA
Boat: Maxum 3100se
Posts: 2
Re: No HEAT or AC. Please help.

Thanks. I'll check the pressure.
__________________
michels280 is offline   Reply With Quote
Reply

Tags
lease

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 13:04.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.