Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 14-09-2018, 11:57   #1
Registered User

Join Date: Sep 2018
Posts: 1
Help needed

Hi there , yes i'm new here and very much in need of your help .

i have a mosa Ge6000 Generator and recently it stopped producing power i checked the bits n pieces within the unit and noticed the Capacitor had blown its top off ... very bad timing !! i ordered the same ISH one from ebay the voltage was 450v same as original as was the uf @ 50 +-5% i put this on and it's no longer producing 240V its way up at 350+ how can this be .. but more important how do i fix the little bugger

Regards

Lee

SIMVAN
SIMVAN is offline   Reply With Quote
Old 14-09-2018, 18:29   #2
Registered User

Join Date: Feb 2009
Posts: 2,020
Re: Help needed

I believe it's not the capacitor, probably heard something in the voltage regulator
motion30 is online now   Reply With Quote
Old 15-09-2018, 03:33   #3
Senior Cruiser
 
GordMay's Avatar

Cruisers Forum Supporter

Join Date: Mar 2003
Location: Thunder Bay, Ontario - 48-29N x 89-20W
Boat: (Cruiser Living On Dirt)
Posts: 33,999
Images: 240
Re: Help needed

Greetings and welcome aboard the CF, Lee.


See ➥ https://mosa.com.au/inventory/manuals/MHP0330000.pdf
__________________
Gord May
"If you didn't have the time or money to do it right in the first place, when will you get the time/$ to fix it?"



GordMay is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Needed with Raymarine Linear Drive - Urgent ! Pete the Cat Marine Electronics 17 24-04-2015 10:24
Help: Insurance needed - Ferro Cement Yacht any help? zooplax Boat Ownership & Making a Living 10 20-06-2013 05:58
Celestial Navigation Help Needed Loose Ends Navigation 67 10-11-2011 12:19
Sailmail help needed Harriet Marine Electronics 0 30-11-2006 11:07
Rub rail damage help needed Pa La O La Multihull Sailboats 5 09-12-2004 17:58



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:52.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.