Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-03-2014, 03:30   #1
Registered User
 
d design's Avatar

Join Date: Oct 2013
Location: Whangaroa, New Zealand
Posts: 243
Did I Kill It?

Did I kill my BEP marine battery monitor by accidently hooking the battery wrong way round?
__________________

d design is offline   Reply With Quote
Old 11-03-2014, 04:31   #2
Registered User

Join Date: Oct 2010
Location: Duluth, MN
Boat: Morgan 383
Posts: 129
Re: did i kill it?

A clue: see if it works.
__________________

Dale Hedtke is offline   Reply With Quote
Old 11-03-2014, 09:32   #3
Senior Cruiser
 
senormechanico's Avatar

Cruisers Forum Supporter

Join Date: Aug 2003
Boat: Dragonfly 1000 trimaran
Posts: 6,700
Re: did i kill it?

Did the magic smoke come out? That's a definite clue.
__________________
One should try to "Die Young" as old as possible.
senormechanico is online now   Reply With Quote
Old 11-03-2014, 10:42   #4
Not Politically Correct
 
ontherocks83's Avatar

Cruisers Forum Supporter

Join Date: Aug 2013
Location: Warwick RI
Boat: Catalina 30
Posts: 1,769
Re: did i kill it?

Quote:
Originally Posted by senormechanico View Post
Did the magic smoke come out? That's a definite clue.
Shhhhhhh it's an industry secret that electronics are powered by smoke, which is why when you let the smoke out they stop working.
__________________
-Si Vis Pacem Parabellum
-Molon Labe
ontherocks83 is offline   Reply With Quote
Old 11-03-2014, 12:51   #5
Registered User
 
d design's Avatar

Join Date: Oct 2013
Location: Whangaroa, New Zealand
Posts: 243
Tried it the right way round and it didnt turn on. No smoke or funny smell. Oh i wish its just a connection problem!
d design is offline   Reply With Quote
Old 11-03-2014, 13:06   #6
Registered User

Join Date: Apr 2013
Posts: 227
Re: Did I Kill It?

Have you looked on BEP's website to see if your model is one of those they show connection diagrams for?
Most stuff has polarity protection.
bornyesterday is offline   Reply With Quote
Old 11-03-2014, 14:27   #7
Registered User
 
d design's Avatar

Join Date: Oct 2013
Location: Whangaroa, New Zealand
Posts: 243
Havent changed any of the wiring. Has always worked well until now. I will check out the BEP website thanks.
__________________

d design is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Convicted in Plot to Kill Couple for Yacht Sentenced to Life Terms knottybuoyz Cruising News & Events 47 07-05-2009 04:53
Tsunamis Kill Thousands in Southeast Asia delmarrey Pacific & South China Sea 7 14-12-2005 03:38



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:04.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.