Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-05-2013, 18:53   #1
Registered User

Join Date: May 2013
Posts: 1
Help with new Rasberry Pi User to install OPENCPN

I have been trying to sucessfully install OPENCPN on my rasberry pi model B and have not had any sucess in getting it installed and runing. I have followed the instructions in the download section of the opencpn.org website for Wheezy 7.0 and it errors out when I update. The error message is that it is Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

Can anyone assist? Do I have to compile the source code to get this to work on the Wheezy (2013-02-09-wheezy-rasberian)?

Thanks In Advance,
Doug K
__________________

__________________
keardou is offline   Reply With Quote
Old 21-05-2013, 22:56   #2
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: Help with new Rasberry Pi User to install OPENCPN

Doug...
Raspi is an ARM machine, you will obviously have no luck with X86 packages on it. I'm not aware of any downloadable debs for ARM, so your best bet is to compile from source. Most of Compiling - Linux | Official OpenCPN Homepage should apply on ARM as well. Also Step 4 of Building on Motorola Xoom | Official OpenCPN Homepage should probably be more or less relevant for you, although targeting Squeeze.

Pavel
__________________

__________________
nohal is online now   Reply With Quote
Old 22-05-2013, 01:11   #3
Registered User

Join Date: Nov 2007
Location: Probably in an anchorage or a boatyard..
Boat: Ebbtide 33' steel cutter
Posts: 3,541
Quote:
Originally Posted by keardou View Post
I have been trying to sucessfully install OPENCPN on my rasberry pi model B and have not had any sucess in getting it installed and runing. I have followed the instructions in the download section of the opencpn.org website for Wheezy 7.0 and it errors out when I update. The error message is that it is Unable to find expected entry 'main/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

Can anyone assist? Do I have to compile the source code to get this to work on the Wheezy (2013-02-09-wheezy-rasberian)?

Thanks In Advance,
Doug K
Have a look here....

http://www.agurney.com/raspberry-pi/pi-chart
__________________
conachair is online now   Reply With Quote
Old 22-05-2013, 13:23   #4
Registered User

Join Date: May 2013
Location: Netherlands
Boat: Matthiesen & Paulsen, 40' Seefahrtkreuzer 50m2, 1935
Posts: 12
Either that or just follow the compile for linux instructions like Pavel pointed out. Worked fine for me.

But be aware that de pi is limited on resources. I own one of the first model Bs with only 256mb of memory, so I reduced the amount of memory used by the gpu in the /boot/config.txt file by setting gpu_mem=32 and set the overclocking the medium according to the overclocking table in the config.txt file.
This way opencpn works reasonable well.
__________________
Verezano is offline   Reply With Quote
Old 22-05-2013, 14:25   #5
Registered User

Join Date: Nov 2007
Location: Probably in an anchorage or a boatyard..
Boat: Ebbtide 33' steel cutter
Posts: 3,541
Re: Help with new Rasberry Pi User to install OPENCPN

Quote:
Originally Posted by Verezano View Post
Either that or just follow the compile for linux instructions like Pavel pointed out. Worked fine for me.

But be aware that de pi is limited on resources. I own one of the first model Bs with only 256mb of memory, so I reduced the amount of memory used by the gpu in the /boot/config.txt file by setting gpu_mem=32 and set the overclocking the medium according to the overclocking table in the config.txt file.
This way opencpn works reasonable well.
Compiling takes a while but at least it takes care of the dependencies for you.

I couldn't zoom without crashing using cm93 charts before adding the lines..

/boot/config.txt framebuffer_depth=32 framebuffer_ignore_alpha=1

These might just be needed for cm93 charts, what charts are you using?

ta
__________________
conachair is online now   Reply With Quote
Old 22-05-2013, 15:44   #6
Registered User

Join Date: May 2013
Location: Netherlands
Boat: Matthiesen & Paulsen, 40' Seefahrtkreuzer 50m2, 1935
Posts: 12
I'm using cm93 too and experienced crashes as well when overzooming.
I'll try this option, but for the real work on board I bought a 1.2GHz dual core Pandaboard ES with 1gb memory.
__________________
Verezano is offline   Reply With Quote
Old 22-05-2013, 19:26   #7
Registered User

Join Date: May 2012
Location: Live aboard 19 years
Boat: Norsea, center cockpit/aft cabin, 27'0"
Posts: 354
Re: Help with new Rasberry Pi User to install OPENCPN

Verezano,

I can't say this is going to apply in every case, but the following symbols if enabled in the vector chart settings caused OpenCPN to terminate (crash) at certain more detailed zoom levels.

Try unselecting them and see if it makes a differenc on your machine.

Obstruction
Traffic seperation scheme, lane part
Wreck

armido
__________________

__________________
armido is offline   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 06:33.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.