Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 03-04-2011, 18:39   #1
Registered User

Join Date: Jul 2008
Posts: 10
Balmar ars5: Not Working, No Tachometer

Hey everyone. I finally made it back down to my boat in mexico and got back into tinkering with my charging system. When I left it, I had just installed a new Balmar ars-5 and for the most part things seemed to be working fine. Today I started the motor and noticed that my tach was not working. I then noticed that the display on the ars-5 did not seem to be scrolling correctly. It starts off just rapidly moving through the battery selection mode and the magnet does not seem to activate the switch. The alternator is also not working. However, when I plug the alternator into the old alpha voltage regulator, everything seems to work fine. Any insight would be appreciated.

s/v viandante
granche1 is offline   Reply With Quote
Old 07-04-2011, 12:32   #2
Registered User
SV Demeter's Avatar

Join Date: Dec 2009
Location: Cruising Eastern Caribbean
Boat: Wauquiez Amphitrite 43- Demeter
Posts: 1,163
Re: Balmar ars-5 not working, no tachometer

My Guess is your regulator is bad. Have you tried resetting the regulator to factory defaults? Obviously check all connections. ALso you can make a jumper wire from the field to the 12v+ output on the alternator to confirm its the regulator that is bad and not the alternator but dont try this unless you know what you are doing. Also sounds like you already confirmed its not the alternator.
SV Demeter is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Balmar ars-5: Not Working, No Tach granche1 Electrical: Batteries, Generators & Solar 6 28-04-2011 16:45
Tachometer Calibration KVK Engines and Propulsion Systems 1 06-11-2010 20:34
Tachometer 'Tached Out' !? s/v Geneve Marine Electronics 0 26-03-2010 09:39
Tachometer connection ScratchBC Engines and Propulsion Systems 4 21-05-2006 17:50
Tachometer 1sailaway Engines and Propulsion Systems 9 11-11-2004 15:59

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 14:48.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.