Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 16-09-2011, 15:17   #1
Registered User

Join Date: Sep 2007
Posts: 10
Raymarine SL70 Radar Display Problem

We have a Raymarine SL70 radar display unit that turns on and seems to show an accurate radar display, however, the soft keys, cursor,etc. won't work,nor will the interface to the garmin GPS. The 13 pin and 7 pin input cables seem to be inserted tightly at the back of the display. Any ideas on what to check before we spend a bunch of money to send the unit into Raymarine? Thanks for your ideas!
__________________
aquavit is offline   Reply With Quote
Reply

Tags
radar, raymarine

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Furuno 1715 Radar Unit Review kirkalittle Product or Service Reviews & Evaluations 15 28-10-2014 08:51
Raymarine C70 - GPS / Radar Interface Troubleshooting Nashira Marine Electronics 1 25-08-2011 00:36
Raymarine C80 - Radar Solutions Chuteman Marine Electronics 21 24-08-2011 03:39
Furuno Radar Problem - Help !! Greg4cocokai Marine Electronics 0 29-06-2011 01:43
Raymarine ST60+ wind instrument problem PetenSuz Marine Electronics 7 28-06-2011 08:27



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 13:34.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.