Cruisers Forum

Join CruisersForum Today

Thread Tools Rate Thread Display Modes
Old 02-09-2013, 16:21   #1
Registered User

Join Date: Aug 2013
Location: Yardley, Pa
Boat: Sea Ray Sundancer 39'
Posts: 6
QuickSilver 7.5kw generator

Hello all,

Had the SeaRay out this weekend and after running the generator for about an hour it started making a clanking sound. Shut down the generator; let it cool down, restarted easily. It was still making sound. Thinking maybe a pulley bearing? Anyone have a similar experience? Suggestions? Whatever the noise was it seemed to have no effect on the engine. Unit has 1400 hrs on it.


CruiserTom is offline   Reply With Quote


Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 01:38.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.