Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 15-05-2013, 10:12   #1
Registered User

Join Date: Feb 2011
Posts: 20
OpenCPN will not start on MAC

Sorry to repost, but my original thread went astray...

I have deleted the ini file as directed in previous posts.
I've downloaded the latest files. When I try to install openCPN it immediately crashes.

Following is the log file from when I try to install it:

07:45:49 EDT: 2013-05-15
07:45:49 EDT: ------- Starting OpenCPN -------
07:45:49 EDT: Version 3.2.2 Build 2013-05-08
07:45:49 EDT: wxWidgets version: wxWidgets 2.8.12
07:45:49 EDT: MemoryStatus: mem_total: 0 mb, mem_initial: 0 mb
07:45:49 EDT: SData_Locn is /Volumes/OpenCPN_3.2.2/OpenCPN.app/Contents/SharedSupport/
07:45:49 EDT: Creating new Config_File: /Users/jpernick/Library/Preferences/opencpn.ini
07:45:49 EDT: Styles loading from /Volumes/OpenCPN_3.2.2/OpenCPN.app/Contents/SharedSupport/uidata/styles.xml
07:45:49 EDT: No styles found at: /Users/jpernick/Library/Preferences/opencpn/
07:45:49 EDT: No styles found at: /Users/jpernick/Library/Preferences/opencpn/.opencpn/
07:45:49 EDT: Setting Viewpoint Lat/Lon 33.358, -79.282
07:45:49 EDT: Setting Ownship Lat/Lon 33.358, -79.282

Any ideas are very welcome!

Jeff
__________________

__________________
Jpernick is offline   Reply With Quote
Old 15-05-2013, 14:04   #2
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: OpenCPN will not start on MAC

You have been told several times how to install apps for Mac OS X.
Why you don't want to follow these steps?
You are still starting the app right of the dmg.
__________________

__________________
CarCode is offline   Reply With Quote
Old 15-05-2013, 14:29   #3
Registered User

Join Date: Feb 2011
Posts: 20
Re: OpenCPN will not start on MAC

These are the steps that were recomended on the other thread that I followed. Is this incorrect?

Download the file: Download OpenCPN from SourceForge.net

You should get the file OpenCPN_3.2.2.dmg in your download folder.
Go with Finder to your download folder and double click this file name.
A new window will open which contains a symbol or icon "OpenCPN".
Drag this symbol to your Applications folder.
Go to LaunchPad or your Applications folder and klick "OpenCPN".
__________________
Jpernick is offline   Reply With Quote
Old 15-05-2013, 14:42   #4
Registered User

Join Date: Jul 2010
Location: Monastir, Tunisia
Boat: Amel Sharki
Posts: 1,777
Re: OpenCPN will not start on MAC

Please regard your logfile posted above:
You are still launching the app from /Volumes/ and not from /Applications/

You get it now?
__________________
CarCode is offline   Reply With Quote
Old 15-05-2013, 14:58   #5
Registered User

Join Date: Feb 2011
Posts: 20
Re: OpenCPN will not start on MAC

Sorry, I just can't get it. This is the Mac crash report.
Doesn't it show launch from applications?
Were instructions quoted above on how to install not correct?
Would you recommend a different process than quoted above?



Process: OpenCPN [2288]
Path: /Applications/OpenCPN.app/Contents/MacOS/OpenCPN
Identifier: ???
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [134]
User ID: 502

Date/Time: 2013-05-15 12:54:27.619 -0400
OS Version: Mac OS X 10.8.2 (12C60)
Report Version: 10

Interval Since Last Report: 3302637 sec
Crashes Since Last Report: 63
Per-App Interval Since Last Report: 350046 sec
Per-App Crashes Since Last Report: 5
Anonymous UUID: B0BF2F14-DF13-1A6B-3A28-8A1FB4338EB7

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000c0000008
__________________
Jpernick is offline   Reply With Quote
Old 15-05-2013, 15:40   #6
Registered User

Join Date: Feb 2011
Posts: 20
Re: OpenCPN will not start on MAC

This is the crash report from the openCPN log.


13:27:22 EDT: 2013-05-15
13:27:22 EDT: ------- Starting OpenCPN -------
13:27:22 EDT: Version 3.2.2 Build 2013-05-08
13:27:22 EDT: wxWidgets version: wxWidgets 2.8.12
13:27:22 EDT: MemoryStatus: mem_total: 0 mb, mem_initial: 0 mb
13:27:22 EDT: SData_Locn is /Applications/OpenCPN.app/Contents/SharedSupport/
13:27:22 EDT: Creating new Config_File: /Users/jpernick/Library/Preferences/opencpn.ini
13:27:22 EDT: Styles loading from /Applications/OpenCPN.app/Contents/SharedSupport/uidata/styles.xml
13:27:22 EDT: No styles found at: /Users/jpernick/Library/Preferences/opencpn/
13:27:22 EDT: No styles found at: /Users/jpernick/Library/Preferences/opencpn/.opencpn/
13:27:22 EDT: Setting Viewpoint Lat/Lon 33.358, -79.282
13:27:22 EDT: Setting Ownship Lat/Lon 33.358, -79.282
__________________

__________________
Jpernick is offline   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 21:03.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.