Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Rate Thread Display Modes
Old 21-04-2012, 04:19   #1
Ancient Mariner
 
spiv's Avatar

Cruisers Forum Supporter

Join Date: Jun 2008
Location: Circumnavigating, currently in AU
Boat: FP, Salina 14.3m
Posts: 260
Send a message via Skype™ to spiv
OpenCPN running but not visible

Hello everyone,
I have been using OpenCPN for 3years from my laptop.
Sometimes I plug in a 23" monitor and shift it there.
If I close it while in the monitor, it will reopen in the monitor even if the monitor is not connected, so it is not visible on my laptop; in that case I press "ALT, SPACEBAR" and "M" then move it with the arrow keys until it comes into the laptop screen.

This morning I turned it on, I can see it running in the taskbar, but it not visible.
I tried my trick, but I cannot see it neither in the laptop, nor in the monitor????

Can someone please help me? I have no other navigation software......
__________________

__________________
Keep smiling
Stefano
spiv is offline   Reply With Quote
Old 21-04-2012, 04:31   #2
Registered User

Join Date: Dec 2005
Location: WNA
Boat: Dufour 35
Posts: 3,250
Re: OpenCPN running but not visible

Not knowing what operating system or version of OpenCPN you are running, it's a bit of a guess.
First read this Known issues with current stable release. | Official OpenCPN Homepage. Could this apply in your case?

Next read the first to paragraphs of the FAQ.

Those instructions should set you right.
In short, stop OpenCPN, rename "opencpn.ini", restart OpenCPN. You could also try the suggested editing of he ini file.
Please publish your original "opencpn.ini" file, to help the developers in their bug tracking.

Thomas

Edit: Pavel, maybe we should agree on a "work" schedule
__________________

__________________
cagney is offline   Reply With Quote
Old 21-04-2012, 04:32   #3
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: OpenCPN running but not visible

Stefano...
I suppose the trick described at the beginning of Known issues with current stable release. | Official OpenCPN Homepage should work for you as well...

Pavel

Edit: OK, Thomas, you won
__________________
nohal is offline   Reply With Quote
Old 21-04-2012, 05:23   #4
Ancient Mariner
 
spiv's Avatar

Cruisers Forum Supporter

Join Date: Jun 2008
Location: Circumnavigating, currently in AU
Boat: FP, Salina 14.3m
Posts: 260
Send a message via Skype™ to spiv
Thumbs up Re: OpenCPN running but not visible

Quote:
Originally Posted by cagney View Post
Not knowing what operating system or version of OpenCPN you are running, it's a bit of a guess.
First read this Known issues with current stable release. | Official OpenCPN Homepage. Could this apply in your case?
Thank you Thomas and Pavel.
It worked!

I use Win7 and OpenCPN V2.5.0 Build 2011-07-26.
Attached is the old ini file.

Again, THANKS guys, great work
__________________
Keep smiling
Stefano
spiv is offline   Reply With Quote
Old 21-04-2012, 05:39   #5
Ancient Mariner
 
spiv's Avatar

Cruisers Forum Supporter

Join Date: Jun 2008
Location: Circumnavigating, currently in AU
Boat: FP, Salina 14.3m
Posts: 260
Send a message via Skype™ to spiv
Re: OpenCPN running but not visible

Too fast on the trigger.....

But then:
ini file not acceptable
renamed to txt, but too big for txt
renamed to doc and is OK
Attached Files
File Type: doc opencpnOLD.doc (7.2 KB, 41 views)
__________________
Keep smiling
Stefano
spiv is offline   Reply With Quote
Old 03-05-2012, 15:16   #6
Registered User

Join Date: Nov 2010
Location: San Francisco Bay
Boat: Hunter Legend 40
Posts: 291
Re: OpenCPN running but not visible

I have same problem. Program won't maximize. I use Win 7 , cant find the ini file. may be related to showing hidden files, but don't know how to change in 7. I'll keep checking
__________________
Gary

I'm wet nurse to a last place dead to the neck up ball club and I'm choking to death.
gpshephe is offline   Reply With Quote
Old 03-05-2012, 15:23   #7
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 4,020
Re: OpenCPN running but not visible

Gary...
Yes, ProgramData folder is hidden by default - instructions to make W7 show it for example at How to show hidden files in Windows 7
The full path to the ini file is C:\ProgramData\opencpn\opencpn.ini in case you didn't change the default Windows install location.

Pavel
__________________
nohal is offline   Reply With Quote
Old 03-05-2012, 15:27   #8
Registered User

Join Date: Nov 2010
Location: San Francisco Bay
Boat: Hunter Legend 40
Posts: 291
Re: OpenCPN running but not visible

It's in Windows explorer > organize > folder and search options.

show hidden files is clicked.
hide extensions is unclicked

Still can't find ini file
I'm version 2.5.0, don't know the build can't get in program to find out.

Regards, Gary
__________________
Gary

I'm wet nurse to a last place dead to the neck up ball club and I'm choking to death.
gpshephe is offline   Reply With Quote
Old 03-05-2012, 15:41   #9
Ancient Mariner
 
spiv's Avatar

Cruisers Forum Supporter

Join Date: Jun 2008
Location: Circumnavigating, currently in AU
Boat: FP, Salina 14.3m
Posts: 260
Send a message via Skype™ to spiv
Re: OpenCPN running but not visible

Quote:
Originally Posted by gpshephe View Post
I have same problem. Program won't maximize. I use Win 7 , cant find the ini file. may be related to showing hidden files, but don't know how to change in 7. I'll keep checking
Gary, try this:

  1. open Windows explorer, in the left tree select the C: drive
  2. on the top right search field type: opencpn.ini
  3. let it find, then click on it, it will open on Notepad
  4. In notepad, go to 'Edit' > 'find' and type: FrameWinPosX=
  5. change Number to: 0
  6. Find: FrameWinPosY=
  7. change number to: 20
  8. save changes
__________________
Keep smiling
Stefano
spiv is offline   Reply With Quote
Old 03-05-2012, 15:42   #10
Registered User

Join Date: Nov 2010
Location: San Francisco Bay
Boat: Hunter Legend 40
Posts: 291
Re: OpenCPN running but not visible

I wonder if Home Premium is different than 7 basic. I have no Appearance and Personalization. I have just Personalization. Can't find folder options anywhere in there. Still checking.
__________________
Gary

I'm wet nurse to a last place dead to the neck up ball club and I'm choking to death.
gpshephe is offline   Reply With Quote
Old 03-05-2012, 15:44   #11
Registered User

Join Date: Nov 2010
Location: San Francisco Bay
Boat: Hunter Legend 40
Posts: 291
Re: OpenCPN running but not visible

Quote:
Originally Posted by spiv View Post
Gary, try this:

  1. open Windows explorer, in the left tree select the C: drive
  2. on the top right search field type: opencpn.ini
  3. let it find, then click on it, it will open on Notepad
  4. In notepad, go to 'Edit' > 'find' and type: FrameWinPosX=
  5. change Number to: 0
  6. Find: FrameWinPosY=
  7. change number to: 20
  8. save changes
Yes, I did that . went one step back to computer and searched the whole tree. No ini file. I'm still checking. Got a feeling something basic, but can't uncover it yet.
__________________
Gary

I'm wet nurse to a last place dead to the neck up ball club and I'm choking to death.
gpshephe is offline   Reply With Quote
Old 03-05-2012, 15:51   #12
Registered User

Join Date: Nov 2010
Location: San Francisco Bay
Boat: Hunter Legend 40
Posts: 291
Re: OpenCPN running but not visible

Ok, I changed the C drive attributes and found it. I was thinking you guys were using programdata as a variable to get to the opencpn directory structure, but the ini file is actually in a system directory called programdata. Sorry misunderstood. question for another day. why is it there? Don't answer. Can't deal with that now. Hahahaha
__________________
Gary

I'm wet nurse to a last place dead to the neck up ball club and I'm choking to death.
gpshephe is offline   Reply With Quote
Old 03-05-2012, 15:56   #13
Registered User

Join Date: Nov 2010
Location: San Francisco Bay
Boat: Hunter Legend 40
Posts: 291
Re: OpenCPN running but not visible

Now what was I doing? Hahaha, oh yeah x=0 y=20. Voila, got it. Thanks for hanging in there with me.
__________________

__________________
Gary

I'm wet nurse to a last place dead to the neck up ball club and I'm choking to death.
gpshephe is offline   Reply With Quote
Reply

Tags
opencpn

Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -7. The time now is 18:41.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.