Cruisers & Sailing Forums (https://www.cruisersforum.com/forums/)
-   OpenCPN (https://www.cruisersforum.com/forums/f134/)
-   -   OpenCPN NMEA input thru USB100 woes (https://www.cruisersforum.com/forums/f134/opencpn-nmea-input-thru-usb100-woes-227110.html)

AboardAdventurer 28-11-2019 11:23

OpenCPN NMEA input thru USB100 woes
 
Hello all,



Long time unregistered lurker here with a question which thorough forum searching couldn't answer.

I'm setting up a new PC based nav system as our primary onboard our new 38ft Downeast trawler. I've got experience with OpenCPN on our previous boat, but primarily as a backup system.

The new boat is being equipped with a NMEA 2000 network for GPS, weather, fuel flow, AIS and other various chores. I want/need this data to integrate with the nav PC since it will be my primary systems interface.

I have acquired a Maretron USB100 to tie the NMEA2k network to the PC and everything works thru the N2KAnalyzer program. I can plainly see NMEA sentence outputs thru the N2KAnalyzer tools for all attached sensors. Additionally, I can see 0183 communication when "sniffing" the com port with a 3rd party serial sniffer program. The port settings on the USB100 were left stock at 9600 baud. When I set up a serial connection within OpenCPN I set that port to the same as the USB100 (in this case, Port 3), 9600 baud. No other special settings. I get absolutely no response in OpenCPN when everything is supposed to be talking. I get no data stream thru the debugger window. I've of course tried all the optional settings, tried a 4800 baud port setting both in Windows and in OpenCPN. I downloaded and installed the NMEA debugger plugin, and that shows activity in the NMEA Inputs window, but not in the NMEA window. I'm no computer scientist but I also have set up things like this many times successfully, so I'm beyond stumped. I had a USB GPS dongle which I just plugged in on a separate com Port, and it woke right up within OpenCPN, so the software appears to be working. There is something wrong between the outputs if the USB100 and the inputs of OpenCPN and I cannot for the life of me figure out what I'm doing wrong. Any help would be very much appreciated.



Many thanks.



AA

Hakan 28-11-2019 16:53

Re: OpenCPN NMEA input thru USB100 woes
 
AA..
And you've folowed the installation manual? https://www.maretron.com/support/man...B100UM_1.7.pdf
Driver installed?
Manual section 4 troubleshooting:
- A Com? port available in device manager called "Maretron NMEA 2000 USBGateway"
- No other app using the USB/COM port?

AboardAdventurer 28-11-2019 17:06

Re: OpenCPN NMEA input thru USB100 woes
 
Thanks for the reply.



Yes, all drivers have been installed per the manufacturer manual. I see "Maretron USB100" as the available device when selecting the com port. No other devices are using the com port which the USB100 is active on. Great questions but I think I've boiled thru all of the obvious stuff. Ya never know though...these things usually end up being something dumb!


AA

s/v Jedi 28-11-2019 17:35

Re: OpenCPN NMEA input thru USB100 woes
 
When you see the data in a com port sniffer the. The USB100 and drivers are okay and the problem must be the OpenCPN config.

I have this working on MacOS, as well as via an Actisense USB gateway, a Vesper AIS over wifi and the Digital Yacht wifi gateway.

Dsanduril 28-11-2019 17:55

Re: OpenCPN NMEA input thru USB100 woes
 
Jedi, what baud rate do you have set? The manual is silent on that question and in another thread OP reports some of the information appears garbled, which could be baud rate.

AboardAdventurer 28-11-2019 18:08

Re: OpenCPN NMEA input thru USB100 woes
 
1 Attachment(s)
So getting feedback from the sniffer is pretty hit or miss....It seems very inconsistent to be able to capture it. Likewise, when I plug in the USB GPS Dongle, the sniffer immediately picks up the data, so I likely have something wrong either in setup or possibly in hardware? The USB100 is brand new. The data in the screen shot was taken with a port setting of 4800, but most of my other testing has been at 9600...both work equally poorly.

Looking forward to your feedback and I really appreciate your attention with this problem I've got...

AA

Dsanduril 28-11-2019 18:17

Re: OpenCPN NMEA input thru USB100 woes
 
That all looks good. VTG and GLL solid. Did not confirm checksums, but otherwise OK. OpenCPN set at 4800?

AboardAdventurer 28-11-2019 18:25

Re: OpenCPN NMEA input thru USB100 woes
 
Yes, I set OpenCPN to 4800 but didn't get any response. As another aside, the port sniffer doesn't start recording any data unless I unplug the USB cable from the usb100, and then plug it back in again. Once the device comes back online the data starts flowing. I don't feel like this is right ...?

Dsanduril 28-11-2019 18:31

Re: OpenCPN NMEA input thru USB100 woes
 
What OS? Windows? 7? 10?

Not at a computer this evening, so can't test anything, but I suspect the way CTS is handled on the virtual driver is causing some problems. I might be able to do some testing on various OSs tomorrow.

AboardAdventurer 28-11-2019 18:37

Re: OpenCPN NMEA input thru USB100 woes
 
Fresh copy of Windows 7 Pro on a Lenovo M76 mini pc, i5 processor. I'm traveling this weekend but will bring some if the hardware with me to test on a laptop to see if I run into similar issues.



Thanks for your help!


AA

s/v Jedi 28-11-2019 20:16

Re: OpenCPN NMEA input thru USB100 woes
 
Because of this being NMEA straight to USB, you can set any bitrate as long as itís fast enough for the data :thumb:

rooiedirk 28-11-2019 23:53

Re: OpenCPN NMEA input thru USB100 woes
 
Quote:

Originally Posted by s/v Jedi (Post 3025539)
Because of this being NMEA straight to USB, you can set any bitrate as long as itís fast enough for the data :thumb:

And in your screenshot I see after a rough calculation 30,000 baud (The whole screenshot takes 0.7 seconds)

So as Jedi already mentioned, try lets say 115,200 as speed for the serial port.

AboardAdventurer 29-11-2019 03:46

Re: OpenCPN NMEA input thru USB100 woes
 
Interesting about the baud rate. Just for clarification, the image posted was not an instantaneous screen shot but a pause in the data stream followed by a screen shot. Not sure if that alters your thoughts at all.



AA

AboardAdventurer 29-11-2019 04:05

Re: OpenCPN NMEA input thru USB100 woes
 
5 Attachment(s)
Tried @ 115200 without any change.

More screen shots for reference taken this morning.

AboardAdventurer 29-11-2019 04:31

Re: OpenCPN NMEA input thru USB100 woes
 
1 Attachment(s)
After further playing with the port sniffer, I think maybe the USB100 isn't working right or isn't configured correctly. It just hangs during initial communication and doesn't actually transfer data across the serial port. When I plug in my USB GPS dongle, the communication immediately starts flowing, which is what I would expect across a device streaming in positional data. I'm going to try and get in touch with Maretron today to understand why I can easily connect with their N2KAnalyzer software but not with anything else.

AA


All times are GMT -7. The time now is 14:21.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.


ShowCase vBulletin Plugins by Drive Thru Online, Inc.