Cruisers & Sailing Forums (https://www.cruisersforum.com/forums/)
-   Our Community (https://www.cruisersforum.com/forums/f129/)
-   -   Bilge blower and fuse (https://www.cruisersforum.com/forums/f129/bilge-blower-and-fuse-217816.html)

Northbound44 05-05-2019 14:11

Bilge blower and fuse
 
2 Attachment(s)
I recently noticed that the West Marine bilge blower ( Turbo 4000), installed 2 years ago and still on warranty is gone. After checking the fuse ( ATO type 5 amps) I noticed that it was completely melted in the fuse holder.
The installation/ instruction sheet specified 5 amps fuse and the amperage draw to be 2.9 amps.

I am a bit worried about this and before replacing it I would like to get some opinions or experience in a way to make sure that this will not happen again.
Attachment 191482
Attachment 191483

a64pilot 05-05-2019 15:26

Re: Bilge blower and fuse
 
Put some silicone grease on the blades of the new fuse, of course the holder has to be replaced.
As it was a 5 amp fuse, if the connections were tight and clean, no way 5 amps created all that heat, so I believe there was only a tiny point of connection and that 2.9 amps over such a small area was able to generate plastic melting heat.

windsweptms 13-05-2019 15:13

Re: Bilge blower and fuse
 
Melt fuse ATC holder indicates a loose connection causing arching to complete flow of 12v positive power, replace holder, tighten female spade connector in holder, and or verify the fuse is inserted correctly. Cheers


All times are GMT -7. The time now is 15:53.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.


ShowCase vBulletin Plugins by Drive Thru Online, Inc.