Cruisers & Sailing Forums (https://www.cruisersforum.com/forums/)
-   OpenCPN (https://www.cruisersforum.com/forums/f134/)
-   -   Zooming in version 4.8.0 (https://www.cruisersforum.com/forums/f134/zooming-in-version-4-8-0-a-189355.html)

baltika_no_9 16-08-2017 11:07

Zooming in version 4.8.0
 
When I try to zoom in OpenCPN 4.8.0 using the "+" button I see almost no movement and the displayed chart area hardly changes. Zooming with the mouse wheel works OK. It's the same with either CM93 or oeSENC charts. On my v 4.6.1 build zooming works fine, same charts, same hardware.

The following pictures show a before and after comparison. Between them I have hit the + button 10 times. Each time I click the button the egg timer rolls round then stops and the screen changes almost imperceptibly. I waited for it to settle between each press.


Any ideas how I can restore a sensible level of zoom using +/-?

RPi3, OpenPlotter 0.14.4/OpenCNP 4.8.0

Thanks
https://www.cruisersforum.com/forums/...cture27886.png
https://www.cruisersforum.com/forums/...cture27887.png

baltika_no_9 16-08-2017 11:10

Re: Zooming in version 4.8.0
 
Sorry, failed to add images. Trying again

petter5 16-08-2017 11:22

Re: Zooming in version 4.8.0
 
works smooth for me using 4.8.0 / ubuntu 16.04 / cm93 / kap

/Petter
Quote:

Originally Posted by baltika_no_9 (Post 2457815)
When I try to zoom in OpenCPN 4.8.0 using the "+" button I see almost no movement and the displayed chart area hardly changes. Zooming with the mouse wheel works OK. It's the same with either CM93 or oeSENC charts. On my v 4.6.1 build zooming works fine, same charts, same hardware.

The following pictures show a before and after comparison. Between them I have hit the + button 10 times. Each time I click the button the egg timer rolls round then stops and the screen changes almost imperceptibly. I waited for it to settle between each press.


Any ideas how I can restore a sensible level of zoom using +/-?

RPi3, OpenPlotter 0.14.4/OpenCNP 4.8.0

Thanks
https://www.cruisersforum.com/forums/...cture27886.png
https://www.cruisersforum.com/forums/...cture27887.png


seandepagnier 16-08-2017 14:10

Re: Zooming in version 4.8.0
 
Quote:

Originally Posted by baltika_no_9 (Post 2457815)
When I try to zoom in OpenCPN 4.8.0 using the "+" button I see almost no movement and the displayed chart area hardly changes. Zooming with the mouse wheel works OK. It's the same with either CM93 or oeSENC charts. On my v 4.6.1 build zooming works fine, same charts, same hardware.

You should try git-bisect between 4.6.1 and 4.8.0.

waterman480 16-08-2017 17:39

Re: Zooming in version 4.8.0
 
That is one of the problems I had - which I noted on the RPi slow thread. I have more Rpi3s arriving tomorrow, and wanted to try a recompile to see if there was a problem there. Witnessed the problem on RPi2, but the Rpi2 is too slow to run the compile tonight.

Git-bisect - that is a new one for me. How do I tell where the change might have been introduced, if that is where the problem lies?

rgleason 16-08-2017 18:31

Re: Zooming in version 4.8.0
 
Quote:

Git-bisect - that is a new one for me. How do I tell where the change might have been introduced, if that is where the problem lies?
https://git-scm.com/docs/git-bisect
https://git-scm.com/book/en/v2/Git-T...gging-with-Git
Using Git bisect to figure out when brokenness was introduced | webchick.net

This can be very effective, if you know approx when it was working and when it stopped.

waterman480 17-08-2017 03:47

Re: Zooming in version 4.8.0
 
baltika_no_9 - Try doing a "Force Full Database Rebuild". I was trying to find out why one of my 4.8.0 RPis did not exhibit this problem. On a hunch I decided to do a database rebuild on one that did. Voila! Now it zooms in and out properly at the normal (for an RPi2) speed, rather than the glacial speed it was before. In addition, the zoom step size is now back to normal.

Let me know if that changes anything

I think one of the major problems with the RPi is the use of an SD card, combined with power cable issues due to the large number of crappy cables in the wild. Writes to the SD card appear to be very sensitive to voltage drops, and are easily corrupted by poor power. It is amazing how bad the power can be when you look at it with a scope.

baltika_no_9 17-08-2017 04:12

Re: Zooming in version 4.8.0
 
Quote:

Originally Posted by waterman480 (Post 2458239)
baltika_no_9 - Try doing a "Force Full Database Rebuild". I was trying to find out why one of my 4.8.0 RPis did not exhibit this problem. On a hunch I decided to do a database rebuild on one that did. Voila! Now it zooms in and out properly at the normal (for an RPi2) speed, rather than the glacial speed it was before. In addition, the zoom step size is now back to normal.

Let me know if that changes anything

I think one of the major problems with the RPi is the use of an SD card, combined with power cable issues due to the large number of crappy cables in the wild. Writes to the SD card appear to be very sensitive to voltage drops, and are easily corrupted by poor power. It is amazing how bad the power can be when you look at it with a scope.

I will try that and report back, meanwhile see this
OpenCPN (via openplotter) slow on RaspPi3 - Page 2 - Cruisers & Sailing Forums

baltika_no_9 17-08-2017 04:20

Re: Zooming in version 4.8.0
 
Quote:

Originally Posted by waterman480 (Post 2458239)
baltika_no_9 - Try doing a "Force Full Database Rebuild". I was trying to find out why one of my 4.8.0 RPis did not exhibit this problem. On a hunch I decided to do a database rebuild on one that did. Voila! Now it zooms in and out properly at the normal (for an RPi2) speed, rather than the glacial speed it was before. In addition, the zoom step size is now back to normal.

Let me know if that changes anything

I think one of the major problems with the RPi is the use of an SD card, combined with power cable issues due to the large number of crappy cables in the wild. Writes to the SD card appear to be very sensitive to voltage drops, and are easily corrupted by poor power. It is amazing how bad the power can be when you look at it with a scope.

I tried the Full Databse Rebuild but the zooming via the +/- buttons is till vanishingly small.

rgleason 18-08-2017 03:32

Re: Zooming in version 4.8.0
 
This is an excellent suggestion. Whenever there is an upgrade the first thing I always do is force a full rebuild, because I found that it has quickly solved issues with new versions. But before that I update the charts with Chartdwnldr. Hope it works.

waterman480 28-08-2017 21:21

Re: Zooming in version 4.8.0
 
I spoke too quickly. Zooming in and out with the buttons is very erratic on both windows and RPi. Sometimes it changes a good amount, sometimes the change is almost barely perceptible. How does O calculate how much to Zoom +/- per tap of the toolbar button? Works just fine using the mouse wheel and touch screen.

Also there is an issue with changing scales. Chart #11325 and 11329 do not change scales at the same time even though both are 1:10000 charts. 11325 disappears first when zooming out.

waterman480 29-08-2017 16:18

Re: Zooming in version 4.8.0
 
Bump - for some reason last post didn't show up.

bdbcat 29-08-2017 16:43

Re: Zooming in version 4.8.0
 
Waterman480...

If the "Smooth zoom/pan" option is not set, zooming using the toolbar button is by binary progression. Zoom-in = x2, zoom out=x0.5.

If "smooth.." is set, then zoom continues as long as the toolbar button is pushed, until some hard stops built-in depending on chart type.

Is your observed behavior not as described?

Thanks
Dave

waterman480 29-08-2017 17:45

Re: Zooming in version 4.8.0
 
For both Rpi and Win - If smooth is not set, O works as you described. If smooth is set and used as you described (holding the button), it works as described. Where the problem comes in is if you single step while smooth is enabled. The amount of zoom is irregular - sometimes very little, sometimes a lot.

Perhaps O was never intended to be operated that way, however it is the only way to get the granularity that is sometimes desired. On the RPi, zooming while holding the button is also sometimes erratic, but that is due to the slow processing speed of the RPi.

On another note - if a vessel does not transmit a heading, and has a speed of zero; O does not use COG for orientation. Instead vessels all point north. Intentional?

Cheers,

Dave

bdbcat 29-08-2017 18:20

Re: Zooming in version 4.8.0
 
Dave...

On the zoom question, not sure what the answer should be. We could probably do something to normalize the operation depending on processor speed, chart load delay, etc. That way, a button push of a specific time always generates the same number of internal zoom commands. Might be hard to get right on all platforms, chart types, etc. Something to think about for the future, though... Feature Request?

On AIS, if SOG is zero, then COG is undefined. We choose north. BTW, some standards (Euro Inland iENC) specifically state that COG should not be used to render the image of the ship onscreen, ever. We finesse this....

Dave


All times are GMT -7. The time now is 02:01.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.


ShowCase vBulletin Plugins by Drive Thru Online, Inc.