Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 19-05-2019, 09:27   #1
Registered User

Join Date: Mar 2019
Location: Sweden
Boat: Hallberg Rassy 36
Posts: 9
Finally installed the watermaker

Hi everyone i finally installed the watermaker and im not sure if i got everything right... It is a Eco sistems splash 25.

1. Low preasure pump is almost at the same height as the water intake.
2. Prefilter with 2-way valve is placed approx 40 cm above low preasure pump.
3. fine filter is placed 20 cm above prefilter.
4. Unit is placed approx at the same hight as the fine filter.

The problem is that i only get low preasure gauge up to 5 bar and high preasure up to 24 bar and production gauge says 33 L/H.
The sailinity check says around 20 ppm and when you taste the production water there is no salt taste at all.
Im residing in the Baltics with brakish water and the temp now is around 12 C.

Anyone have an idea what i did get wrong?

Br

Micke
Attached Thumbnails
Click image for larger version

Name:	Preasure.jpg
Views:	57
Size:	146.8 KB
ID:	192323   Click image for larger version

Name:	Production.jpg
Views:	57
Size:	124.2 KB
ID:	192324  

Click image for larger version

Name:	Pump.jpg
Views:	61
Size:	250.7 KB
ID:	192325   Click image for larger version

Name:	Fine_Filter.jpg
Views:	58
Size:	167.4 KB
ID:	192326  

Click image for larger version

Name:	Prefilter.jpg
Views:	60
Size:	197.1 KB
ID:	192327   Click image for larger version

Name:	Unit.jpg
Views:	60
Size:	175.8 KB
ID:	192328  

__________________
--------------------------------------------------------
https://www.leftthedock.com
mickejo is offline   Reply With Quote
Reply

Tags
water, watermaker

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Finally made decision on watermaker -- ordered Spectra Ventura 200T Capt.Don Plumbing Systems and Fixtures 56 08-01-2019 08:16
Just installed a PowerSurvivor 35 Watermaker looking for advise Rocketman Plumbing Systems and Fixtures 8 07-06-2014 07:38
Anyone installed generic membrane in SR Ultra Whisper 600 Modular watermaker? svlamorocha Plumbing Systems and Fixtures 10 27-12-2013 19:01
Finally got my toolbox installed Latitude9.5 Construction, Maintenance & Refit 11 16-05-2008 04:19
New purpose built compression beam installed fastcat435 Multihull Sailboats 5 03-03-2008 02:21

Advertise Here


All times are GMT -7. The time now is 19:27.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.