Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 16-03-2018, 11:10   #1
Registered User

Join Date: Aug 2016
Location: Brazoria, Tx
Boat: '72 Ta Chiao 41'
Posts: 16
Fresh Water pump draws power when pressurized & causes LED lights to flicker...

I was told I should post this in my own, so here goes.

Any time I switch power on to fresh water it draws 10 amps for 20 seconds, even if it is still pressurized, & I don't hear it pumping. If I release the pressure before I flip the switch, it will only run for a couple of seconds (which tells me it isn't bleeding down) but continues to draw 10 amps for about 20 seconds. As A side note, all my lights have been converted to LED so it takes only 0.2 amps to run the light in the head near where the fresh water pump is, but I see it flickering the entire time that the pump is drawing 10 amps. If I turn on additional lights in the forward cabin, they all flicker the same. The amp draw is consistent & 20 seconds each time, & during that time the lights in the head (LED) flicker lightly (barely noticeable) as if the pump was idling, but I don't hear it like when it is pumping. Also no lights flicker when it is pumping normally with faucet open & water flowing. It never looses pressure. I turn it off every time I leave & I can go down to the boat a week later & turn on the water & it releases what looks like full pressure. Turn the faucet off, switch the power on, it pumps for a few seconds, stops, but the current remains 10 amps for 20 seconds every time, then goes to 0.2 amps for LED overhead light & as I said above lights flicker.


Another thing that is curious, the switch panel has led indicators which lite when the switch is engaged. All the others go off immediately when turned off. The fresh water indicator light takes a few seconds to "bleed down" as if it were a battery/capacitor losing power. Is that normal?

Any feed back would be appreciated!
Duece is offline   Reply With Quote
Reply

Tags
led lights, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pressurized fresh water pump triggered every 2 hours BrettB Plumbing Systems and Fixtures 30 07-04-2018 20:58
M3-20 Universal - Gauges flicker, power drops and engine stops amandak Electrical: Batteries, Generators & Solar 20 14-08-2017 06:04
Time Draws Near Andrei123 General Sailing Forum 6 31-07-2012 14:08
Cruisers: Pressurized Fresh Water ? Beersmith Plumbing Systems and Fixtures 80 22-11-2011 02:46
Led lights flicker Overlord Electrical: Batteries, Generators & Solar 12 22-03-2011 00:04

Advertise Here


All times are GMT -7. The time now is 17:33.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.