Cruisers Forum
 


Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 28-06-2020, 14:07   #1
Registered User

Join Date: Apr 2008
Posts: 7
Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Hi all, canít get a Ysb8 to start. New fuel, electric primary pump works. I get a big stream from the injector pump when I loosen the delivery valve and injector pump is bleed very well.....I believe. I turn engine over and nothing from delivery valve? I took injector pump apart and everything looks clean and nothing seems worn. Not sure I could tell but nothing obvious. Should I just put a new injector pump in? Do they just go bad and nothing pumps out? Any help or insight would be great.
Thanks
Liam
lydude is offline   Reply With Quote
Old 28-06-2020, 14:32   #2
Registered User

Join Date: Jul 2016
Posts: 194
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

what happens if you spray WD40 in the intake.. does it fire?
could the decompression lever be stuck and not working?
do you get diesel at the injector is you crack open the line while its cranking?


-dkenny64
dkenny64 is offline   Reply With Quote
Old 28-06-2020, 15:04   #3
Registered User

Join Date: Apr 2008
Posts: 7
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Yes fires when I sprayed some started fluid in.
No diesel when cranking, Iíve taken off high pressure metal line and cranked and no fuel spurting out at all? Iím pretty sure decompression lever works fine.
lydude is offline   Reply With Quote
Old 28-06-2020, 15:32   #4
Moderator
 
a64pilot's Avatar

Cruisers Forum Supporter

Join Date: Oct 2013
Location: Jacksonville/ out cruising
Boat: Island Packet 38
Posts: 31,472
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

I am completely unfamiliar with that motor, but are you certain that the fuel shut off isn’t shut off?
a64pilot is offline   Reply With Quote
Old 28-06-2020, 15:40   #5
Registered User

Join Date: Apr 2008
Posts: 7
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Fuel is in flowing freely with the electric primary pump.
lydude is offline   Reply With Quote
Old 28-06-2020, 16:01   #6
Senior Cruiser
 
Halifax Sailor's Avatar

Cruisers Forum Supporter

Join Date: Nov 2014
Location: Halifax Nova Scotia
Boat: Mirage 27
Posts: 266
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

May sound dumb, but same happened to me last year. Planned on changing both filters before launch but didnt and then engine would not start. Electric fuel pump couldn't get any fuel thru primary and secondary was totally empty (engine ran it dry). Felt pretty stupid but glad that's all it was. Changed out both, bled lines and vroom.
__________________
"When i grow up I want to be a sailor, my wife tells me i can't do both"
Halifax Sailor is offline   Reply With Quote
Old 28-06-2020, 16:27   #7
Marine Service Provider

Join Date: Sep 2014
Location: Auckland, NZ
Boat: Compass 790 , 7.9 metres or 26 ft
Posts: 2,276
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Quote:
Originally Posted by lydude View Post
Hi all, canít get a Ysb8 to start. New fuel, electric primary pump works. I get a big stream from the injector pump when I loosen the delivery valve and injector pump is bleed very well.....I believe. I turn engine over and nothing from delivery valve? I took injector pump apart and everything looks clean and nothing seems worn. Not sure I could tell but nothing obvious. Should I just put a new injector pump in? Do they just go bad and nothing pumps out? Any help or insight would be great.
Thanks
Liam
A few of questions for you.
Have you been working on the fuel system before it failed to start?
Was it a good starter before this problem occurred?
Do you have a copy of the service manual? Check the CF library for a copy
I wouldn't replace the injection pump just yet if there are no obvious faults like scoring or rust.
They don't usually just go bad unless dirt or air is in them. Once you answer the questions it may give us a clue.
Wotname knows more about those IP's I'll alert him to your post
Here is a link to a video you might like.
Compass790 is offline   Reply With Quote
Old 28-06-2020, 16:45   #8
Registered User

Join Date: Jul 2016
Posts: 194
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

the electric pump only get the fuel to the injector pump.. not past
do you have fuel at the injector is you crack open the line.


my first boat had the YSE8 yanmar...
does spraying WD40 in the intake make it fire..no.. check the compression release...yes...back to the first question


-dkenny64
dkenny64 is offline   Reply With Quote
Old 28-06-2020, 16:52   #9
Registered User

Join Date: Apr 2008
Posts: 7
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Thanks
Just changed all fuel in tank
Starter turns engine over quickly
Electric pump fills up injector pump when bleeding. Get major stream of fuel when I unscrew delivery valve. But when I tighten it up again and turn over engine nothing will spurt out of delivery valve. I know fuel is in IP has bleeder screw on banjo fitting suppling it. How nothing comes out baffles me. Donít know how any air could be in there? Pretty sure I have the air venting figured out.
lydude is offline   Reply With Quote
Old 28-06-2020, 17:02   #10
Marine Service Provider

Join Date: Sep 2014
Location: Auckland, NZ
Boat: Compass 790 , 7.9 metres or 26 ft
Posts: 2,276
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Quote:
Originally Posted by lydude View Post
Thanks
Just changed all fuel in tank
Starter turns engine over quickly
Electric pump fills up injector pump when bleeding. Get major stream of fuel when I unscrew delivery valve. But when I tighten it up again and turn over engine nothing will spurt out of delivery valve. I know fuel is in IP has bleeder screw on banjo fitting suppling it. How nothing comes out baffles me. Donít know how any air could be in there? Pretty sure I have the air venting figured out.
Ok is the throttle wide open when you are cranking it? Is the governor linkage ok?
Did the problem occur suddenly?
Compass790 is offline   Reply With Quote
Old 28-06-2020, 17:24   #11
Certifiable Refitter/Senior Wannbe
 
Wotname's Avatar

Join Date: Jan 2008
Location: South of 43 S, Australia
Boat: C.L.O.D.
Posts: 12,566
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Quote:
Originally Posted by lydude View Post
Hi all, canít get a Ysb8 to start. New fuel, electric primary pump works. I get a big stream from the injector pump when I loosen the delivery valve and injector pump is bleed very well.....I believe. I turn engine over and nothing from delivery valve? I took injector pump apart and everything looks clean and nothing seems worn. Not sure I could tell but nothing obvious. Should I just put a new injector pump in? Do they just go bad and nothing pumps out? Any help or insight would be great.
Thanks
Liam
Some points to consider.

The injector pump (IP) is very simple but somewhat different to latter style IPs.

You will only see a very very small amount of fuel from the delivery valve and only if the regulator lever is in the full power position..

The best way to tell if fuel is being injected is to set the throttle fully open (WOT), decompress the engine, turn it over rapidly by hand and listen for the injection squeak. If it is injecting fuel, there will be a distinct squeak at the injection moment. If no squeak (or very weak squeak), there is no fuel being injected. Note - the throttle must be wide open (i.e. regulator lever fully operated and regulation valve fully closed) for this test.

The operation manual gives full details on how to adjust the regulator valve if you have disassembled it. It must be followed exactly but it isn't difficult.

It also must be adjusted periodically as the regular valve wears. By periodically, I mean say every 1000 hours - anytime the squeak becomes weak!

This IP doesn't usually fail without warning and last time I checked, parts where still available (2 years ago). There are only three parts needed. The plunger and barrel assembly (sold as a matched pair), the regulator needle and the delivery valve.

Do you have the operators manual or a service manual? You need them if you want to work on or replace the the IP.
__________________
All men dream: but not equally. Those who dream by night in the dusty recesses of their minds wake in the day to find it was vanity: but the dreamers of the day are dangereous men, for they may act their dreams with open eyes, to make it possible. T.E. Lawrence
Wotname is online now   Reply With Quote
Old 28-06-2020, 17:31   #12
Certifiable Refitter/Senior Wannbe
 
Wotname's Avatar

Join Date: Jan 2008
Location: South of 43 S, Australia
Boat: C.L.O.D.
Posts: 12,566
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Quote:
Originally Posted by lydude View Post
Thanks
Just changed all fuel in tank
Starter turns engine over quickly
Electric pump fills up injector pump when bleeding. Get major stream of fuel when I unscrew delivery valve. But when I tighten it up again and turn over engine nothing will spurt out of delivery valve. I know fuel is in IP has bleeder screw on banjo fitting suppling it. How nothing comes out baffles me. Don’t know how any air could be in there? Pretty sure I have the air venting figured out.
The way the the YSB IP regulates fuel quantity being delivered is sort of the opposite of most other IPs.

It regulates the amount of fuel delivered to the injector by bleeding off the high pressure side of the pump back to the low pressure side. At full power, no (or very little) high pressure fuel is diverted back to the low pressure side. At idle, most of the high pressure fuel is divert back to the low pressure side. This all happens internally in the IP.

EDIT: When you crack the delivery valve, you no longer have a high pressure side as you have opened that side to the atmosphere.
__________________
All men dream: but not equally. Those who dream by night in the dusty recesses of their minds wake in the day to find it was vanity: but the dreamers of the day are dangereous men, for they may act their dreams with open eyes, to make it possible. T.E. Lawrence
Wotname is online now   Reply With Quote
Old 28-06-2020, 17:47   #13
Certifiable Refitter/Senior Wannbe
 
Wotname's Avatar

Join Date: Jan 2008
Location: South of 43 S, Australia
Boat: C.L.O.D.
Posts: 12,566
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

BTW, that is an excellent video posted by Compass790 upthread and describes the IP very well. The squeak can be heard at 3.21 and 4 minute marks.

Unfortunately it doesn't describe the regulator adjustment after re-assembley. This is a critical step.
__________________
All men dream: but not equally. Those who dream by night in the dusty recesses of their minds wake in the day to find it was vanity: but the dreamers of the day are dangereous men, for they may act their dreams with open eyes, to make it possible. T.E. Lawrence
Wotname is online now   Reply With Quote
Old 28-06-2020, 18:24   #14
Registered User

Join Date: Dec 2014
Location: On a round sphere in a planetary system
Boat: 1977 Bristol 29.9 Hull #17
Posts: 590
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

An outside chance but,... is your engine stop button solenoid sticking in the off position? Ask me why I ask this...

Fair winds,
Pegu Club is offline   Reply With Quote
Old 28-06-2020, 18:39   #15
Registered User

Join Date: Apr 2008
Posts: 7
Re: Yanmar Ysb8 not starting, injector pump doesnít seem to be pumping

Thanks Wotname, that all gives me a bit of insight. Iím not sure Iíve adjusted the regulator properly, I did try as I had removed it all. I did order a new regulator valve but havenít gotten yet. I did have the throttle wide open, not sure if reg was correct. Sounds like it needs to be fully closed ďscrewed downĒ when throttle is all the way down. Iíll check that next weekend. Great video thanks! Iíll study up the regulator adjustment. Based on video not much fuel gets pushed out. Itís hard to crank my engine by hand as my fiberglass covers the engine and my homemade hand crank is about 12Ē long so hard getting it going, thus use starter.
Thanks again look forward to trying your tips next weekend!
lydude is offline   Reply With Quote
Reply

Tags
injector pump, pump, yanmar

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iPad Navionics App doesn't seem to access GPS HighTemp Navigation 4 24-12-2015 09:14
Injector pump not pumping to 2 injectors msponer Engines and Propulsion Systems 21 06-12-2015 10:23
Control Checksum doesn't seem to be operational simonmtl OpenCPN 4 30-09-2015 17:49
Do skippers really want crew? Doesn't seem so... messias Training, Licensing & Certification 51 23-03-2015 23:16
For Sale: Yanmar YSB8 Hand Crank and Injector. endoftheroad Classifieds Archive 3 01-03-2013 10:00

Advertise Here


All times are GMT -7. The time now is 16:35.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.