Cruisers Forum
 


Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 23-07-2020, 15:59   #91
Registered User

Join Date: Aug 2010
Location: sydney, australia
Boat: 38 roberts ketch
Posts: 1,309
Images: 3
Re: Yanmar 2qm20 not starting troubleshooting

well done thesauvage, I'm chiming in a bit late on this but I'm glad to see a classic old engine wont start thread solved without the usual kneejerk resort to pulling apart lift pumps and injector pumps, tho' you were on the verge of fiddling pointlessly with the injectors before you actually checked the cheapest, easiest and most common cause of these sorts of problem, the fuel lines. I spent a year sorting through a medley of recurring fuel air leak problems with my 2qm20 and it was actually running quite well when i first got it, so let me warn you to check the following; the fuel tank taps, fuel filter connections and bleed screw, bleed screw seal on injector pump, seal on lift pump, seals on secondary filter and its bleed screw, vibration damping on the fuel lines to injectors - if there isnt any make some.
get all these things bullet proofed and you'll have years of trouble free running from a 2qm20. good luck.
charliehows is offline   Reply With Quote
Old 26-07-2020, 00:22   #92
Registered User

Join Date: Mar 2012
Location: Australia
Boat: Savage Nautilus with Yanmar 2qm15 inboard diesel.
Posts: 152
Re: Yanmar 2qm20 not starting troubleshooting

Quote:
Originally Posted by thesauvage View Post
OK, I'll re-bleed the fuel lines, just to make sure:
I found with my old 2qm15 starting problem that the Yanmar fuel pump was taking too long to bring the fuel up to the injectors each time I tried to start it.

I believe it was due to the length of the fuel line. At 7 feet it was too long so with the engine not running fuel would drain back down the hose and the fuel pump had trouble bringing it all the way back. I solved this by fitting one of those rubber squeeze bulbs into the line near the engine just before the fuel pump. A couple of squeezes on the bulb brings the fuel right up to the pump under pressure and the engine now has no trouble starting.
bony is offline   Reply With Quote
Old 26-07-2020, 01:31   #93
Registered User

Join Date: Dec 2019
Posts: 171
Re: Yanmar 2qm20 not starting troubleshooting

One thing that can cause that is a loose solenoid.
Michael Cobbe is offline   Reply With Quote
Reply

Tags
2qm20, yanmar

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting solar setup... or troubleshooting my troubleshooting!! basssears Electrical: Batteries, Generators & Solar 151 27-08-2018 08:41
Troubleshooting Generator Starting Pelagic Electrical: Batteries, Generators & Solar 4 25-08-2018 14:12
2qm20 starting help BurningDaylight Engines and Propulsion Systems 48 26-05-2015 13:18
Looking for used Yanmar 2QM20 cylinder head. tylerz Engines and Propulsion Systems 4 04-03-2013 13:24
Has Anyone Retrofitted a Yanmar 2qm20 with Modern Engine Mounts ? charliehows Engines and Propulsion Systems 1 01-09-2011 05:46

Advertise Here


All times are GMT -7. The time now is 01:40.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.