Cruisers Forum
 


Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 31-10-2020, 11:52   #1
Registered User

Join Date: Jul 2020
Location: SoCal
Boat: Beneteau 323
Posts: 92
Need help: Yanmar 2GM20F wont start

Hi all,
I need some help figuring out how to get the engine started.

Events that preceded the issue:
We were out one day going on engine, it started losing RPMs and then stopped. Restarted it, it ran for 30 seconds and then stopped again. After another 2 tries called the tow (no wind, which is why we were using the engine).

At the doc discovered that fuel tank had slime and debris. Took out fuel tank, got rid of old fuel, cleaned it, replaced both fuel filters, put fresh fuel, put everything back together.

Closed the water intake valve, tried starting - won't start.
Tried to bleed air out of the fuel system - little pump on the side of the engine didn't seem to work or at least was taking forever. Tried to prime by lifting decompression valves and then start - turns, cranks, won't start.

Installed bulb type priming pump before first filter. Pumps fuel great, bled air out of first filter, bled air from the second filter, bled air from injector banjo bolts (for fuel return).

Engine cranks and when I let go of the start button - it sounds like it is trying to run, but won't catch/stay running.

Any ideas?


----------------
As i was trying to troubleshoot and figure out why it's not starting - noticed a few disconnected wires on the engine around alternator (i didn't disconnect them). Not sure if these are spare connections for something else or if i disconnected them accidentally (i don't believe so, I'm fairly careful)).

I don't see any other connectors where these could have been connected to, they won't mate with each other (all appear to be female) and no other random wires/connections hanging unused.

Red with white stripe, comes out of a harness








This one is from the top of the alternator




Blue wire from the harness.




Ideas?
George_SD is online now   Reply With Quote
Old 31-10-2020, 12:28   #2
Registered User

Join Date: Jul 2020
Location: SoCal
Boat: Beneteau 323
Posts: 92
Re: Need help: Yanmar 2GM20F wont start

UPDATE: Read the manual some more, moved throttle half way as directed, gave it 10 seconds of cranking and it finally fired up.

The question about the extra wires is still unresolved.
George_SD is online now   Reply With Quote
Old 31-10-2020, 14:39   #3
Certifiable Refitter/Senior Wannbe
 
Wotname's Avatar

Join Date: Jan 2008
Location: South of 43 S, Australia
Boat: C.L.O.D.
Posts: 11,862
Re: Need help: Yanmar 2GM20F wont start

Quote:
Originally Posted by George_SD View Post
UPDATE: Read the manual some more, moved throttle half way as directed, gave it 10 seconds of cranking and it finally fired up.

The question about the extra wires is still unresolved.
The connector with the red/white wire is for the rubber seal switch / alarm on the sail drive version.

The wire from the alternator is the 'W' terminal of the alternator. It is used when the tach signal is from the alternator. Not used on a 2GM20F.

The blue wire is used on the 1GM10 engine but I forgotten it's function. It is not used on the 2GM20F.
__________________
All men dream: but not equally. Those who dream by night in the dusty recesses of their minds wake in the day to find it was vanity: but the dreamers of the day are dangereous men, for they may act their dreams with open eyes, to make it possible. T.E. Lawrence
Wotname is online now   Reply With Quote
Old 31-10-2020, 17:33   #4
Marine Service Provider

Join Date: Sep 2014
Location: Auckland, NZ
Boat: Compass 790 , 7.9 metres or 26 ft
Posts: 1,898
Re: Need help: Yanmar 2GM20F wont start

Glad to hear you got it started.


Don't know how thoroughly you cleaned the tank but hope you put biocide in with new fuel & replaced deck fill cap o-ring as it will grow again if you didn't.
Compass790 is online now   Reply With Quote
Old 31-10-2020, 20:38   #5
Registered User

Join Date: Jul 2020
Location: SoCal
Boat: Beneteau 323
Posts: 92
Re: Need help: Yanmar 2GM20F wont start

Thank you for the info about the wires. Good to know it wasn’t me doing something wrong.

Yes, cleaned it well and added some fresh additives to keep it in good condition
George_SD is online now   Reply With Quote
Old 01-11-2020, 09:07   #6
Registered User

Join Date: Jan 2010
Location: on boat in south pacific
Boat: challenger 32, USSV Dharma
Posts: 60
Re: Need help: Yanmar 2GM20F wont start

Give it a good swift kick...worked with my ex husband...good kick and he started to work
ussvdharma is offline   Reply With Quote
Old 01-11-2020, 09:30   #7
running down a dream

Join Date: Mar 2006
Location: somewhere in the deep south
Boat: CD30 MKII
Posts: 2,222
Images: 6
Send a message via Yahoo to gonesail
Re: Need help: Yanmar 2GM20F wont start

Quote:
Originally Posted by George_SD View Post
UPDATE: Read the manual some more, moved throttle half way as directed, gave it 10 seconds of cranking and it finally fired up.

my yanmar mechanic said you should always advance the throttle for cold starts. then adjust when motor fires up. if only the Yanmar had glow plugs
__________________
some of the best times of my life were spent on a boat. it just took a long time to realize it

gonesail is offline   Reply With Quote
Old 02-11-2020, 07:25   #8
Registered User

Join Date: Oct 2014
Posts: 23
Re: Need help: Yanmar 2GM20F wont start

I imagine your bleeding the engine from the bleed screw on top of the filter. Your right in that the "dickey pump" is slow but they do work just takes time. You might also try cracking the nut on the top of the fuel pump before the fuel line goes to the injectors. Then actuate the dickey pump until fuel flow out then tighten everything and try starting. Should work. The 2gm yammers are pretty bullet proof. Good luck.
wmac is offline   Reply With Quote
Reply

Tags
2gm, 2gm20, yanmar

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yanmar 2gm20f manual hand crank start? Aklein620 Challenges 10 20-06-2020 03:43
YANMAR 1GM wont start...30 degrees CAPTNSTUMPY Engines and Propulsion Systems 28 09-12-2015 03:39
Yanmar 2GM20F, hard to start, won't idle MrSteve007 Engines and Propulsion Systems 0 26-05-2014 00:38
Recoil start outboard wont engage flywheel Soundtrackzz Engines and Propulsion Systems 3 28-07-2013 13:57
Battery charger wont't start jr_spyder Electrical: Batteries, Generators & Solar 11 15-12-2012 14:56

Advertise Here


All times are GMT -7. The time now is 18:52.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.