Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 28-12-2009, 12:47   #1
running down a dream
 
gonesail's Avatar

Join Date: Mar 2006
Location: somewhere in the deep south
Boat: cape dory 30 MKII
Posts: 2,496
Images: 6
Send a message via Yahoo to gonesail
Question Alternator Is Not Charging

I have a Link 2000-R with an ideal regulator along with 100 amp alternator that does not show voltage or amps while the engine is running. The red charge LED on the regulator is not on but the charge light on the Link 2000 is on. I checked the fuses and connections from regulator into the alternator and they were good. What else can I test before calling the doctor? Thanks.
__________________
some of the best times of my life were spent on a boat. it just took a long time to realize it

gonesail is offline   Reply With Quote
Old 28-12-2009, 13:31   #2
Registered User
 
Sailmonkey's Avatar

Join Date: Sep 2009
Location: Houston
Boat: '76 Allied Seawind II, 32'
Posts: 9,192
Does your tachometer work?
Sailmonkey is offline   Reply With Quote
Old 28-12-2009, 13:59   #3
running down a dream
 
gonesail's Avatar

Join Date: Mar 2006
Location: somewhere in the deep south
Boat: cape dory 30 MKII
Posts: 2,496
Images: 6
Send a message via Yahoo to gonesail
yes tachometer worked fine today.
__________________
some of the best times of my life were spent on a boat. it just took a long time to realize it

gonesail is offline   Reply With Quote
Old 28-12-2009, 14:02   #4
Registered User
 
Sailmonkey's Avatar

Join Date: Sep 2009
Location: Houston
Boat: '76 Allied Seawind II, 32'
Posts: 9,192
the quick and dirty sound like your regulator has died......I'd still check the voltage sense, field voltage, and power supply to the regulator. I'm not familar with this regulator, but it probably has an ignition hot wire going to it.
Sailmonkey is offline   Reply With Quote
Old 28-12-2009, 21:40   #5
Commercial Member
 
CharlieJ's Avatar

Cruisers Forum Supporter

Join Date: Dec 2008
Location: St. Petersburg, FL
Boat: Gulfstar Long Range Trawler; 53'; BearBoat
Posts: 1,260
Go to the Balmar site and find the owner's manual for the MC612 alternator regulator. The troubleshooting procedure in that manual will help you determine what component is not working.
__________________
Charlie Johnson
ABYC Master Technician
JTB Marine Corporation
"The Devil is in the details and so is salvation."
CharlieJ is offline   Reply With Quote
Reply

Tags
alternator

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alternator Not Charging Batteries pacmaann2 Electrical: Batteries, Generators & Solar 14 01-09-2009 09:18
XAR Digital Alternator Regulator - Over Charging paulsailorirish Electrical: Batteries, Generators & Solar 7 05-08-2009 14:50
Batteries Aren't Charging - Help! witzgall Electrical: Batteries, Generators & Solar 2 02-06-2009 11:49
1 alternator charging more than other ? gramos Electrical: Batteries, Generators & Solar 7 27-10-2008 10:37
Volvo alternator and charging sensor seafox Electrical: Batteries, Generators & Solar 2 23-07-2007 18:40

Advertise Here


All times are GMT -7. The time now is 15:08.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.