Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 21-05-2019, 21:30   #1
Registered User

Join Date: May 2010
Location: San Francisco, USA
Boat: 1976 Islander 36 - Geja
Posts: 31
Waypoint not received from Garmin GPS

Hi, I'm trying to transition from MacENC to OpenCPN 5 on my MacBook Air. I can't figure out the following required feature:

My GPS source is a Garmin 180 or 72 at the helm. OpenCPN receives position data just fine. When I do GOTO WAYPOINT on the Garmin, OpenCPN does not seem to do anything with this information.

With MacENC, upon hitting GOTO WAYPOINT on the Garmin, a little window pops up with the waypoint name, distance, XTE, VMG, etc. And MacENC draws the path on the chart. This just happens automatically - never had to configure a thing.

NMEA headers for the active waypoint seem to be GPBOD, GPRTE, GPWPL.

Anybody with a solution for me?

I've also had zero luck sending waypoints to the Garmin 180 from OpenCPN. MacENC sends multiple waypoints at once without flaw.

Cheers,
Andrew
www.SailGeja.com
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2019-05-16 at 1.11.44 PM.png
Views:	67
Size:	324.0 KB
ID:	192499  
andrewvik is offline   Reply With Quote
Old 22-05-2019, 01:41   #2
Registered User

Join Date: May 2014
Boat: Shuttleworth Advantage
Posts: 2,344
Images: 3
Re: Waypoint not received from Garmin GPS

I use both 128 and 76 with OpenCPN

These threads may help.

http://www.cruisersforum.com/forums/...in-128119.html

http://www.cruisersforum.com/forums/...rs-193386.html

I typically use O for route plotting and then upload to GPS and subsequently goto on the AP. The acquired WP then displays as active on O.

You may need to check "output on this port (for AP or NMEA)" in settings - connections.

There is an issue with early Garmin in way they accept wp / routes.
Tupaia is offline   Reply With Quote
Old 19-04-2020, 00:43   #3
Registered User

Join Date: May 2010
Location: San Francisco, USA
Boat: 1976 Islander 36 - Geja
Posts: 31
Re: Waypoint not received from Garmin GPS

Tupaia, thanks so much, the first link you mentioned was a great help! I'm now able to upload waypoints with ease, and entire routes (in a clumsy workaround).

But... when I activate a waypoint in the Garmin 76, there is no reaction in OpenCPN. MacENC, and my ST4000+ autopilot receive all of the DTW, XTE, etc. info just fine.

How do you get the WP to display as active in O, as you wrote above?

Cheers!
Andrew
www.SailGeja.com
andrewvik is offline   Reply With Quote
Old 19-04-2020, 07:26   #4
Registered User

Join Date: May 2014
Boat: Shuttleworth Advantage
Posts: 2,344
Images: 3
Re: Waypoint not received from Garmin GPS

Hi Andrew,

Although I use both GPS's only the 128 is wired in so not sure if the 'Active WP' works with the 76. In the case of the 128 the 'Active WP' MIGHT only show on OCPN when the AP is actually in TRACK mode and or the GPS is in GOTO mode. I am unable to get to the boat at the moment (CV19) so if the above doesn't solve it here are a couple of things that might help. Can't remember but could be down to 'repeater setting' or feedback signals see below.

1. I seem to 'remember' that there was an issue with the connection setup with OCPN. Play around with these first.

Use Garmin GRMN (Host) mode for uploads - NOT Checked
Use Garmin (GRMN) mode for input - NOT Checked
Output on this port (as autopilot or NMEA repeater) - IS Checked

2. My ST5000 (this is the same as ST4000 with different firmware) is connected through Raymarine e85001 interface and there are several ways of wiring the PC/AP/GPS to this.
Tupaia is offline   Reply With Quote
Reply

Tags
garmin, gps

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help to send a waypoint or a route to a GPS or autopilot Gilletarom OpenCPN 0 29-01-2018 03:06
Route and waypoint transfer to Garmin 76xx chartplotters patja OpenCPN 8 08-11-2017 15:40
Send to GPS waypoint name truncated adwuk OpenCPN 3 30-03-2016 14:55
Garmin GPS 152 will not calculate tide data after 01/01/2012 ajchan Navigation 0 11-06-2013 15:59
Is Garmin GARMIN/GARMIN (Host) Mode Working ? Sail323 OpenCPN 13 13-11-2010 06:36

Advertise Here


All times are GMT -7. The time now is 19:20.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.