Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 20-05-2024, 23:48   #1
Registered User

Join Date: Apr 2009
Location: Staging in Honolulu before sailing to Vancouver this summer
Boat: Southern Cross 35
Posts: 77
OpenCPN 5.8.4 OpenGL stopped working !

OpenCPN 5.8.4
Window 11
New Levono IdeaPad Slim 5 16IRU9 with Intel(R) Graphics


W11 out of the box, OpenCPN was installed with a set of MBTile Charts copies from my old Laptop. All was working fine for a few hours and then, OpenCPN stopped displaying those charts.

OpenCPN manual does mention some issues with OpenGL and Microsoft, so I have updated the Graphics Card Driver with the latest Intel...no avail...same issue.

Why was it working fine and then it stopped?

The only change between working and not working is an W11 automatic update... but this Update did not made any change to the Graphic Card Driver.

According to GPU Cap Viewer, the Intel(R) Grahics Card supports OpenGL.

The sole purpose of this new Laptop is to run OpenCPN... I am not in a happy place now with this issue... Last resort, I will drop W11 and install a Linux OS and see if this works... but before committing to this plan that might not solve the issue, I would appreciate hearing from anyone who have a good understanding of the OpenGL issues on W11 to help me solve this impasse.
Attached Thumbnails
Click image for larger version

Name:	Screenshot 2024-05-21 054943.jpg
Views:	18
Size:	237.8 KB
ID:	290104   Click image for larger version

Name:	Screenshot 2024-05-21 064607.png
Views:	25
Size:	33.9 KB
ID:	290105  

__________________
Serge
spirare is offline   Reply With Quote
Old 21-05-2024, 00:36   #2
Registered User

Join Date: Apr 2009
Location: Staging in Honolulu before sailing to Vancouver this summer
Boat: Southern Cross 35
Posts: 77
Re: OpenCPN 5.8.4 OpenGL stopped working !

UPDATE
I found that OpenGL has been mysteriously disactivated in opencpn.ini !!!!
After enabling it again, the MBTile are being displayed again just fine.
OpenGL=1
DisableOpenGL=0
__________________
Serge
spirare is offline   Reply With Quote
Old 21-05-2024, 05:44   #3
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 4,194
Re: OpenCPN 5.8.4 OpenGL stopped working !

Serge..
I may have seen the same sometimes. I think it's a bug in o 5.8.4 corrected in coming 5.10.
Good report that others may be able to benefit from.
Hakan is offline   Reply With Quote
Old 01-06-2024, 10:12   #4
Registered User

Join Date: Apr 2009
Location: Staging in Honolulu before sailing to Vancouver this summer
Boat: Southern Cross 35
Posts: 77
Re: OpenCPN 5.8.4 OpenGL stopped working !

Quote:
Originally Posted by Hakan View Post
Serge..
I may have seen the same sometimes. I think it's a bug in o 5.8.4 corrected in coming 5.10.
Good report that others may be able to benefit from.

It just happen again on a short overnight between two islands in Hawaii !
Opencpn stopped displaying the mbtiles charts and OpenGL was disables on opencpn.ini

The value off "OpenGL entry" in opencpn.ini had to be manually edited to re-enable OpenGL and mbtiles charts to be displayed.


Any suggestion for a temporary fix before 5.10
__________________
Serge
spirare is offline   Reply With Quote
Old 01-06-2024, 21:07   #5
Registered User

Join Date: Aug 2009
Location: Onboard, currently cruising in SE Asia
Boat: St. Francis 44 Mk II (Catamaran)
Posts: 183
Send a message via Skype™ to SoggyPaws
Re: OpenCPN 5.8.4 OpenGL stopped working !

I have seen this reported recently by several users. Somehow this keeps getting turned off. I don't seem to have the problem on either W10 or W11. The W11 machine is always on, but rebooted every night, latest windows updates and graphic driver updates. But there have been a rash of reports on the OpenCPN Users FB group. Since 5.8.4 isn't new, can't imagine why this has just started happening (in the last month).
SoggyPaws is offline   Reply With Quote
Old 03-06-2024, 14:50   #6
Registered User

Join Date: Apr 2009
Location: Staging in Honolulu before sailing to Vancouver this summer
Boat: Southern Cross 35
Posts: 77
Re: OpenCPN 5.8.4 OpenGL stopped working !

Quote:
Originally Posted by SoggyPaws View Post
I have seen this reported recently by several users. Somehow this keeps getting turned off. I don't seem to have the problem on either W10 or W11. The W11 machine is always on, but rebooted every night, latest windows updates and graphic driver updates. But there have been a rash of reports on the OpenCPN Users FB group. Since 5.8.4 isn't new, can't imagine why this has just started happening (in the last month).

Thank you for your report.


It happened again this morning...totally annoying considering some users like my friend currently using OpenCPN under W11 does not have the computer skills to edit the configuration file each time this happens.


By the way, once should not have to reboot daily W11 just to keep it working... But just to be clear, rebooting does not reset the opencpn.ini openGP settings.
__________________
Serge
spirare is offline   Reply With Quote
Old 04-06-2024, 06:35   #7
Registered User

Join Date: Aug 2009
Location: Onboard, currently cruising in SE Asia
Boat: St. Francis 44 Mk II (Catamaran)
Posts: 183
Send a message via Skype™ to SoggyPaws
Re: OpenCPN 5.8.4 OpenGL stopped working !

Quote:
Originally Posted by spirare View Post
By the way, once should not have to reboot daily W11 just to keep it working... But just to be clear, rebooting does not reset the opencpn.ini openGP settings.
I think my problem on my current machine is not related to Windows 11. I think it is due to a cheap Chinese mini pc that has faulty memory. More than about 8 hours of run time, and Explorer (and several other things) stop working. I don't think this is a Windows issue. So I automatically reboot the machine just after midnight.

I don't have the technical skills, nor the time right now, to track it down precisely. OpenCPN is pretty flakey on this machine too. But IMHO there would be more people screaming about W11 if it were really a W11 problem. When I get unlimited internet in a quiet (non-navigational setting), I'll upgrade one of my lknown-stable aptops to W11 and see how it does in a 24x7 runtime environment with OpenCPN and node-red (running our electrical system monitoring).
SoggyPaws is offline   Reply With Quote
Reply

Tags
enc, opencpn, work

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solar Boost 200E Stopped Working MarkJ Electrical: Batteries, Generators & Solar 33 07-07-2016 13:17
OpenCPN 3.3.2028 VMH Charts Working but a new OpenGL problem Rasbats OpenCPN 6 06-09-2014 13:49
OpenCPN has Stopped Working LifePart2 OpenCPN 11 31-07-2013 00:12
HELP! My Toilet Pump Stopped Working lorenzo b Plumbing Systems and Fixtures 10 22-02-2010 06:28

Advertise Here


All times are GMT -7. The time now is 19:07.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.