Cruisers Forum
 


Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-12-2021, 19:28   #46
Registered User
 
yachtvalhalla's Avatar

Join Date: Aug 2009
Location: Philippines
Boat: Fuji 32 Ketch
Posts: 940
Re: OpenCPN 5.6.0 Released

Quote:
Originally Posted by HeywoodJ View Post
Terry,

The black, vaguely ship-shaped polygon around each of your AIS icons is the “real size” representation. Ship static data includes the position of the AIS port/starboard of centerline and fore/aft. That is where the green standard icon is shown, the dimensions of the ship as received in the static data are then used to draw an outline around the regular icon that is the approximate size of the ship. That outline is the black “rectangle” with an angled end for the bow that is around each of the icons.
Got it and feeling stupid for not noticing that. Must zoom way in to see.
Thanks, Terry
yachtvalhalla is offline   Reply With Quote
Old 11-12-2021, 23:33   #47
Registered User

Join Date: Aug 2016
Location: Stockholm, Sweden
Posts: 201
Re: OpenCPN 5.6.0 Released

Phil,

I don't think thia is related to 5.6.0 so let's continue this in the correct thread: https://www.cruisersforum.com/forums...er-241659.html
/Lennart
LennartG is offline   Reply With Quote
Old 12-12-2021, 10:51   #48
Registered User

Join Date: Feb 2020
Boat: Dehler 35 CWS
Posts: 8
Re: OpenCPN 5.6.0 Released

Hello OCP team,


Congratulations with this milestone, nice work again!


However, I'm afraid I have a new bug. I logged it at FlySpray (ID 2811: https://opencpn.org/flyspray/index.p...s&task_id=2811) but not sure where to best report. Hence also here my message.
Every now and then I get a popup box, saying:
ASSERT INFO:
/usr/include/wx-3.0/wx/math.h(151): assert "x > INT_MIN - 0.5 && x < INT_MAX + 0.5" failed in wxRound(): argument out of supported range


I can close the popup with the "Continue" button but it keeps on coming for some 10-20 times, after which it finally shuts up. Until it starts again. Sometimes after a few minutes, sometimes after an hour or so.
I also added the backtrace; it seems like something to do with wxWidget 3.0.


Hopefully someone can assist me here.


Best regards,


Mark
Sindbad2p0 is offline   Reply With Quote
Old 12-12-2021, 14:16   #49
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 3,529
Re: AIS Target size?

Quote:
Originally Posted by yachtvalhalla View Post
Hakan,
Can we see a screen shot of yours showing real size of the targets?

Thanks, Terry
Terry.. Sorry, delayed but yes here's my shot from Win10 but it's the same on RPi.
Håkan
Attached Thumbnails
Click image for larger version

Name:	ais_size.jpg
Views:	78
Size:	279.5 KB
ID:	249739  
Hakan is offline   Reply With Quote
Old 14-12-2021, 06:56   #50
Registered User

Join Date: Feb 2020
Boat: Dehler 35 CWS
Posts: 8
Re: OpenCPN 5.6.0 Released

Quote:
Originally Posted by Sindbad2p0 View Post
Hello OCP team,


Congratulations with this milestone, nice work again!


However, I'm afraid I have a new bug. I logged it at FlySpray (ID 2811: https://opencpn.org/flyspray/index.p...s&task_id=2811) but not sure where to best report. Hence also here my message.
Every now and then I get a popup box, saying:
ASSERT INFO:
/usr/include/wx-3.0/wx/math.h(151): assert "x > INT_MIN - 0.5 && x < INT_MAX + 0.5" failed in wxRound(): argument out of supported range


I can close the popup with the "Continue" button but it keeps on coming for some 10-20 times, after which it finally shuts up. Until it starts again. Sometimes after a few minutes, sometimes after an hour or so.
I also added the backtrace; it seems like something to do with wxWidget 3.0.


Hopefully someone can assist me here.


Best regards,


Mark

Hello,


Again, not sure if this is the right place to post my message, bear with me. Anyway, in addition to the above mentioned Assert message, I sometimes also get similar types of popup's with different messages. Below a copy of a backtrace:


ASSERT INFO:
../include/wx/datetime.h(1740): assert "IsValid()" failed in GetTicks(): invalid wxDateTime

BACKTRACE:
[1] wxDateTime::IsDST(wxDateTime::Country) const
[2] wxDateTime::MakeTimezone(wxDateTime::TimeZone const&, bool)
[3] PlugInManager::SendPositionFixToAllPlugIns(Generic PosDatEx*)
[4] MyFrame::OnFrameTimer1(wxTimerEvent&)
[5] wxAppConsoleBase::CallEventHandler(wxEvtHandler*, wxEventFunctor&, wxEvent&) const
[6] wxEvtHandler::ProcessEventIfMatchesId(wxEventTable EntryBase const&, wxEvtHandler*, wxEvent&)
[7] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[8] wxEvtHandler::TryHereOnly(wxEvent&)
[9] wxEvtHandler::ProcessEventLocally(wxEvent&)
[10] wxEvtHandler::ProcessEvent(wxEvent&)
[11] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[12] wxTimerImpl::SendEvent()


In common with my other message: wx seems to be involved.


As said, these messages are actually completely blocking the proper use of OCP. I hope someone can help me with a solution.




Best regards,


Mark
Sindbad2p0 is offline   Reply With Quote
Old 14-12-2021, 07:35   #51
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 6,758
Re: OpenCPN 5.6.0 Released

Mark....
The ASSERT is probably happening in a plugin.
Please disable all plugins. Then re-enable one-by-one, until the error occurs. That way we can identify exactly which plugin is not playing nice.


Thanks
Dave
bdbcat is offline   Reply With Quote
Old 14-12-2021, 08:02   #52
Registered User

Join Date: Feb 2020
Boat: Dehler 35 CWS
Posts: 8
Re: OpenCPN 5.6.0 Released

Hello Dave,


That makes sense. I have my pi now here with me at home, without all the instruments connected to it, so I cannot replicate all errors which I might have had on board.

But anyway starting in safe mode and switching on plugins quickly revealed that "Dashboard_tactics" is the one which causes problems.
I use this one instead of the regular Dashboard with the sole purpose of also showing a polar percentage speed in addition to the regular instruments. So for me it's rather straightforward to just switch back to the normal "Dashboard" plugin.
I remember that I also had some issues with installing the plugin, some year ago. Might it be that's not a fully supported plugin?


Anyway thanks for your hint; I now seem to have an accepable solution (I can live without a polar percentage meter). And I hope that this info helps you guys as well.


Brgds,


Mark
Sindbad2p0 is offline   Reply With Quote
Old 14-12-2021, 08:19   #53
Registered User

Join Date: Feb 2020
Boat: Dehler 35 CWS
Posts: 8
Re: OpenCPN 5.6.0 Released

Hello,


One addition: I just found out that also the "Tactics" plugin shows the Assert popups.


Best regards,


Mark
Sindbad2p0 is offline   Reply With Quote
Old 15-12-2021, 08:16   #54
Registered User

Join Date: Mar 2020
Posts: 3
Re: OpenCPN 5.6.0 Released

Just installed OpenCPN 5.6.0 on windows 10 laptop.

I can not change the speed on Legs in Route & Mark Manager like I used to by double clicking the speed for a Leg.

I must now open each Waypoints Property and change it on the Extended tab.

What's the fix?

Brent
Brent63 is offline   Reply With Quote
Old 15-12-2021, 08:33   #55
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 3,529
Re: OpenCPN 5.6.0 Released

Brent...
Confirmed on Win10 and RPi

I can change the total route's "Planned speed" but not on any legs row. If edited on Win it falls back to default on enter.
In properties for a included waypoint I can add a speed in the empty(?) field and it stays there and it's also used for route calculations.
What I can see is there no user fix to make it easier to edit.
Hakan is offline   Reply With Quote
Old 15-12-2021, 09:05   #56
Registered User

Join Date: Mar 2020
Posts: 3
Re: OpenCPN 5.6.0 Released

I had OpenCPN 5.2.4 installed this morning and was able to now with 5.6.0 I can't.

May need to revert back...

Brent
Brent63 is offline   Reply With Quote
Old 19-12-2021, 06:32   #57
Registered User

Join Date: Oct 2014
Location: Netherlands
Boat: Halmatic 30
Posts: 897
Re: OpenCPN 5.6.0 Released

Quote:
Originally Posted by verkerkbr View Post
There was a problem with OpenGL in the RaspiOS 64 Debian Bullseye.

But after installing the next file. OpenCPN 5.6.0 screen movements run very fast with the OpenGL setting to on.

sudo apt install python3-opengl

There is now a new version of the 64 bits RaspiOS based on Debian Bullseye.



There was still a problem with the Ubuntu OS Impish no GPS usb ports. But with the latest updated version this problem is also solved.


Now running OpenCPN 5.6.0 (flatpak) on the RaspiOS Bullseye version and on the Ubuntu Impish version. Both with the Oesenc plugin and the Oesenc Charts. All on the RPI 2 Gb. Not only from SD, but also from USB stick 3.1 and SDD.


verkerkbr is offline   Reply With Quote
Old 19-12-2021, 16:27   #58
Registered User

Join Date: Jan 2019
Posts: 23
Re: OpenCPN 5.6.0 Released

Hi Running opencpn on ubuntu 20.04. Upgrade to 5.6 and get warning of unstable oesenc pluging 4.2. Error said it will not load oesenc. So tried to reload using sudo apt-get install oesenc and get error as below
The following NEW packages will be installed:
oesenc-pi
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/593 kB of archives.
After this operation, 2292 kB of additional disk space will be used.
(Reading database ... 214440 files and directories currently installed.)
Preparing to unpack .../oesenc-pi_4.0.10-0~focal1_arm64.deb ...
Unpacking oesenc-pi (4.0.10-0~focal1) ...
dpkg: error processing archive /var/cache/apt/archives/oesenc-pi_4.0.10-0~focal1_arm64.deb (--unpack):
trying to overwrite '/etc/udev/rules.d/98-sglock.rules', which is also in package oesenc_pi 4.2.14
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/oesenc-pi_4.0.10-0~focal1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can you help or should I revert to my working 5.4 ?
georgetina is offline   Reply With Quote
Old 19-12-2021, 18:55   #59
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 6,758
Re: OpenCPN 5.6.0 Released

georgetina...
Plugin installation by debian package (using apt-get, etc.) is no longer supported.
Plugins are now installed by Options->Plugins. Refresh the master catalog, then select and install the latest version of oeSENC_PI.


Thanks
Dave
bdbcat is offline   Reply With Quote
Old 19-12-2021, 23:47   #60
Registered User

Join Date: Jan 2018
Location: Gold Coast, Australia
Boat: Lagoon 500
Posts: 146
Re: OpenCPN 5.6.0 Released

There is an issue with CM93 charts and OCN5.6.0 on a Mac.
If you drag the chart around the screen, the chart does not redraw/refresh - see attached.
It only occurs with CM93 charts, even when they are all that is installed on a clean new installation.
Attached Files
File Type: pdf Screen Shot 2021-12-19 at 20.37.10.png.pdf (908.2 KB, 25 views)
kevinvh is offline   Reply With Quote
Reply

Tags
enc, lease, opencpn

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Beta Version 3.1.814 Released bdbcat OpenCPN 185 14-09-2012 07:43
OpenCPN Beta Version 3.1.802 Released bdbcat OpenCPN 158 14-08-2012 10:07
OpenCPN Beta Version 3.1.714 Released bdbcat OpenCPN 91 01-08-2012 17:08

Advertise Here


All times are GMT -7. The time now is 03:11.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.