Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 15-03-2018, 16:46   #1
Registered User

Join Date: Apr 2016
Posts: 21
OpenCPN 4.99 not compatible with any plugins?

Just built the latest github clone, but cant install any plugins. I thought OpenCPN was supposed to be backward compatible with plugins!? I guess I just wasted a bunch of time?
__________________

THEMuffinMan7 is offline   Reply With Quote
Old 15-03-2018, 17:29   #2
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 5,985
Re: OpenCPN 4.99 not compatible with any plugins?

TheMuffinMan...

As we have said often, the github master branch is an untested sandbox full of new code, interfaces, and ideas. We have never asserted that it works usefully on any given day. And we won't so assert until we actually go to Beta test on something.

That said, on any given day master branch will build (thanks to C.I process), and experienced testers on the bleeding edge can give us useful feedback.

I suppose you are building for Windows? We know that Plugins for Windows will need re-building for 4.99 due to the wxWidgets API update. This will be an unavoidable speed bump, I'm afraid. But necessary in order to stay current with wxWidgets advances.

Thanks
Dave
__________________

bdbcat is offline   Reply With Quote
Old 15-03-2018, 17:58   #3
Registered User

Join Date: Apr 2016
Posts: 21
Re: OpenCPN 4.99 not compatible with any plugins?

Thanks for the response. I get it, it was mostly was a mistake on my part for checking out the latest source. Had some troubles getting it to build and everything and so spent some time on it.. Now reverting to 4.8.2. Also wanted to confirm that there wasn't some known way to get 4.99 to support older plugins - sounds like not.

Cheers
THEMuffinMan7 is offline   Reply With Quote
Old 15-03-2018, 18:12   #4
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 13,958
Re: OpenCPN 4.99 not compatible with any plugins?

The posts below, have confirmed to me without any doubt, we are astride two islands at the moment.

Old World
OpenCPN v4.8.2 & Plugins, API 1.15, wxWidgets 3.0.2, MSVC++2013 or other tools. Advantage: Plugins for Opencpn can be compiled and run.

New World
OpenCPN v4.99 & no external Plugins, API 1.16(?), wxWidgets 3.1.1, MSVC++2017 or other tools. Advantage: Compile at the current Master Head.

Is this correct?

IMHO There are still some plugins that need some final work in order to "pack v4.8.2 away" as "history". Indeed a few PI have had some significant improvements and changes and need a chance to settle in.
rgleason is offline   Reply With Quote
Old 16-03-2018, 05:50   #5
Registered User
 
pinguino's Avatar

Join Date: May 2009
Location: SE Spain
Boat: Jeanneau SO 32I
Posts: 94
Re: OpenCPN 4.99 not compatible with any plugins?

I compiled last week the 499. with support for MBTiles in an Rpi with OpenPlotter and the plugins work correctly. Even the oesENC mapping plugin.

I suppose it will be a problem related to the compilation for windows because in the Rpi everything seems to work... even the support for MbTiles, more or less...
pinguino is offline   Reply With Quote
Old 16-03-2018, 07:19   #6
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 13,958
Re: OpenCPN 4.99 not compatible with any plugins?

Pinguino, I guess you are right about Linux, when you have recompiled and installed all the plugins as a part of the process of compiling 4.99. Linux has a nice setup for users.

Windows is a little different. All the plugins need to be recompiled with the new API, which is not done on user's machines normally.

The reason this is necessary is every time wxWidgets is changed (IE wxWidgets 3.0.2 to 3.1.1 in Opencpn v4.99) the old Plugins lose forward compatibility and the newer compiled plugins (with wxWidgets 3.1.1) do not work with the older version of OpenCPN.

Nice to know it works for you (and those compiling Linux)!

For the time being I am going to stick with compiling PI for v4.8.2 using wxWigets 3.0.2 because there are still Plugins that are being improved, debugged and updated with the most recent language files etc.

I am stating to wonder if we should not have all the 4.8.2 PI archived somewhere, or remain available on the website for awhile when we do start compiling them for the next version.
rgleason is offline   Reply With Quote
Old 16-03-2018, 07:20   #7
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,228
Re: OpenCPN 4.99 not compatible with any plugins?

Quote:
Originally Posted by pinguino View Post
I compiled last week the 499. with support for MBTiles in an Rpi with OpenPlotter and the plugins work correctly. Even the oesENC mapping plugin.

I suppose it will be a problem related to the compilation for windows because in the Rpi everything seems to work... even the support for MbTiles, more or less...
At this moment the incompatible changes are present only on Windows and macOS, Linux stays with wx3.0. For now.
nohal is offline   Reply With Quote
Old 03-04-2018, 21:57   #8
Registered User

Join Date: Sep 2012
Location: Baikal
Posts: 453
Re: OpenCPN 4.99 not compatible with any plugins?

How to compile plug-ins for 4.99 for Windows?

upd//
added file opencpn.lib in the folder with built-in plug-ins, everything was compiled and works under Win
Baikal is online now   Reply With Quote
Old 08-04-2018, 16:27   #9
Registered User

Join Date: Feb 2011
Posts: 691
Re: OpenCPN 4.99 not compatible with any plugins?

It does work (4.99.0); but why did you change all the fonts settings?
It does not make sense to do that.
Windows 10 Pro ed. up to date.
P_Dub is offline   Reply With Quote
Old 08-04-2018, 17:05   #10
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 5,985
Re: OpenCPN 4.99 not compatible with any plugins?

P_Dub...

Fonts not changed intentionally.
Do you have any font change examples, please?

Thanks
Dave
bdbcat is offline   Reply With Quote
Old 08-04-2018, 17:49   #11
Registered User

Join Date: Feb 2011
Posts: 691
Re: OpenCPN 4.99 not compatible with any plugins?

I ended up with Arial 13 as compare to Calibri 10. Secondly the appearane on the screen was way oversize for the picture (buoys, names, etc. Thridly, I got fed up and did remove it from my system. It was working ok, but not for a scrren size of 15 inches.
P_Dub is offline   Reply With Quote
Old 08-04-2018, 17:57   #12
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,228
Re: OpenCPN 4.99 not compatible with any plugins?

Quote:
Originally Posted by P_Dub View Post
I ended up with Arial 13 as compare to Calibri 10. Secondly the appearane on the screen was way oversize for the picture (buoys, names, etc. Thridly, I got fed up and did remove it from my system. It was working ok, but not for a scrren size of 15 inches.
P_Dub...

Just to understand: You ended up having to switch the font to Arial 13 or the fonts were switched for you?
The appearance of what (fonts, boat icons (for own ship? For AIS targets? Both?), everything?) was oversize for the picture (what does this mean?) Are you aware of the scaling factor logic extended in 4.8.2 (Toolbox -> User interface tab)? What settings are you using there? Is the size of your screen (Toolbox->Display->Advanced) detected correctly?
By any chance do you have a screenshot?

As usually, if we do not know what exactly needs our attention, we will not be able to pay attention to it and you will stay pissed for much longer.

Pavel
nohal is offline   Reply With Quote
Old 09-04-2018, 04:32   #13
Registered User

Join Date: Feb 2011
Posts: 691
Re: OpenCPN 4.99 not compatible with any plugins?

I have an idea, I thing this might have been done by my Windows defender.
If you dont turn it off for the installation it might be trouble.
As far as using the functionality of the program, there is no problems.
One thing I would like is having the course indicated (000į)
normally above the course line.
Best Regards.
P_Dub is offline   Reply With Quote
Old 09-04-2018, 05:48   #14
Registered User

Join Date: Feb 2011
Posts: 691
Re: OpenCPN 4.99 not compatible with any plugins?

That was the problem. swith off the Windows defender for the installation and it is OK.
__________________

P_Dub is offline   Reply With Quote
Reply

Tags
enc, opencpn, plug

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opencpn plugins not installing on macbook pro Michel88 OpenCPN 1 21-01-2018 20:41
Installateur de plugins, Install software for plugins. Gilletarom OpenCPN 3 30-04-2013 05:57
USB dongle gps compatible with opencpn on mac Dieterdong OpenCPN 0 10-04-2013 22:40
AIS Receiver Compatible with OpenCPN yanuar OpenCPN 6 24-04-2011 19:06
Bahamas / Caribbean Charts Compatible with OpenCPN EpicAdventure OpenCPN 13 28-03-2011 10:42

Advertise Here


All times are GMT -7. The time now is 22:28.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.