Cruisers Forum
 


Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 28-02-2017, 05:24   #1
Registered User
 
pendragon's Avatar

Join Date: Aug 2008
Boat: Van de Stadt 38"
Posts: 125
OpenCpn 4.4 showing green world no CM93charts

I have used OpenCpn for many years and installed it on various laptops from XP to Win7 & 10 and always had success, until now.
The latest install is v4.4 on a T410 lenovo Win10 64bit and I cannot get the CM93 vector charts to display. Clicking "Scan charts and update database" and "Force full database rebuild" have no effect and both only run for a fraction of a second, which is too fast for rebuilding.
Also there is no yellow bar on the bottom of the screen..My suspicion is that there is a wrong setting in the registry??
I don't really know where to look anymore . Tried Versions 4.0.0 and 3.02 also, but both give the same results eg No charts showing
Can anyone shed a light on the subject?? ...>Many thanks for any help
pendragon is offline   Reply With Quote
Old 28-02-2017, 06:01   #2
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,960
Re: OpenCpn 4.4 showing green world no CM93charts

pendragon...
One more thing to try...
in tools>options>charts>Chart files. Select your CM93 directory and "Remove selected".
Then "Add directory" and point to e.g. "C:\Users\admin\Documents\Charts\CM93\" or where you have your CM files stored. (Check that the directory really has a bunch of directories and files) Click "Apply".
Check your "Chart Groups" that they are up to date or use "Chart Groups -> All active charts" in Canvas right click menu.
If not succeed check what opencpn.log - file says about charts loading.
Håkan
Hakan is offline   Reply With Quote
Old 01-03-2017, 01:40   #3
Registered User
 
pendragon's Avatar

Join Date: Aug 2008
Boat: Van de Stadt 38"
Posts: 125
Re: OpenCpn 4.4 showing green world no CM93charts

Hakan, thanks for the reply
I checked what you suggested and all is as per normal and in the right place.
The log states "Extract: toolbox-vectorcharts-24324.png... 100%"
The entrees regarding the charts are identical in Windows 7 and windows 10 laptops. Yet it works fine in Win7 64bit and Not in Win 10 (both run version OpenCpn 3.02).

I have 2 IBM laptops running Windows 10 64bit prof. V 302 Opencpn and both show ablack background with purple outlines of N Europe. both logs are the same
I think that there is some setting in Windows 10, that needs to change
pendragon is offline   Reply With Quote
Old 01-03-2017, 02:16   #4
Registered User
 
pendragon's Avatar

Join Date: Aug 2008
Boat: Van de Stadt 38"
Posts: 125
Re: OpenCpn 4.4 showing green world no CM93charts

There are 2 logs, an install log and a OpenCPN log
In C:\program data\opencpn\opencpn.log states that "Failed to open E:\CM93 for reading (error 5: access denied.). So it is Windows 10 that is screwing it up.
How to get access??
pendragon is offline   Reply With Quote
Old 01-03-2017, 02:32   #5
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,960
Re: OpenCpn 4.4 showing green world no CM93charts

Well, I'm using a couple of Win10 w/o problem.
But what about proceed by updating your OCPN to a more modern version?
O 4.4 is the latest release and 4.6 soon to come after Beta test completion of 4.5.
https://opencpn.org/OpenCPN/info/downloads.html
After a update from version 3 it may be necessary to also update any plugins not included in the core package. Dashboard, WMM, Grib and Chartloader are all included. If you use any other check the download page for updates.

The "Failed to open E:\CM93 for reading (error 5: access denied.)" I've never seen. For me it could be a user account properties in Win10? Are there any Win10 user restrictions for disk E:/? If it's not solved in OCPN v4.4 try run OCPN as administrator or change your Win10 user account to Admin rights.
Håkan
Hakan is offline   Reply With Quote
Old 01-03-2017, 03:07   #6
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 2,145
Re: OpenCpn 4.4 showing green world no CM93charts

Nobody knows what your device E:\ is. It might be a harddisk partition, an USB stick, a CD-ROM or whatever else. Please explain to get help.

Gerhard
CarCode is online now   Reply With Quote
Old 01-03-2017, 14:20   #7
Registered User
 
pendragon's Avatar

Join Date: Aug 2008
Boat: Van de Stadt 38"
Posts: 125
Re: OpenCpn 4.4 showing green world no CM93charts

E: is a partition dedicated to charts only. This partition in on the same HDD as where the OS WIN 10 is located. thanks
pendragon is offline   Reply With Quote
Old 01-03-2017, 17:46   #8
Registered User
 
pendragon's Avatar

Join Date: Aug 2008
Boat: Van de Stadt 38"
Posts: 125
Re: OpenCpn 4.4 showing green world no CM93charts

I have just installed MaxSea v10 using the CM93 charts in partition E: , and it works perfectly.
Because of this , I must conclude that there is a conflict between OpenCpn and Windows 10 64 bit .
As I mentioned before OCpn works fine in XP, Vista, Win 7 32 or 64 bit
Any insight please??
pendragon is offline   Reply With Quote
Old 01-03-2017, 19:17   #9
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 6,178
Re: OpenCpn 4.4 showing green world no CM93charts

pendragon...

Pretty sure this is not an OCPN problem. Lots of Win10/64 users out there.

Try Google, search term "win10 failed to open access denied".

Lots of good, relevant reading there, and things to try.

Thanks
Dave
bdbcat is offline   Reply With Quote
Old 01-03-2017, 22:52   #10
Registered User
 
pendragon's Avatar

Join Date: Aug 2008
Boat: Van de Stadt 38"
Posts: 125
Re: OpenCpn 4.4 showing green world no CM93charts

bdbcat. "win10 failed to open access denied" relates to users who want to access a file or folder. Many online solutions are given to in essence: Take OWNERSHIP, That;s all good and well, but I can access the cm93 folder without any problems,
Earlier today I installed MaxSea v 10, it runs perfectly (showing the same cm93 charts & GPS position) .But Ocpn fails to do so..???
One of my laptops Win10, used to run Ocpn without any problems using the same cm93 charts. On firing it up last week, Ocpn won't run.
The other lappy also win 10 (new install): ocpn refuses to show the charts as well. I installed MaxSea here also, and it works,.... It;s got me beat............
pendragon is offline   Reply With Quote
Old 02-03-2017, 08:23   #11
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 6,178
Re: OpenCpn 4.4 showing green world no CM93charts

pendragon...

Lets see some logfile entries related to chart loading, please.

re:
One of my laptops Win10, used to run Ocpn without any problems using the same cm93 charts. On firing it up last week, Ocpn won't run.

Hmmm...
This makes me think of Win10 update problem of some sort.

You could try OCPN 4.0.0, but I would be very surprised if there is any difference.

Or, you could try temporarily moving the cm93 to c:\, as a test case.

Thanks
Dave
bdbcat is offline   Reply With Quote
Old 02-03-2017, 09:24   #12
Marine Service Provider

Join Date: Apr 2008
Location: La la Land
Boat: 37' Oyster Heritage
Posts: 416
Re: OpenCpn 4.4 showing green world no CM93charts

I have exactly the same problem with a Windows 10 tablet. CPN can't seem to find the charts.
__________________
LPG? https://www.sestina-services.co.uk/
sestina is offline   Reply With Quote
Old 02-03-2017, 10:37   #13
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 6,178
Re: OpenCpn 4.4 showing green world no CM93charts

sestina...

Logfiles, please?

Have you tried charts on C:\?

Thanks
Dave
bdbcat is offline   Reply With Quote
Old 02-03-2017, 11:06   #14
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 2,145
Re: OpenCpn 4.4 showing green world no CM93charts

Quote:
Originally Posted by bdbcat View Post
sestina...

Logfiles, please?

Have you tried charts on C:\?

Thanks
Dave
It seems there is a possible dual entry for the location of the chartlist.dat file in opencpn.ini and in the Windows Registry. I know nothing about Windows but when this is true that is really a bad thing...

Gerhard
CarCode is online now   Reply With Quote
Old 03-03-2017, 02:41   #15
Marine Service Provider

Join Date: Apr 2008
Location: La la Land
Boat: 37' Oyster Heritage
Posts: 416
Re: OpenCpn 4.4 showing green world no CM93charts

Hi Guys

Sorry I'm bit of a thicko when it comes to these things. WTF is a log file and where do I find it? FWIW I'm running Windows 10.

I can't put the charts into C:\ as the hard drive isn't big enough, I've got them on an SD card labeled D:\

OpenCPN can find the directrory, but nothing happens when I try and scan or force the database rebuild.

I really appreciate your assistance.

Mike
__________________
LPG? https://www.sestina-services.co.uk/
sestina is offline   Reply With Quote
Reply

Tags
charts, enc, opencpn

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crew Wanted: Freeport Bahamas to Green Green Cove Springs FishyBiz Crew Archives 7 03-07-2016 11:12
AIS on OpenCPN showing ships over 1000 nm away? olympia Marine Electronics 6 14-09-2013 23:02
AIS Target Light Green or Dark Green Gilletarom OpenCPN 13 02-08-2013 17:15
OpenCPN - Currents Not Showing edsailing OpenCPN 7 01-12-2010 05:08

Advertise Here


All times are GMT -7. The time now is 01:58.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.