Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 28-08-2019, 12:11   #1
Registered User

Join Date: Aug 2010
Location: Hampton VA USA
Boat: Beneteau M500 50'3"
Posts: 59
Oops, what have I done wrong?,

Hello
just updated OpenCPN to version 5.0 and installed a RPi B4, well I followed the instructions implicitly and was not able to get it to install, here is a copy of my last attempt
pi@RpiB3:~ $ sudo nan /etc/apt/sources.list
sudo: nan: command not found
pi@RpiB3:~ $ sudo nano /etc/apt/sources.list
pi@RpiB3:~ $ sudo apt install dirmngr
Reading package lists... Done
Building dependency tree
Reading state information... Done
dirmngr is already the newest version (2.2.12-1+rpi1).
The following package was automatically installed and is no longer required:
rpi.gpio-common
Use 'sudo apt autoremove' to remove it.
pi@RpiB3:~ $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys C865EB40
Executing: /tmp/apt-key-gpghome.NTJML7Qm2l/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys C865EB40
gpg: key 67E4A52AC865EB40: "Launchpad PPA for OpenCPN" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
pi@RpiB3:~ $ sudo apt-get install opencpn
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
opencpn : Depends: libtinyxml2.6.2v5 but it is not installable
Depends: libwxbase3.0-0v5 (>= 3.0.4+dfsg) but it is not installable
Depends: libwxgtk3.0-0v5 (>= 3.0.4+dfsg) but it is not installable
Depends: wx3.0-i18n but it is not installable
Recommends: xcalib but it is not installable
Recommends: opencpn-doc but it is not going to be installed
Recommends: opencpn-gshhs-intermediate but it is not going to be installed
Recommends: opencpn-gshhs-high but it is not going to be installed
Recommends: opencpn-gshhs-full but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
pi@RpiB3:~ $

short of reinstalling Noobs which is probably where I am going does anyone have any idea or has run into similar situations
Thanks in advance
benet250 is offline   Reply With Quote
Old 29-08-2019, 03:38   #2
Registered User

Join Date: Jul 2019
Posts: 81
Re: Oops, what have I done wrong?,

I did ... !
You have to change the repo to "bionic" even if you are under raspbian stretch.
sudo nano /etc/apt/sources.list
change :
juancho38 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wrong time wrong place? uldinch Marinas 15 04-12-2015 18:11
Oops - Should Have Checked That! ribbony The Sailor's Confessional 15 08-04-2009 03:18

Advertise Here


All times are GMT -7. The time now is 15:57.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.