Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 22-05-2020, 08:13   #1
Registered User

Join Date: Feb 2019
Location: Åby, Sweden
Boat: Johnson 24
Posts: 12
Odd look-ahead

Hi!

Have a problem with the auto follow look-ahead mode.

When i turn it on, the own ship symbol jumps to the center of the lower part of the screen, near the edge.

That´s fine when we are heading north, but not in all other directions....

It worked fine in the 4.x versions.

Anyone have a solution to this?

Håkan B
__________________

HakanRob is offline   Reply With Quote
Old 22-05-2020, 11:43   #2
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,792
Re: Odd look-ahead

Håkan B.

Nothing I can repeat. For me it works fine on Win10.
But there's a somewhat different function of the auto follow mode in O version 5.0. Read more here: https://opencpn.org/OpenCPN/about/ver500.html
The look ahead mode works fine both in north and head -up mode for me.
The auto follow mode is change in the way you can position the boat symbol on a screen position and that is kept all time irrespective of course and head mode. To have the boat centered again one method is e.g. a mouse click close to the boat.

Håkan
__________________

Hakan is offline   Reply With Quote
Old 22-05-2020, 12:37   #3
Registered User

Join Date: Feb 2019
Location: Åby, Sweden
Boat: Johnson 24
Posts: 12
Re: Odd look-ahead

Hi Håkan!

Yes, I have noticed the difference, but the problem is still as I described it.

It works fine in normal auto follow mode, but as soon as I enable look-ahead, the boat jumps down to the lower edge and remains there. I can move the boat around as you describe it, but that doesn´t help the look ahead situation.

Håkan B
HakanRob is offline   Reply With Quote
Old 23-05-2020, 11:43   #4
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,792
Re: Odd look-ahead

On look ahead mode and head up the boat symbol will always be in the lower end and approximate 1/3 screen from bottom and 2/3 in front of the boat. In north up the boat symbol will turn around with the boat's heading but always 1/3 screen distance behind. See my shot showing the two modes.
If your screen differ from this a screen shot would be interesting.
Håkan
Attached Thumbnails
Click image for larger version

Name:	lookahead.jpg
Views:	33
Size:	293.5 KB
ID:	215632  
Hakan is offline   Reply With Quote
Old 23-05-2020, 13:19   #5
Registered User

Join Date: Feb 2019
Location: Åby, Sweden
Boat: Johnson 24
Posts: 12
Re: Odd look-ahead

Hi again!

Yes, that is obvious - when it all works! ;-)

But my problem is, as I have written twice before, that the ship symbol is at the bottom of the screen whatever course you steer, even southwards, when in look-ahead mode.

I won´t be to the boat for about a week now, but I can grab a screen shot when I get there, and show you.

I never navigate in course up mode, always in north up.

Håkan B
HakanRob is offline   Reply With Quote
Old 23-05-2020, 13:32   #6
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 2,792
Re: Odd look-ahead

Håkan B
OK good and no misunderstandings then. But what you describe I've never seen or heard of. If the boat symbol is at the screen bottom all times also on north up it's really strange.
If on course up I'd asked about a screen size mismatch but that seems not relevant here.
Anyone else? Dave?
Håkan
Hakan is offline   Reply With Quote
Old 30-05-2020, 13:33   #7
Registered User

Join Date: Feb 2019
Location: Åby, Sweden
Boat: Johnson 24
Posts: 12
Re: Odd look-ahead

Hi again,

Now I have been on a short boat trip and took the first attached screenshot. It clearly shows the problem: on the left part the look-ahead function is activated and the ship is positioned in the lower part, although I am heading south. The right part is with normal auto follow.

But, i have a crazy idea:
I also have the problem with SOG and COG missing in the status bar at the bottom (see attachment 2) which is discussed in other threads.

After a suggestion from Hakan I use the status bar plug-in instead, and that works fine. But that is only a work-around, the built-in software obviously doesn´t have access to the correct COG and SOG values, since it can´t display them.

Now think of the piece of software that shall calculate where to place the ship symbol in look-ahead mode. It will need the position, of course, and the COG. If the COG is not known it will perhaps take the default value of zero, and that means heading north. Thus it will place the ship in the middle of the lower part of the screen!!! Voila!

The heading arrow, whick is correct, could be calculated in some other way.

W#hat do you think about that?
Attached Thumbnails
Click image for larger version

Name:	LookAhead2.JPG
Views:	27
Size:	216.5 KB
ID:	216236   Click image for larger version

Name:	sog-cog.jpg
Views:	16
Size:	19.1 KB
ID:	216237  

HakanRob is offline   Reply With Quote
Old 31-05-2020, 06:32   #8
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 5,984
Re: Odd look-ahead

HakanRob...
The missing status bar COG/SOG:
May we see a screenshot of your NMEA debug output, found on Settings->Connections page?
Also, do you have the "Settings->Ships->Ownship->Calculate SOG and COG from position changes" option ticked?


Thanks
Dave
bdbcat is online now   Reply With Quote
Old 31-05-2020, 11:16   #9
Registered User

Join Date: Feb 2019
Location: Åby, Sweden
Boat: Johnson 24
Posts: 12
Re: Odd look-ahead

That was it!!!

The box "Calculate SOG and COG from position changes" was ticked of some unknown reason.

When I unticked it, SOG/COG was displayed again in the status bar.
After a quick rush around in the neighborhood I confirmed that the look-ahead function also worked again. My theory above was obviously correct!

Thanks a lot bdbcat!

/Håkan
__________________

HakanRob is offline   Reply With Quote
Reply

Tags
head

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Challenge: Ship, Out of the Fog, Dead Ahead ... Now What? SvenG Challenges 15 30-10-2009 16:32
Planning Ahead vera libertas General Sailing Forum 4 29-05-2008 22:37

Advertise Here


All times are GMT -7. The time now is 20:38.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.