Cruisers Forum
 


Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-06-2017, 05:29   #1
Registered User

Join Date: Jul 2014
Posts: 24
New computer - v4.4 and 4.6 hangs on connection of USB port

Hi.
I am a happy OpenCPN user since several years.
After last season I had to buy a new computer (hard drive crash on the old Win 10 machine), so I'm now installing OpenCPN on the new one (Win10) and experience an odd problem.

OpenCPN starts up alright with no connections configured.
When I configure the USB port connected to the NMEA multiplexer (Shipmodul) everything is OK at first. I see a good NMEA stream from all instruments (AIS/GPS, wind, compass, log).

However...
If I close OpenCPN and restarts it without doing anything else OpenCPN just hangs and stops responding.
If I pull out the USB OpenCPN can start again, but as soon as I reconnect the USB the program hangs again.
The only way to get it to work is to delete the connection with the USB pulled out and then reconfigure the connection, a procedure that has to be repeated for each program start!
I have tried both 4.4 and 4.6.1 with the same result...

If I use the USB port on the AIS/GPS directly it works fine (though I miss the information from the other instruments then)

On the old computer I ran 4.4 without problems...

Any suggestions what I can try?

Best Regards
Magnus Ohlsson
maohls is offline   Reply With Quote
Old 11-06-2017, 05:41   #2
Registered User
 
Rock-Head's Avatar

Join Date: May 2015
Location: St. Augustine, FL
Boat: 1978 Lancer 30 MkIV
Posts: 150
Re: New computer - v4.4 and 4.6 hangs on connection of USB port

Brand new computer: check for bios, chipset and/or usb driver update/download from the manufacturers support site.
Rock-Head is offline   Reply With Quote
Old 11-06-2017, 05:56   #3
Registered User

Join Date: Jul 2014
Posts: 24
Re: New computer - v4.4 and 4.6 hangs on connection of USB port

Thanks for the tips.
I have checked with ASUS - no machine related updates available.
Shipmodul - I have the latest driver for the multiplexer.

On interesting thing though:
I just tested to install the old SeaClear2 program:
No problems with the NMEA data from the multiplexer!!

Regards
Magnus Ohlsson
maohls is offline   Reply With Quote
Old 11-06-2017, 06:38   #4
Marine Service Provider

Join Date: May 2013
Location: Norway
Posts: 700
Re: New computer - v4.4 and 4.6 hangs on connection of USB port

Try to download xinutop, install on usb stick and boot (you may have to disable uefi in bios first) if opencpn works under xinutop, your problem is not hardware related but windows 10 related - just my 10 cents.

Quote:
Originally Posted by maohls View Post
Thanks for the tips.
I have checked with ASUS - no machine related updates available.
Shipmodul - I have the latest driver for the multiplexer.

On interesting thing though:
I just tested to install the old SeaClear2 program:
No problems with the NMEA data from the multiplexer!!

Regards
Magnus Ohlsson
petter5 is offline   Reply With Quote
Old 11-06-2017, 18:42   #5
Registered User
 
Rock-Head's Avatar

Join Date: May 2015
Location: St. Augustine, FL
Boat: 1978 Lancer 30 MkIV
Posts: 150
Re: New computer - v4.4 and 4.6 hangs on connection of USB port

Sorry for your luck w Asus. Their post-purchase driver support is poor.

One other suggestion, try running opencpn "as administrator". Win10 application security is a different animal.
Rock-Head is offline   Reply With Quote
Old 11-06-2017, 19:04   #6
Registered User

Join Date: Jul 2014
Posts: 24
Re: New computer - v4.4 and 4.6 hangs on connection of USB port

Ok, thanks! I'll try that.
Will be some days now until I'm back in the boat through...
I find the intermittent behavior and that other programs work encouraging in a way.
The NMEA stream IS tranferred to the virtual port...
Regards
Magnus Ohlsson
maohls is offline   Reply With Quote
Old 13-06-2017, 08:35   #7
Registered User

Join Date: Jul 2014
Posts: 24
Re: New computer - v4.4 and 4.6 hangs on connection of USB port

I've found one other thing to try - reduce the latency time and packet size under the advanced tab for the com port.
Hope it will work, testing on Friday....
/Magnus
maohls is offline   Reply With Quote
Old 24-06-2017, 07:33   #8
Registered User

Join Date: Jul 2014
Posts: 24
Re: New computer - v4.4 and 4.6 hangs on connection of USB port

SOLVED!
It was the NMEA Converter Plugin that somehow had got corrupt. I removed the old conversions and re-entered them from a backup text file from last year. And now it's ok again!
(Found out about this by disabling the plugin and saw the OpenCpn functioned as normal again)
Best regards
Magnus Ohlsson
maohls is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN 4.2 crashes and hangs up -- regressed to 3.2 Akka OpenCPN 7 14-05-2016 09:02
Rpi 3 hangs when zoomed out. jimseng OpenCPN 14 11-03-2016 21:53
USB Port software to alert when port closes. MarkJ OpenCPN 11 06-11-2013 09:56
Assign USB Port to COM Port ? GWB Navigation 10 17-05-2010 18:27
Garmin Video Port / Computer Connection RaySea Lady Marine Electronics 4 11-03-2010 20:35

Advertise Here


All times are GMT -7. The time now is 17:36.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.