Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-09-2019, 04:04   #16
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 17,698
Images: 2
Re: MWV sentences not working in dashboard

Why not? But these nasa instruments have proven to be somewhat problematical.

No, there have been no such updates.

Have you tried using dashboard-tactics?
Which Canne has improved and tested extensively?
rgleason is online now   Reply With Quote
Old 11-09-2019, 08:44   #17
Registered User

Join Date: Jul 2010
Location: Hannover - Germany
Boat: Amel Sharki
Posts: 2,545
Re: MWV sentences not working in dashboard

Quote:
Originally Posted by Karanga View Post
Is there any update on the usability of the these Nasa marine units by OpenCPN?

They have a wireless masthead unit that talks to a "data box" which puts out nmea 183.

Is it possible to run this through a USB serial adapter and into OpenCPN?

Tim
See page 2 of the manual:
https://media1.svb-media.de/media/sn...2014-10-27.pdf
You have to make the correct cable installation. Connecting to a computer you will need a serial/USB adapter.
CarCode is offline   Reply With Quote
Old 11-09-2019, 09:55   #18
cruiser

Join Date: Nov 2007
Location: Probably in an anchorage or a boatyard..
Boat: Ebbtide 33' steel cutter
Posts: 5,030
Re: MWV sentences not working in dashboard

Quote:
Originally Posted by Karanga View Post
Is there any update on the usability of the these Nasa marine units by OpenCPN?

They have a wireless masthead unit that talks to a "data box" which puts out nmea 183.

Is it possible to run this through a USB serial adapter and into OpenCPN?

Tim
Should work....... maybe....
Pretty sure the problem with the nasa wind sensor sending the wrong checksum was only with older units. How old is yours? Mine must be at least a decade.
Give it a go if you have a spare serial/usb adapter and have a look at the sentences in opencpn. Or even if it's wrong the 'ignore'checksum' in Opencpn might do the trick, the arduino code above was to go into another program which demanded the correct checksum.
conachair is offline   Reply With Quote
Old 18-11-2019, 23:17   #19
zzz
Registered User

Join Date: Jul 2016
Posts: 12
Re: MWV sentences not working in dashboard

Mine is probably different issue but when I feed nasa marine sensor value to open cpn through encoded solutions nmea wifi multiplexer, I got wimwv with blank value like this,

<GREEN>09:08:40 (UDP:10.11.12.1:10110) $WIMWV,,R,,,A*6D<0x0D><0x0A>
<BLUE>--> 09:08:40 (Serial:COM3) $WIMWV,,R,,,A*6D.

Original data came out (directly read from nasa wireless wind base station through usb serial) contain value as the pic.

Trying to find out who’s a bad guy next time on the boat but if anyone has clue...
Attached Thumbnails
Click image for larger version

Name:	6E81DDD2-4BD6-4F4D-BD6E-14FCE9977D00.jpg
Views:	72
Size:	411.9 KB
ID:	203372  
zzz is offline   Reply With Quote
Old 18-11-2019, 23:53   #20
zzz
Registered User

Join Date: Jul 2016
Posts: 12
Re: MWV sentences not working in dashboard

So I have to add .0 to degree value and .0 to velocity when the original value is 0?
zzz is offline   Reply With Quote
Old 19-11-2019, 06:19   #21
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 4,202
Re: MWV sentences not working in dashboard

Tim..
I've Nasa wifi unit feeding OCPN. Although not direct since the data box is connected by NMEA0183 to my old Simrad IS15 wind instrument and from there out into the common IS15 NMEA0183 stream to OCPN via a serial-USB converter.
Håkan

A rather nice calm day today.
Attached Thumbnails
Click image for larger version

Name:	MWV.PNG
Views:	86
Size:	28.3 KB
ID:	203387  
Hakan is offline   Reply With Quote
Old 23-11-2019, 21:13   #22
zzz
Registered User

Join Date: Jul 2016
Posts: 12
Re: MWV sentences not working in dashboard

Quote:
Originally Posted by zzz View Post
So I have to add .0 to degree value and .0 to velocity when the original value is 0?
Found out that OpenCPN can handle MWV with or without decimal point. My problem was simply garmin plotter was sending MWV with no value and multiplexer port to which nasa wind sensor connected was not working. I deselect MWV for garmin plotter and connected nasa sensor to alive multiplexer port then everything works fine.
zzz is offline   Reply With Quote
Old 19-04-2020, 22:55   #23
Registered User

Join Date: May 2012
Posts: 1,214
Re: MWV sentences not working in dashboard

Cannot get MWV to show correctly for the digital display in the dashboard, with or without the ".0". Task raised in flyspray.

https://opencpn.org/flyspray/index.p...s&task_id=2656

This may be a repeat.

Mike
Rasbats is offline   Reply With Quote
Old 20-04-2020, 00:19   #24
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 4,202
Re: MWV sentences not working in dashboard

Quote:
Originally Posted by Rasbats View Post
Cannot get MWV to show correctly for the digital display in the dashboard, with or without the ".0". Task raised in flyspray.
Mike
Mike..
I suppose this is fixed in current master?
See the below shot if we are talking about the same thing?
Attached Thumbnails
Click image for larger version

Name:	MWV.jpg
Views:	64
Size:	132.3 KB
ID:	213256  
Hakan is offline   Reply With Quote
Old 20-04-2020, 02:08   #25
Registered User

Join Date: May 2012
Posts: 1,214
Re: MWV sentences not working in dashboard

Sorry ... you are correct. I should have tried that. For me the <> are not very intuitive but ...

Mike
Rasbats is offline   Reply With Quote
Old 20-04-2020, 03:11   #26
Registered User

Join Date: May 2012
Posts: 1,214
Re: MWV sentences not working in dashboard

Ok ... I've got it!
Rasbats is offline   Reply With Quote
Old 20-04-2020, 03:52   #27
Registered User

Join Date: Nov 2012
Location: Orust Sweden
Boat: Najad 34
Posts: 4,202
Re: MWV sentences not working in dashboard

Could have been "->" instead of "> " but many different OS and sometimes lack of space I suppose? (Special keys like "→" ar not always supported?)
Hakan is offline   Reply With Quote
Reply

Tags
enc

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which NMEA Sentences Does an Autopilot Use ? svpresent Marine Electronics 8 02-05-2020 16:42
dashboard water temp (not metric?? RickyEM OpenCPN 5 16-07-2018 12:49
NMEA AIS Sentences with Tag block. O 4.0 Do not show AIS targets. Gilletarom OpenCPN 4 08-12-2015 10:35
OpenCPN 3.3.xxxx and plugins : NMEA sentences list ? Gilletarom OpenCPN 17 01-05-2014 06:02
OpenCPN not sending NMEA autopilot sentences. Islander OpenCPN 6 16-04-2014 07:02

Advertise Here


All times are GMT -7. The time now is 18:55.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.