Cruisers Forum
 


Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 26-10-2020, 11:57   #1
Registered User

Join Date: Oct 2020
Posts: 3
MBTiles file not displaying...

I am new to OpenCPN. My goal is to create MBTile file(s) to use on local lakes. Through other tools, I've hand-crafted an MBTile file that contains only the metadata and tiles tables. The tiles file contains zoom levels from 1 through 18 for a small region covering a single lake in Florida.



I've added it to the charts section of OpenCPN and it seems to be recognized.


When I display the main map, I see a red box indicating the bounding rectangle of the MBTiles chart. However, no map data or images are rendered.


I do not know if I am doing something wrong in OpenCPN (there's no red 'x' in the bottom chart boxes). Or if my MBTiles file is not valid with only those two tables.


I also created a chart group that only contains the MBTile chart. Same result. When I right-click on the chart-bar I correctly see the filename and other meta data from my MBTiles file.


I'm happy to share the MBTiles file (~7.1mb). The file opens fine with standard sqlite tools.


Sorry if this is a too newbie a question, but any help would be appreciated.
RobNY is offline   Reply With Quote
Old 26-10-2020, 17:08   #2
Marine Service Provider
 
bdbcat's Avatar

Join Date: Mar 2008
Posts: 6,195
Re: MBTiles file not displaying...

RobNY...
Please post the tile set somewhere that we can download it, and we will have a look.


Thanks
Dave
bdbcat is offline   Reply With Quote
Old 26-10-2020, 17:17   #3
Registered User

Join Date: Oct 2020
Posts: 3
Re: MBTiles file not displaying...

Dave,



Thanks, but I just figured it out. In the sticky MBTILES thread on this forum there is a reference that OCPN would only support the xyz scheme. However, it turns out that it only supports TNS scheme as far as I can tell.


Layer onto that, I was doing my xyz->tns calculation incorrectly and now it seems to be resolved.

(Again, I'm new to OCPN so there may be tons of documentation I haven't gotten to yet. Appreciate the quick reply.)
RobNY is offline   Reply With Quote
Old 27-10-2020, 12:18   #4
Registered User

Join Date: Oct 2020
Posts: 3
Re: MBTiles file not displaying...

Even though this is solved, I was wondering if someone could answer a question for me concerning MBTile format.


Per the MBTile spec, the Y axis (tile_row) *must* be encoded using the TMS scheme. This was my mistake, and I've fixed it.


However, in the metadata table, there is a "scheme" entry. In the NOAA RNC tiles files, the Y's are encoded TMS, but the scheme in the metadata field says "xyz".


If the encoding of the data is required to be TMS, what is the purpose of the "scheme" field in the metadata table?
RobNY is offline   Reply With Quote
Old 30-10-2020, 02:20   #5
Registered User

Join Date: May 2017
Location: Delft, NL
Boat: Hurley
Posts: 27
Re: MBTiles file not displaying...

From what I know without looking something up again, the only real difference between TMS and XYZ schemes is a flipped y-axis. I should dig into it a bit deeper to properly explain the behaviour you are experiencing, but don't have the time for it now.
However, I wouldn't worry about it too much. You experienced it only properly working within OpenCPN with this specific scheme you are currently using. Therefore I would not be surprised if OpenCPN does not look into the 'scheme' attribute at all, and just assumes one of the two.
Baksteen is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Convert "*.route" Route File into ".*wpt" File To Be Used in Maxsea V.10 doiroda Navigation 7 12-03-2020 06:00
Charts not Displaying travellerw OpenCPN 1 08-02-2015 14:23
3.0.0 : make package : bad file right after installing the deb file manuprenlair OpenCPN 1 12-06-2012 04:17
Current Prediction Not Displaying as SPEEDS HappySeagull OpenCPN 20 28-04-2011 11:48
ZyGRIB not Displaying Hurricane? idpnd Navigation 1 01-09-2009 03:47

Advertise Here


All times are GMT -7. The time now is 09:59.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.