Cruisers Forum
 


Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 26-03-2017, 01:49   #1
Registered User

Join Date: Mar 2017
Posts: 7
Low fps when building in Visual Studio

When I build OpenCPN myself in Visual Studio (2013) in Release I get very low fps (Open GL enabled). I only get <20 fps but mostly 1-5fps. If it were in Debug build I'd get it but not in Release. When I run the installed version I get 100-200fps without problem on the same computer.

Any clue what might cause the problem? Is there any options I should turn on in my own build like logging that's going on or something?

Thanks in advance.
b.lindahl is offline   Reply With Quote
Old 26-03-2017, 04:25   #2
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 2,143
Re: Low fps when building in Visual Studio

As an example regard this thread:
https://news.ycombinator.com/item?id=13941293

13% of CPU power is used in this example only for a blinking cursor. The devil in this example was Chromium which was used by the Electron framework which is used by the source code editor of Microsoft Visual Studio Code.

The chain of used dependencies in OpenCPN is even larger and so it is difficult to determine where is the bottle neck...

Gerhard
CarCode is offline   Reply With Quote
Old 26-03-2017, 04:48   #3
Registered User

Join Date: Mar 2017
Posts: 7
Re: Low fps when building in Visual Studio

Quote:
Originally Posted by CarCode View Post
As an example regard this thread:
https://news.ycombinator.com/item?id=13941293

13% of CPU power is used in this example only for a blinking cursor. The devil in this example was Chromium which was used by the Electron framework which is used by the source code editor of Microsoft Visual Studio Code.

The chain of used dependencies in OpenCPN is even larger and so it is difficult to determine where is the bottle neck...

Gerhard
Of course there are many factors which might be the root of the problem but what I'm asking if there's some logging done or something else that's on by default and common to bite you when building OpenCPN out of the box.
b.lindahl is offline   Reply With Quote
Old 26-03-2017, 05:11   #4
Registered User

Join Date: Jul 2010
Location: Kalamata, Greece
Boat: Amel Sharki
Posts: 2,143
Re: Low fps when building in Visual Studio

Quote:
Originally Posted by b.lindahl View Post
Of course there are many factors which might be the root of the problem but what I'm asking if there's some logging done or something else that's on by default and common to bite you when building OpenCPN out of the box.
I have only my personal thumb rules: I never use Windows or any Microsoft software...

Gerhard
CarCode is offline   Reply With Quote
Old 26-03-2017, 05:22   #5
Registered User

Join Date: Mar 2017
Posts: 7
Re: Low fps when building in Visual Studio

Wow, thanks for the really helpful advice...
b.lindahl is offline   Reply With Quote
Old 28-03-2017, 05:12   #6
Registered User

Join Date: Mar 2017
Posts: 7
Re: Low fps when building in Visual Studio

I noticed that prebuilt Windows version 4.6.0 also suffer from low fps (<10 fps) Switching back to 4.4.0 show about 200fps. So something was introduced between 4.4.0 and 4.6.0 which probably would be the cause for low fps when building with VS as well.

Could someone else running Windows as well as building it for VS verify it's a common issue?
b.lindahl is offline   Reply With Quote
Old 28-03-2017, 05:15   #7
Registered User

Join Date: Mar 2017
Posts: 7
Re: Low fps when building in Visual Studio

Forget about my last post. (I can't see any way to remove a post?)

I saw in the 4.6.0 release thread that numerous others reporting some OpenGL issues well with last release...
b.lindahl is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCPN Compiling in windows using visual studio page not found dinusha OpenCPN 7 25-09-2016 16:17
Microsoft Visual Studio Express 2013 rgleason OpenCPN 4 24-10-2013 13:41
General Info: FPs For Extended Cruising with Kids? drewvta Fountaine Pajot 18 26-01-2013 12:20
How to compile opencpn codes on Windows 7, not use Visual Studio 2010 bailizi OpenCPN 1 18-07-2012 02:40
Building OpenCPN in Visual C++ 2008 Express - Errors steve314 OpenCPN 8 02-06-2011 13:50

Advertise Here


All times are GMT -7. The time now is 18:28.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.