Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 28-12-2019, 22:13   #1
Registered User

Join Date: Dec 2019
Posts: 5
Help - Installing and uptating plugin catalog - Linux

Hi all, first, I wanted to thank to this community as I have been able to sort out a lot of the problems i encountered with the installation for debian.

Secondly, i am trying to install the weatherrouting plugin, and i am encountering some issues i think some of you might have gone through.

1) I did not find all the alternative plugins in the xenial version (my debian is 9, so xenial is my matching ubuntu version for ppa). example: climatology plugin.

2) I could apt-get install Weatherrouting, polars. However, I cannot see them in the plugin list to enable them. I did try to update the plugin catalog (both in master and release channels according to the UI advanced plugin catalog updater).

How I could solve for these 2 items? Did anyone of you experience the same situation?
When the weather routing says it uses teh climatology plugin, is it pre-required to have it installed for the weatherrouting plugin to work?

Thank you very much! Best,

Santi
__________________

AmericadelSur is offline   Reply With Quote
Old 29-12-2019, 02:12   #2
Registered User

Join Date: Dec 2005
Location: Helsingborg
Boat: Dufour 35
Posts: 3,710
Re: Help - Installing and uptating plugin catalog - Linux

Quote:
However, I cannot see them in the plugin list to enable them. I did try to update the plugin catalog (both in master and release channels according to the UI advanced plugin catalog updater).
It's obvious that you refer to the development version of OpenCPN not the current stable version, 5.0 (5.01 on Mac). If you want to follow the development see instructions in this thread - http://www.cruisersforum.com/forums/...ew-227965.html
The code changes, more or less, every day. The features you referred to changed overnight.

On this forum you can only expect help for the official release.
Before the next stable release there will be some beta releases. These will be discussed on this forum.
If you want to compile your own, don't use the "Master" branch, as that is were the development happens. Instead use the "v5.0.x" branch which is the stable release + a few bug fixes.

Thomas
__________________

cagney is offline   Reply With Quote
Old 29-12-2019, 05:20   #3
Registered User

Join Date: Dec 2019
Posts: 5
Re: Help - Installing and uptating plugin catalog - Linux

Quote:
Originally Posted by cagney View Post
If you want to compile your own, don't use the "Master" branch, as that is were the development happens. Instead use the "v5.0.x" branch which is the stable release + a few bug fixes.
Thomas, thank you very much for your prompt response. I am sorry I did not clarify this before, but I am using OpenCPN 5.0.522 with Plugin API 117.

I assume this is the official stable release? I compiled my own following the instructions on the wiki, trying to use the stable release. In case I should compile a different version, how can i ensure i am compiling the stable version?

If I am using the correct version, how can I make the plugin list updated? is there a special folder where plugins should be - maybe they were installed in a wrong folder?
Thanks again. Best,
Santi
AmericadelSur is offline   Reply With Quote
Old 29-12-2019, 06:13   #4
Registered User

Join Date: Dec 2005
Location: Helsingborg
Boat: Dufour 35
Posts: 3,710
Re: Help - Installing and uptating plugin catalog - Linux

5.0.522 is not an official release. It's just a named development snapshot from December 18. Anything compiled after that has the same number, so far. Read again, what I wrote in my last post about versions.

To clone the correct branch use
Code:
$git clone -b v5.0.x https://github.com/OpenCPN/OpenCPN.git
cagney is offline   Reply With Quote
Old 02-01-2020, 13:28   #5
Registered User

Join Date: Dec 2005
Location: Helsingborg
Boat: Dufour 35
Posts: 3,710
Re: Help - Installing and uptating plugin catalog - Linux

As the 5.0.1 branch is now developing, and diverging more and more from v 5.0, I need to correct my statement above, about getting the 5.0 code.

Download the code for 5.0, the latest stable release of OpenCPN from this page https://github.com/OpenCPN/OpenCPN/releases/tag/v5.0.0 .
A direct link is https://github.com/OpenCPN/OpenCPN/archive/v5.0.0.zip

Thomas
cagney is offline   Reply With Quote
Reply

Tags
linux, plug

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale: Adler Barbour ice cube trays and Yanmar engine parts catalog Richard Kollmann General Classifieds (no boats) 0 30-09-2018 14:05
A CF audio and e-book catalog? OndinePLC Fishing, Recreation & Fun 2 28-03-2018 06:19
SOUND SPARS: need parts and old catalog PUDDLE JUMPER II Deck hardware: Rigging, Sails & Hoisting 3 28-12-2016 11:16
Help Installing S-63 Plugin. Glen96 OpenCPN 16 12-10-2014 11:21
Installing OpenCPN on a Bootable Linux Flash Drive jimbim OpenCPN 34 14-08-2010 04:24

Advertise Here


All times are GMT -7. The time now is 23:15.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.