Cruisers Forum
 


Join CruisersForum Today

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 27-06-2018, 12:49   #1
Registered User

Join Date: Jun 2018
Posts: 12
All charts have disappeared!

Hi gents,
suddenly OpenCPN cannot find any chart. If I reload the database, all seems well, all arquives are correct, I can download and install OESENC charts, but nothing helps: The charts are simply not there in the map.


What did I do wrong? What can I do?
Help is very much appreciated.
__________________

aurigo is offline   Reply With Quote
Old 28-06-2018, 04:20   #2
Registered User

Join Date: Dec 2005
Location: Helsingborg
Boat: Dufour 35
Posts: 3,710
Re: All charts have disappeared!

aurigo

It's not easy to help you as you don't supply any facts about your system, your setup, your charts, your actions to fix the problem or your level of knowledge of OpenCPN.
Have you read the documentation?

Please let us have a look at your opencpn.log.
Go to the "?" in the tool-bar. Press the button "Copy Log File to Clippboard" and copy it to post here.

Thomas
__________________

cagney is offline   Reply With Quote
Old 28-06-2018, 08:17   #3
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,796
Re: All charts have disappeared!

And please check first if the oeSENC plug-in is present - and enabled.
bcn is online now   Reply With Quote
Old 28-06-2018, 09:30   #4
Registered User

Join Date: Jun 2018
Posts: 12
Re: All charts have disappeared!

Plug-in is enabled. Also the CM93 charts which are notOESENC, do not show.
aurigo is offline   Reply With Quote
Old 28-06-2018, 09:43   #5
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,796
Re: All charts have disappeared!

Did you install the charts perhaps on a portable device like a USB stick or a SD card?
If the drive letter (case of Windows) did change, then you will need to rebuild your chart directoriy entries.



What OS are you using?
And please show us the log file.
bcn is online now   Reply With Quote
Old 28-06-2018, 09:46   #6
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,228
Re: All charts have disappeared!

Quote:
Originally Posted by aurigo View Post
Plug-in is enabled. Also the CM93 charts which are notOESENC, do not show.
Please post your logfile or at least a screenshot like this to start with:
nohal is offline   Reply With Quote
Old 28-06-2018, 16:31   #7
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 13,958
Re: All charts have disappeared!

What Device and Operating System?
Where are your charts located? Give us the exact pathname.
When you go into Options > Charts, do the pathnames match?
Have you rebuilt the database yet?

Pick the "?" in the menu and Copy Settings file to clipboard, then save it and upload it here.
Pich the "?" in the menu and Copy Logf file to clipbooard, then save it and upload it here.

You may have to rename them to be .doc.

You can solve this yourself!
rgleason is offline   Reply With Quote
Old 29-06-2018, 06:48   #8
Registered User

Join Date: Jun 2018
Posts: 12
Re: All charts have disappeared!

I am working W10 home latest update on a laptop on board. Thr paths are the same for the last 3 years without any change. I have also changed nothing in the laptop configuration (save an automatic windows update, which I don't know about).


Everything points to the correct location. Rebuilding the database does not change anything.


I have attached the config file. The logfile is way too big for uploading here, because txt upload is only 1 KB and doc is 400 kb. My logfile as doc is 7 MB. Unfortunately the uploada does not accept zip files.
Attached Files
File Type: doc config_WK_29618.doc (70.5 KB, 13 views)
aurigo is offline   Reply With Quote
Old 29-06-2018, 06:52   #9
Registered User

Join Date: Feb 2010
Location: On the go. Not in Prague.
Posts: 5,228
Re: All charts have disappeared!

Quote:
Originally Posted by aurigo View Post
I am working W10 home latest update on a laptop on board. Thr paths are the same for the last 3 years without any change. I have also changed nothing in the laptop configuration (save an automatic windows update, which I don't know about).


Everything points to the correct location. Rebuilding the database does not change anything.


I have attached the config file. The logfile is way too big for uploading here, because txt upload is only 1 KB and doc is 400 kb. My logfile as doc is 7 MB. Unfortunately the uploada does not accept zip files.
Please ZIP the logfile and rename to .DOC, that should allow you to upload. Or upload it to google docs, onedrive, dropbox or whatever other similar service you are familiar with and post a link.
The config file confirms that you do have some chart directories configured, yes.
nohal is offline   Reply With Quote
Old 29-06-2018, 06:53   #10
bcn
Registered User

Join Date: May 2011
Location: underway whenever possible
Boat: Rangeboat 39
Posts: 3,796
Re: All charts have disappeared!

Just rename the zipped log file to ...zip.doc
Then you shall be able to upload it.
bcn is online now   Reply With Quote
Old 29-06-2018, 13:20   #11
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 13,958
Re: All charts have disappeared!

aurigo, please do upload those files. You can zip them and then just add .doc or .pdf which is bigger. We will change the extension. opencpn.ini.zip.pdf or opencpn.log.pdf


Also you can try this, assuming your opencpn.ini file is somehow corrupted. You can always go back to what you had.

In C:\ProgramData\opencpn or C:\Users\All Users\opencpn
try just renaming your opencpn.ini file to opencpn.ini.old
You can always change it back.

The close the folder and start Opencpn up again. Opencpn creates a fresh new opencpn.ini file and you will need to reestablish all your pathnames and settings again.

However you can look in your opencpn.ini.old with any text editor to help determine what you had setup earlier, but don't corrupt the new opencpn.ini doing this.

If that does not work for you go back using to the earlier opencp.ini

If you are not familiar with this, procedure or unsure. Don't do it. Just upload the file.
rgleason is offline   Reply With Quote
Old 29-06-2018, 13:28   #12
Registered User
 
rgleason's Avatar

Join Date: Mar 2012
Location: Boston, MA
Boat: 1981 Bristol 32 Sloop
Posts: 13,958
Re: All charts have disappeared!

This opencpn.ini file seems like a partial file. Is that all of it?
rgleason is offline   Reply With Quote
Old 29-06-2018, 15:11   #13
Registered User

Join Date: Dec 2005
Location: Helsingborg
Boat: Dufour 35
Posts: 3,710
Re: All charts have disappeared!

aurigo

Looking at your config file......
You have one chart group "oeSENC", but there are currently no charts in that group. So if you pick this group nothing will show. You have probably at some stage added charts to this group, but now they have disappeared. I have seen this many times and it's a bug in OpenCPN.

Run "Force Full Database Rebuild", follow up by adding the correct chart-directory to your "oeSENC" group. Try both the "All Active Charts" and "oeSENC" group.

Thomas
cagney is offline   Reply With Quote
Old 30-06-2018, 16:02   #14
Registered User

Join Date: Jun 2018
Posts: 12
Re: All charts have disappeared!

Unfortunately you are wrong, Thomas. All charts (KAP, CM93, OESENC) are present in their respective archives. Rebuilding the complete database shows, that the rebuild works thru all he correct archives and charts. But still: The don't show.


I am thinking about deinstalling and reinstalling the whose system, although that is rather complicated (licensing of OESENC files, saving all my track and waypoints.)
Attached Files
File Type: doc Log_WK_290618.doc (91.9 KB, 8 views)
aurigo is offline   Reply With Quote
Old 30-06-2018, 16:06   #15
Registered User

Join Date: Jun 2018
Posts: 12
Re: All charts have disappeared!

renaming opencpn.ini to opencpn.ini.old and restarting the programm did also not change anything
__________________

aurigo is offline   Reply With Quote
Reply

Tags
charts

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iNavX charts disappeared (Navionics) Mike OReilly Navigation 118 24-04-2018 09:00
All Anodes have disappeared b_rodwell Construction, Maintenance & Refit 16 22-01-2018 14:35
INavX charts disappeared... chouliha Navigation 13 01-12-2016 00:46
AIS targets have disappeared on OCPN nhschneider OpenCPN 6 03-03-2015 08:28
Somehow spell check disappeared rsn48 Forum Tech Support & Site Help 3 02-11-2006 10:37

Advertise Here


All times are GMT -7. The time now is 23:09.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.