Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 13-10-2017, 14:59   #1
Registered User

Join Date: Feb 2011
Location: Mexico
Boat: Catalina 42
Posts: 61
Simrad IS40 Display Problem

I Have a Simrad !S40 wind/depth instrument, When I turn on the instrument the back light comes of but there is no data displayed on either the wind speed, wind direction or depth. I have checked all the NEMA connections and also turned off and powered up a few time but no luck, can anyone help?
Chris
Exmoor is offline   Reply With Quote
Reply

Tags
simrad

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Navico Autopilot commissioning with B&G Triton T41 (~Simrad IS40) rabbi Marine Electronics 13 28-02-2017 13:28
Simrad IS20 swap to an IS40 KJW911 Marine Electronics 0 21-01-2016 10:47
Simrad NSS7 and Simrad 3G radar gunkylump Marine Electronics 6 26-04-2015 12:15
Simrad RS35 and Simrad product support alctel Product or Service Reviews & Evaluations 0 25-03-2015 14:48
For Sale: Simrad ac40 for sale and simrad ap25 for sale heintje23 Classifieds Archive 2 04-11-2013 07:19

Advertise Here


All times are GMT -7. The time now is 08:51.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.