Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-06-2022, 11:06   #1
Registered User
 
Jamme's Avatar

Join Date: Feb 2020
Location: Stamford, CT
Boat: Beneteau Oceanis 31
Posts: 556
Airmar Smart Tri Multisensor showing impossible sea temperatures

Hi, I have what I think is an NMEA 2000 Airmar multisensor (model 20-633-01, see pic below).

I have been getting way off water temperature readings. OK for global warming etc… But 40 degrees Celsius in the Long Island Sound waters seems a bit too much!

Should I just toss the thing and buy a new sensor or has anyone experienced the same issue and found a solution?

Thanks so much in advance, fair winds

Click image for larger version

Name:	IMG_8594.jpg
Views:	34
Size:	138.2 KB
ID:	259001Click image for larger version

Name:	IMG_8593.jpg
Views:	66
Size:	54.1 KB
ID:	259002
__________________
"I always arrive late at the office, but I make up for it by leaving early.” – Charles Lamb
Jamme is offline   Reply With Quote
Old 05-06-2022, 13:23   #2
Registered User

Join Date: Jul 2015
Location: Chicago
Posts: 52
Re: Airmar Smart Tri Multisensor showing impossible sea temperatures

Similar discussion here which referenced these troubleshooting tips.
b_ohare is offline   Reply With Quote
Old 05-06-2022, 17:54   #3
Registered User
 
Jamme's Avatar

Join Date: Feb 2020
Location: Stamford, CT
Boat: Beneteau Oceanis 31
Posts: 556
Re: Airmar Smart Tri Multisensor showing impossible sea temperatures

Thanks B!

Basically it seems I will need to replace the unit:

“To get the water temperature working again you will need to replace the transducer as these are fully sealed bodies and not repairable.”
__________________
"I always arrive late at the office, but I make up for it by leaving early.” – Charles Lamb
Jamme is offline   Reply With Quote
Old 08-06-2022, 10:44   #4
Registered User

Join Date: Feb 2017
Location: Occasionally in Colorado. Generally live-aboard. Nova Scotia and Newfoundland this summer, Eastern Caribbean this winter.
Boat: Antares 44i
Posts: 706
Re: Airmar Smart Tri Multisensor showing impossible sea temperatures

Ours started drifting and we were compensating with the offset in the display settings. When the drift reached about 30 degrees F we started to see the depth readings acting a bit strange. Within a month of that point we could only sense depths between 10 and 25 feet, but no shallower or deeper.

Take it as a sign that the sensor is failing and replace it.
dougweibel is offline   Reply With Quote
Reply

Tags
sensor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Airmar Ultrasonic Smart Sensor alansmith General Sailing Forum 0 04-05-2021 17:51
Airmar Smart transducer sending bad singal CSYChip Marine Electronics 0 06-09-2018 06:18
For Sale: airmar dst 800 SMART sensor mlydon Classifieds Archive 0 13-05-2015 08:53
For Sale: Smart Tri 40 Jort Classifieds Archive 0 05-03-2013 00:37
For Sale: AirMar Tri-Ducer DST800 - brand new - $225 memelet Classifieds Archive 0 06-07-2012 20:02

Advertise Here


All times are GMT -7. The time now is 07:09.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2023, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.