Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 18-05-2022, 22:43   #1
Wanderer
 
Tenedos's Avatar

Cruisers Forum Supporter

Join Date: Nov 2012
Location: Used to be San Francisco Bay, now PNW
Boat: Jeanneau 43 DS
Posts: 409
Webasto DBW 2010 Hydronic Heater Problems

I am having a problem with my Webasto DBW 2010 Hyronic heater and wondering if anyone can provide an insight.

The heater runs for a while, I get warm air from all 4 fans. Then at some point the heater "cycles" and the on/off green light goes off for about 5-10 seconds without me doing anything. When the light goes off, all fans also go off. Then in about 5-10 seconds, the green light comes back on by itself (with no change in the switch status) and the fans start blowing warm air but heating unit doesn't run. This keeps going until fans start blowing cool air and this keep going on forever. The heater does never come back on until I power cycle it on and off.

This heater worked for more than a year flawlessly and then I had a problem and I called in service. After a week of troubleshooting, almost changing every part on it and several thousand dollars I ended up in this scenario. I will call the service again but I am getting frustrated with it. I came to the conclusion that I need to start learning and doing it myself so any hint you can offer will be appreciated.
__________________
SV Renaissance
Tenedos is offline   Reply With Quote
Old 19-05-2022, 05:52   #2
Registered User

Join Date: Jun 2021
Boat: Nordhavn 40 II
Posts: 10
Re: Webasto DBW 2010 Hydronic Heater Problems

I call Graham at Sure Marine in Seattle when ours has issues. I purchase nozzles from John Carillo RV as Sure has quality control problems with theirs.
IRENE is offline   Reply With Quote
Old 19-05-2022, 09:55   #3
Registered User

Join Date: May 2010
Location: Seattle
Boat: Endeavour 43
Posts: 32
Re: Webasto DBW 2010 Hydronic Heater Problems

I installed the DBW2010 on my sailboat 20 years ago, it's a great heating system. Most likely the problem is with the control unit, particularly if it's the old metal box with relays in it. Sure Marine has researched the issue through the years and found an aftermarket control unit that solves the problems the old controller had. One quick thing to check though, when the unit fails to re-light...Voltage at the heater. It doesn't like low voltage. I purchased the Webasto unit from Sure Marine and their level of customer service is outstanding. Highly recommend you contact them, they will have the answer to your problem. 206-784-9903
sea1ljs is offline   Reply With Quote
Old 19-05-2022, 10:27   #4
Wanderer
 
Tenedos's Avatar

Cruisers Forum Supporter

Join Date: Nov 2012
Location: Used to be San Francisco Bay, now PNW
Boat: Jeanneau 43 DS
Posts: 409
Re: Webasto DBW 2010 Hydronic Heater Problems

Quote:
Originally Posted by sea1ljs View Post
I installed the DBW2010 on my sailboat 20 years ago, it's a great heating system. Most likely the problem is with the control unit, particularly if it's the old metal box with relays in it. Sure Marine has researched the issue through the years and found an aftermarket control unit that solves the problems the old controller had. One quick thing to check though, when the unit fails to re-light...Voltage at the heater. It doesn't like low voltage. I purchased the Webasto unit from Sure Marine and their level of customer service is outstanding. Highly recommend you contact them, they will have the answer to your problem. 206-784-9903
Thanks. That control box just got replaced two weeks ago... I work with SureMarine too and called them. This has just been a very challenging experience with several weeks of issues with the heater.
__________________
SV Renaissance
Tenedos is offline   Reply With Quote
Old 19-05-2022, 16:12   #5
Registered User

Join Date: Aug 2017
Posts: 35
Re: Webasto DBW 2010 Hydronic Heater Problems

Sounds like an overheat error which is usually caused by low boiler fluid level or too slow flow in the fluid circuit. Check that your header tank is full when cold. I usually run the system for a minute or two with the pressure cap off of the header tank to get rid of any air in the system.
rphdiego is offline   Reply With Quote
Reply

Tags
heater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Webasto Hydronic Heater Thermo 90 prajna101 Construction, Maintenance & Refit 3 09-10-2020 22:50
Diesel Hydronic Heaters: Hurricane vs. Webasto Boaterbob Product or Service Reviews & Evaluations 9 28-01-2020 19:34
For Sale: Webasto DBW-300 diesel fired coolant heater pmoil General Classifieds (no boats) 0 25-09-2016 16:41
Webasto Hydronic Heater Best Practices Macblaze Liveaboard's Forum 23 30-11-2015 21:15
Espar Hydronic Heater Dealer / Consultant ? SvenG Plumbing Systems and Fixtures 8 24-02-2011 07:50

Advertise Here


All times are GMT -7. The time now is 13:11.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2022, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.