Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 23-01-2020, 09:15   #1
Registered User

Join Date: Mar 2017
Posts: 189
Washdown pump quick connects leaking

I have a jabsco hotshot pump model 82405-0092 and the quick connect fittings are leaking. The pump is about 1 year old and I've used the washdown maybe 4 or 5 times total.

Any tips on how to stop these leaks? I've heard of lubricating the o-ring and tried that with some grease but that didn't seem to fix it.
__________________

felizcortez is offline   Reply With Quote
Old 23-01-2020, 09:16   #2
Registered User

Join Date: Mar 2017
Posts: 189
Re: Washdown pump quick connects leaking

Pic attached
Attached Thumbnails
Click image for larger version

Name:	IMG_20200123_101334128.jpg
Views:	117
Size:	406.4 KB
ID:	207449  
__________________

felizcortez is offline   Reply With Quote
Old 23-01-2020, 09:55   #3
Registered User
 
Bill O's Avatar

Join Date: Jul 2015
Boat: Bruce Bingham Christina 49
Posts: 1,302
Re: Washdown pump quick connects leaking

Have the same wash down pump and never had it leak. Is this something new or happen since the original install?

I'm sure you've done this already, but remove the fitting and inspect, re-install making certain it is clipped in properly. Also possibly check the fitting to see if there is a small crack, etc. (possibly from over tightening the hose clamp). If you do put lube on the seal/o-ring use a silicone or non-petroleum lube.

Another thing to check is the hose connection. Is the hose clamp on correctly or the hose split or small hole from the hose clamp (try to isolate/identify the leak location)?

Jabsco customer service if fairly good and if this leak happened during the install, maybe its a defective hose fitting.


Bill O.
__________________
Bill O.
KB3YMH
https://phoenixketch.blogspot.com/
Bill O is offline   Reply With Quote
Old 23-01-2020, 13:28   #4
Registered User

Join Date: Jun 2012
Location: Port Aransas, Texas
Boat: 2019 Seawind 1160 Lite
Posts: 1,540
Re: Washdown pump quick connects leaking

Quote:
Originally Posted by Bill O View Post
Have the same wash down pump and never had it leak.

Bill O.
Same experience here, for both saltwater washdown and two different fresh water pumps of same maker. Especially amazing that its leaking on the suction (low pressure) side.
sailjumanji is offline   Reply With Quote
Old 25-01-2020, 06:00   #5
Registered User

Join Date: Dec 2012
Boat: Jeanneau SO45.2
Posts: 229
Re: Washdown pump quick connects leaking

From the picture it looks as if the hose comes in at an angle rather than straight into the fitting. That may be part of the problem.
Redline452 is offline   Reply With Quote
Old 14-02-2020, 13:23   #6
Registered User

Join Date: Mar 2017
Posts: 189
Re: Washdown pump quick connects leaking

Quote:
Originally Posted by Redline452 View Post
From the picture it looks as if the hose comes in at an angle rather than straight into the fitting. That may be part of the problem.
I straightened out the hose and ensured it wouldn't move with a zip tie, but there is definite play in the fitting even when the retaining clip is seated completely.

Straightening the hose helped with the leaking a bit, but it is still not completely dry
felizcortez is offline   Reply With Quote
Old 14-02-2020, 13:27   #7
Registered User

Join Date: Mar 2017
Posts: 189
Re: Washdown pump quick connects leaking

When the pump is turned on it also pulses every 20 seconds or so as well
felizcortez is offline   Reply With Quote
Old 15-02-2020, 08:01   #8
Registered User

Join Date: Jun 2012
Location: Port Aransas, Texas
Boat: 2019 Seawind 1160 Lite
Posts: 1,540
Re: Washdown pump quick connects leaking

Quote:
Originally Posted by felizcortez View Post
When the pump is turned on it also pulses every 20 seconds or so as well
That is the pump raising the pressure back to account for what is lost by the drip. Or it could be leaking back through bad seal, or debris in the seal.
__________________

sailjumanji is offline   Reply With Quote
Reply

Tags
pump

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Icon SSB 140 tuner connects Sailshabby Marine Electronics 2 24-12-2018 15:04
For Sale: Jabsco washdown Quick connect Kit New jdisarro General Classifieds (no boats) 2 26-07-2018 13:46
Want to set up a boat WiFi system that connects through marina's wifi MV Wanderlust Marine Electronics 25 06-12-2016 13:45
need waterproof electrical quick-connects GafferMate Construction, Maintenance & Refit 5 18-05-2015 16:39
Ipad connects to WiFi but no internet F51 Marine Electronics 5 31-07-2014 17:56

Advertise Here


All times are GMT -7. The time now is 15:55.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.