Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-01-2023, 09:08   #1
Registered User
 
sv_isara's Avatar

Join Date: Jan 2020
Location: Cruising Pacific Mexico
Boat: Hunter Legend 40.5
Posts: 151
Jabsco manual pump issue

They all hope you are having a great New Year!

I have a jabsco manual pump toilet. I Bought a new pump assembly and installed it however i reused the old weighed flap valve at the bottom of the pump (not The Joker valve, but rather the flap valve)

I installed it and everything has been working great. Except recently something weird happened - It would pump water in but not pump the bowl out. When I was pumping with the lever on the "empty" selection there was very little resistance.

Then on "empty" it changed from no resistance to an easy upstroke and blocked downstroke. Not like a blocked vent, but rather a hydrolocked pump. I didn't try to force it because it felt like surely it would break if I did. Eventually, it started sorta working again - but only if I push the pump back in slowly - if I press the pump handle in quickly, it binds again.

Do you think it's that old flap valve?
What parts should I start checking here?
sv_isara is offline   Reply With Quote
Old 06-01-2023, 09:11   #2
Registered User

Join Date: Mar 2021
Location: Flagler County, FL, USA, Earth
Boat: Lagoon 380
Posts: 1,514
Re: Jabsco manual pump issue

make sure its not trying to empty into a closed seacock. I dont think its relevant, but why reused the weighted flapper? I just replaced both my pumps, fyi.
team karst is offline   Reply With Quote
Old 06-01-2023, 09:32   #3
Registered User
 
Kelkara's Avatar

Join Date: Oct 2016
Location: Vancouver Island
Boat: Hullmaster 27
Posts: 1,061
Re: Jabsco manual pump issue

My pump sucked in some seaweed once, and did something very similar ... easy to clean by disassembling the pump again.
Kelkara is offline   Reply With Quote
Old 06-01-2023, 09:37   #4
Registered User

Join Date: Nov 2014
Location: Falmouth, UK
Posts: 252
Re: Jabsco manual pump issue

I recently had a similar issue - it was something blocking/obstructing the seawater intake. To unblock it I removed the seawater pipe from the pump and fitted it were the outlet pipe goes, hence forcing water in reverse through the intake. It took a few pumps, but then cleared itself.
wiekeith is offline   Reply With Quote
Old 06-01-2023, 12:43   #5
Marine Service Provider
 
peghall's Avatar

Join Date: Feb 2011
Posts: 3,039
Re: Jabsco manual pump issue

Why did you choose to replace the new flapper valve that was in the toilet pump with an old worn one? It's most likely getting "hung up." So the first thing to check--and replaced with the new one.

There is another possibility that's kinda common in Jabsco manual toilets, even new ones: a failed wet/dry cam. The wet/dry "valve" is actually just a little "gate" (the cam) that the lever swings to block or unblock the flow of incoming flush water. Due to either a tooling or mfr'g flaw, it hangs up...creating back pressure that feels like pumping against a clog or blocked tank vent, except it only happens in one mode--usually the wet mode.

The cure: replace the wet/dry cam assembly.
Jabsco often sends out a new one for no charge...but then you have to take the pump apart to replace it, which can be a PITA and really messy because you can't flush water through the pump to clean it out before you take it apart.

So my advice: If replacing the worn flapper valve with the new one doesn't cure the problem, replace the pump again. If it's still under warranty, return it (AFTER you replace the worn out flapper with the new one!) for an exchange.

--Peggie
__________________
2024 Peggie Hall
Specializing in marine sanitation since '87.
Author "The NEW Get Rid of Boat Odors"
peghall is offline   Reply With Quote
Old 06-01-2023, 19:24   #6
Registered User
 
sv_isara's Avatar

Join Date: Jan 2020
Location: Cruising Pacific Mexico
Boat: Hunter Legend 40.5
Posts: 151
Re: Jabsco manual pump issue

Quote:
Originally Posted by wiekeith View Post
I recently had a similar issue - it was something blocking/obstructing the seawater intake. To unblock it I removed the seawater pipe from the pump and fitted it were the outlet pipe goes, hence forcing water in reverse through the intake. It took a few pumps, but then cleared itself.
This is ONLY happening on 'dry' mode, but maybe something still got sucked into the seawater intake.

I temporarily lost the new flap valve, but i found it so i will (sigh) open this sh** up again.
__________________
Our sailing videos
formerly sv_sharky
...working to make the dream happen
sv_isara is offline   Reply With Quote
Old 07-01-2023, 09:12   #7
Marine Service Provider
 
peghall's Avatar

Join Date: Feb 2011
Posts: 3,039
Re: Jabsco manual pump issue

The major advantage to replacing a Jabsco manual toilet pump instead of rebuilding it is, it only requires removing and replacing 2 hoses and 4 bolts...no need to open up the pump. So You shouldn't have opened it up in the first place...unless it was an attempt to solve the problem you're having with it. That it didn't work is a pretty strong indication that the problem is a failed wet/dry cam assembly.


Paul Campagna is Jabsco's toilet guru. I suggest you give him a call before doing anything else. His direct line is 978.282.5246


--Peggie
__________________
2024 Peggie Hall
Specializing in marine sanitation since '87.
Author "The NEW Get Rid of Boat Odors"
peghall is offline   Reply With Quote
Old 08-01-2023, 09:37   #8
Registered User

Join Date: May 2021
Posts: 185
Re: Jabsco manual pump issue

Quote:
Originally Posted by team karst View Post
make sure its not trying to empty into a closed seacock. I dont think its relevant, but why reused the weighted flapper? I just replaced both my pumps, fyi.
This could be the switch lever at the top you have to make sure it is all the way one way or the other
c.K. is offline   Reply With Quote
Reply

Tags
jabsco, pump

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thinking about swapping Jabsco Electric Conversion Pump too a manual pump YES / NO ? Al B Plumbing Systems and Fixtures 20 26-01-2023 12:22
Jabsco conversion pump on head issue ? Al B Monohull Sailboats 0 12-07-2019 02:49
Jabsco toilet leaking from manual pump shaft sailor Martin Plumbing Systems and Fixtures 14 18-11-2018 21:01
Shaft seal in a Jabsco manual pump head Aussie_Sequoia Plumbing Systems and Fixtures 7 11-04-2014 07:21
Old Jabsco Manual Head Pump Assembly Replacement gpeacock Plumbing Systems and Fixtures 2 26-04-2010 10:42

Advertise Here


All times are GMT -7. The time now is 14:19.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.