Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-09-2013, 07:02   #1
Registered User
 
sailcruiser's Avatar

Join Date: Aug 2011
Boat: S2 11.0A 36'
Posts: 763
Diagnose Jabsco 37010 compact motor?

Press the 'flush' button and hear an audible click and nothing more. This is a raw water flush head.

Is this a motor failure? Could something be jammed?

This head has been a project the last several days. It has a new base as of yesterday but the motor only was unscrewed and replaced. Wiring looks ok and not popping a breaker. I'm not one to think coincidences. It did flush last night and died after a liquid only little (appropriate) toilet paper use.

It reminds me of starting a car with a dead battery. (Batteries are full)

This is my first electric head so learning as I go. What say you plumbing wizards? No idea on the age of the existing motor.

SC
sailcruiser is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertise Here


All times are GMT -7. The time now is 21:29.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.