Cruisers Forum
 


Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-01-2021, 20:44   #1
Registered User
 
Privilege's Avatar

Join Date: Oct 2009
Location: Bermuda
Boat: Privilege 435
Posts: 576
Images: 12
Clarke pump on Spectra water maker not ‘thumping’.

I’m trying to help a friend diagnose why his Spectra 340 water maker has stopped working. The initial supply pump which lifts the raw water up to the pump module appears to working OK. The high pressure pump inside the pump module is making a humming noise but nothing like the noise my pumps make on my Cape Horn system. In turn, the Clarke pump isn’t operating properly and only gives a half-hearted whimper thump every 30 seconds or so. My best guess is that the high pressure pump is faulty and not supplying the Clarke pump with enough pressured water...but it’s only an educated guess.
I’d welcome any input.
Privilege is offline   Reply With Quote
Old 11-01-2021, 06:09   #2
Sponsoring Vendor
 
Tellie's Avatar

Community Sponsor

Join Date: Oct 2007
Location: Hollywood, Fl.
Boat: FP Athena 38' Poerava
Posts: 3,579
Re: Clarke pump on Spectra water maker not ‘thumping’.

Is this a 340Catalina model Spectra? You would first need to do a flow test of the brine discharge water. The flow should be around 2.3 gpm. It is rare a feed pump reduces it's pressures and flow on this model. The feed pump usually either works or it does not. I would also suspect the Clark pump needs to be looked at as well.
Tellie is offline   Reply With Quote
Old 11-01-2021, 12:12   #3
Registered User
 
Privilege's Avatar

Join Date: Oct 2009
Location: Bermuda
Boat: Privilege 435
Posts: 576
Images: 12
Re: Clarke pump on Spectra water maker not ‘thumping’.

Thank you Tellie. I appreciate it.
Privilege is offline   Reply With Quote
Old 12-01-2021, 03:40   #4
Sponsoring Vendor
 
Tellie's Avatar

Community Sponsor

Join Date: Oct 2007
Location: Hollywood, Fl.
Boat: FP Athena 38' Poerava
Posts: 3,579
Re: Clarke pump on Spectra water maker not ‘thumping’.

Quote:
Originally Posted by Privilege View Post
Thank you Tellie. I appreciate it.



No problem. If you need any help just let me know and we can discuss it here on the forum so others might benefit.
Tellie is offline   Reply With Quote
Reply

Tags
pump, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KM35P Transmission is thumping in low gear bchbum1972 Propellers & Drive Systems 2 19-04-2020 19:36
Clarke Pump Ssas5342 Plumbing Systems and Fixtures 8 09-01-2020 07:06
Thumping noise from shaft hlev00 Engines and Propulsion Systems 15 02-02-2019 11:17
Spectra Ventura 150 Clarke Pump Leak Query Insight Plumbing Systems and Fixtures 9 14-08-2017 05:28
Want To Buy: Spectra Newport 400 mk11 Clarke pump Overlord Classifieds Archive 1 02-02-2015 13:16

Advertise Here


All times are GMT -7. The time now is 21:48.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.