Cruisers Forum
 


Join CruisersForum Today

Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on Cruisers Forums. Advertise Here
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-07-2017, 20:06   #1
Registered User
 
fstarocka's Avatar

Join Date: Aug 2014
Location: Long Beach, CA
Posts: 121
Alpha 1 Gen 2 upper gear seal question

Hi all - sorry to ask a seemingly basic question but cant get a good idea from the merc manual on what exactly to do -

Got a kit and helped some1 install new seals - we couldnt exactly figure out where seals go and what direction -

When we took it apart there were 2 seals in the upper drive that we took out from the top - nothing from the bottom.

In the kit were 2 matching seals and also one thicker one that was about 3/4 the thickness of the other 2 combined.

We put in the two matching ones from the kit, one with the lip/spring facing down toward the lower housing, and the 2nd one with the lip/seal facing up toward the upper square cap with the 4 bolts.

I used permatex form a gasket #1 (hard setting/fast drying) on the seals and put everything back together. After about an hour and a half in the hot Socal weather I did a low psi test of 2, and then later a 4 psi test and the whole unit held up perfect.

Anyway - I want to know if we made a mistake along the way? Got conflicting info online where one posted said BOTH lips have to face upwards


I thought we had to install one seal from the bottom, or is that earlier models? And did we just happen to get an extra seal (thicker one - what models does the thicker one go on?)

thanks!
fstarocka is offline   Reply With Quote
Reply

Tags
gear

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raritan PHII shaft seal doesn't (seal) skipgundlach Plumbing Systems and Fixtures 0 14-03-2016 10:18
LasDrop Gen 2 shaft seal? whiteapeman Propellers & Drive Systems 7 29-01-2016 07:37
Shaft Seal - PSS or Tides Marine Lip Seal ? Lennie Construction, Maintenance & Refit 40 13-08-2015 09:36
LasDrop Gen II shaft seal sailorboy1 Propellers & Drive Systems 10 09-07-2013 05:15
Rub Rails: To Seal or Not to Seal ? rognvald Construction, Maintenance & Refit 3 12-11-2011 16:13

Advertise Here


All times are GMT -7. The time now is 01:59.


Google+
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Social Knowledge Networks
Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

ShowCase vBulletin Plugins by Drive Thru Online, Inc.