Cruisers & Sailing Forums (http://www.cruisersforum.com/forums/)
-   Marine Electronics (http://www.cruisersforum.com/forums/f13/)
-   -   Raymarine RD424 and E80 display (http://www.cruisersforum.com/forums/f13/raymarine-rd424-and-e80-display-74569.html)

CHM 11-01-2012 04:15

Raymarine RD424 and E80 display
 
I have purchased the above equipment to upgrade electronics on my boat. I purchased the radar used on Ebay and it arrived with the 8 pin connector missing from the cable. I finally received a replacement yesterday and connected everything to bench test the unit with my E80. The scanner did not work! The display would flicker and reset in a loop. I reviewed everything in terms of connections. The power leads are straightforward. The 8 wires to the connector are also relatively simple with the user's guide showing where each wire goes in the connector. At first, I thought I had a bad conncetion, but I know that is not the case today. So, I have narrowed it down to the scanner or my power supply. I have been using a 1.5 amp trickle charger as a 12V power supply. This works just fine for the E80 display, but perhaps there is not enough power for the radar scanner? The scanner should pull 10 watts in standby and 34 watts active. The charger should be putting out 18 watts? My next step will be connecting the display to a 10 amp circuit and a battery. Any thoughts from the experts? I need to resolve this ASAP as returning this scanner will not be an easy feat through Ebay/paypal. I hope resolve this today. THANKS!!!

River Cruiser 11-01-2012 10:34

Try using a battery for your power source. Car batter + jumper cables, good luck

CHM 12-01-2012 02:24

I used a battery as a power supply and the scanner checked out just fine. Thanks. Now on to the next project...


All times are GMT -7. The time now is 12:14.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.


ShowCase vBulletin Plugins by Drive Thru Online, Inc.