Cruisers & Sailing Forums (http://www.cruisersforum.com/forums/)
-   Plumbing Systems and Fixtures (http://www.cruisersforum.com/forums/f115/)
-   -   Seawater Output-Recommissioning a Sea Recovery Ultra 200 (http://www.cruisersforum.com/forums/f115/seawater-output-recommissioning-a-sea-recovery-ultra-200-a-198332.html)

dworkman 05-03-2018 11:19

Seawater Output-Recommissioning a Sea Recovery Ultra 200
 
Our boat came with a Sea Recovery Ultra Whisper 200 on board when we purchased in Oct 2016. I pickled it in March 2017 with Sea Recovery chemicals per their manual. It was working when I did this.

I have been trying to re-commission and learn about this system. Iíve realized from past postings that the Sea Recovery units arenít high on anyoneís list, but since it came with the boat, I am hopeful I can get it back up and running. The unit is tagged as 2012.

When I start the unit. None of the gauges register anything, and all of the feed water appears to be flowing out the brine/waste discharge. I pulled the outlet hose off the membrane vessel and all that seems to be coming out of the membrane is salt water. This would seem to indicate the membrane has a significant hole in it allowing sea water through and therefore not building pressure anywhere in the system. Does this make sense? Is it possible the seals are shot and not the membrane?

What would be recommended to confirm the membrane is shot? Looks like a membrane is about $500 for this unit. Any changes I should make at this juncture knowing we are heading out for an extended cruise?

Appreciate the advice and help.

Bleemus 06-03-2018 05:52

Re: Seawater Output-Recommissioning a Sea Recovery Ultra 200
 
You turn the black knob located between the gauges to build the pressure if I remember correctly.


All times are GMT -7. The time now is 22:32.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.


ShowCase vBulletin Plugins by Drive Thru Online, Inc.