Cruisers & Sailing Forums (http://www.cruisersforum.com/forums/)
-   OpenCPN (http://www.cruisersforum.com/forums/f134/)
-   -   ubuntu 15.10 wily (http://www.cruisersforum.com/forums/f134/ubuntu-15-10-wily-155342.html)

Screwdiver 28-10-2015 13:38

ubuntu 15.10 wily
 
just to keep you informed: opencpn with ppa:opencpn/opencpn will not start after dist-upgrade to wily.

Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).

We all appreciate your work

nohal 28-10-2015 14:02

Re: ubuntu 15.10 wily
 
Screwdriver...
Ubuntu 15.10 changes the toolchain so we can't just copy the 4.0.0 packages to it. For now, you can use the 4.1 beta packages from https://launchpad.net/~nohal/+archive/opencpn
I will eventually backport the patches needed to compile with GCC5 to the 4.0 codebase and re-release 4.0 for Wily, but a) can't promise any date and b) the result is far from guaranteed to be more stable than the current beta.

Pavel


All times are GMT -7. The time now is 10:36.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.


ShowCase vBulletin Plugins by Drive Thru Online, Inc.