Cruisers & Sailing Forums (http://www.cruisersforum.com/forums/)
-   Electrical: Batteries, Generators & Solar (http://www.cruisersforum.com/forums/f14/)
-   -   Westerbeke BCG 5.0 3 cylinder gasoline problem (http://www.cruisersforum.com/forums/f14/westerbeke-bcg-5-0-3-cylinder-gasoline-problem-150213.html)

peterdev 28-07-2015 11:34

Westerbeke BCG 5.0 3 cylinder gasoline problem
 
I have a Westerbeke BCG 5.0 gasoline generator that suddenly stopped running. It was running perfectly one day, and the next it would not start.

I checked the oil pressure transducer as well as the water temp and exhaust temp sender units and they seem to be operating correctly.

Checked the fuel filter and it is clean, and the fuel pump is working.

I also put in new spark plugs as the old ones were as black as I have ever seen plugs and the gaps had burned wide. Checked for spark on the new plugs and spark is strong.

I have now also removed all electrical loads from the generator.

The engine now cranks but does not start. If I hold the choke open (Normal start position is choke closed) it runs slowly but does not pick up rpm and then stalls.

I looked at the new plugs and they are now also very black indicating a way too rich mixture.

Has anyone experienced this with a Westerbeke, or does anyone have any suggestions?

This is the manual for the unit I have:

http://www.westerbeke.com/operator's..._operators.pdf


Thanks in advance for your kind help.


All times are GMT -7. The time now is 05:12.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.


ShowCase vBulletin Plugins by Drive Thru Online, Inc.